[HowTo] Increase your chances of solving your issue

Difficulty: ★☆☆☆☆

Strong of its many members, the Manjaro support forum can provide you help whenever you have an issue with your Manjaro installation. But in order to work efficiently, we shall also ask you to follow three major steps.

Keep calm and read

First some basics: whenever you need to troubleshoot, chances are the solution is already under your nose.

Find error messages

Very often when an applications crashes, and sometimes when it misbehaves, it prints an error message somewhere.

  • If the message appears on screen, like in a popup or in the terminal, do read it. In most cases, it hints at what goes wrong (a missing file, a wrong configuration, a corrupted input…) if it doesn’t outright tells the solution (add a missing argument, install a missing dependency, start a service…).
  • If no such message appears, there are still ways to look for one.
    • Restart the application from the terminal. In many cases an error will be printed there when reproducing the issue.
    • Check the system journals. This is often required when the issue comes from the system itself, or when the application runs as a daemon and thus cannot be restarted.

Read the relevant documentation

Documentation related to the application often detail its processing logic, or even lists common issues with solutions and workarounds. A few places that you can check first are:

  • its manual and help pages, when available
man <my_app>
<my_app> --help

Look for similar issues

Chances are you are not the only one with the issue you are experiencing. Searching online for such occurrences may also bring you to a solution or workaround.

  • The second post in each update announcement lists known issues related to that update, usually with solutions or workarounds.
  • This forum does have a search feature, so does the Arch forum.
  • Upstream, Arch package maintainers have a bug tracker for known issues to be fixed/followed.
  • More upstream, most developers also have a bug tracker, moreover when they use Github or Gitlab for publishing their applications.
  • There are many online communities where issues may be shared. The issue could also occur in other distributions. In order to find all of those, use your favorite web search service.

:star2: If those steps allowed you to solve your issue at this point, congratulations! You managed to troubleshoot your issue by yourself!

Ask and you may be helped

As the official Manjaro forum, this is a good place to ask for support for your issue. But things can speed up if you take some steps.

Narrow to the relevant category

Many members here are knowledgeable, but not always about the same things. In order to solicit the right people, you can:

  • Create your support thread in the associated sub-category.
    If you don’t know where to post, you can leave it in the main category, and a moderator may move it to the relevant one. Don’t abuse them though!
  • Add tags to your thread, relating to the problematic application and/or your user context (architecture, desktop environment, hardware brand…).

Entice others to help you

This may seem like a weird think to ask, but the point here is to avoid rebuking members from helping because of your manners.

  • Create one thread per issue.
    Mixing several issues in a single thread makes support more difficult, as it would require to always contextualize which issue a reply is for.

  • Avoid broad titles, use it to summarize your issue.

    • :x: “I need help!”
    • :white_check_mark: “After updating, my system is stuck to black screen on boot”
  • Do not put details in the title, leave them in the main post, where you can also format them.

    • :x: “I can’t boot since update. I have Nvidia card and Intel GPU. Please help!”
    • :white_check_mark: “I can’t boot since update”
  • Do not write as you would in an instant messenger. Use punctuation and paragraphs, check your grammar.

    • :x: “so dis monin i dl the update after i cant boot at all what do i do”
    • :white_check_mark: “So this morning, i downloaded the update, and afterwards i can’t boot.
      What do i do?”
  • Do not rant.
    It’s easy to blame Manjaro and/or its community for your issue. But that does not make you any closer from finding why that issue happens in the first place, and thus neither are you from resolving it.

    • :x: “Garbage Manjaro doesn’t let me change my wallpaper”
    • :white_check_mark: “I can’t change my wallpaper”
  • Do your best to be understood.
    When someone questions your description, it usually means you didn’t use the right words. Sometimes it is worth using more words to correctly explain yourself.

    • :x: “The screen doesn’t show fresh when i open from the taskbar.”
    • :white_check_mark: “The window doesn’t refresh itself when i select it in the taskbar.”
  • Provide context information, including error messages and system information.
    Sometimes the issue is specific to some software/hardware configuration. Information from system commands is usually preferred, as it exposes intel it actually uses.

    • :x: “There is an error. I have an Intel cpu and a Nvidia gpu.”
    • :white_check_mark: "The application starts with the error “Unreachable service, dump core”.
System:
  Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=71bd23f7-486c-40be-9340-bb3466e941d1 rw quiet udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
...

"

  • Avoid using screenshots of text outputs.
    It is largely preferred to post text outputs as preformatted text (</>), so your helpers can directly use them, and may help other users in need to find your thread.

  • List what you already tried, with links to relevant sources whenever possible.

    • :x: “I tried everything but nothing worked.”
    • :white_check_mark: “I followed this guide and this solution, but they didn’t work.”
  • Don’t be impatient.
    This support forum is not a hotline that guarantees a 5-minute answer, but a community forum where members voluntarily help when that have the time and knowledge.

  • Don’t pick the wrong fight.
    No need to lose your temper from other people’s remarks and interrogations, even if they seem “noobish” or irrelevant.
    This forum has rules, which apply equally to newcomers and veterans. If you deem a moderator needs to intervene, flag the infringing post and keep on resolving your issue.

Knowledge is power

Asking for support does not mean someone else will take full control of the matter for you. In order for the solution to come, and afterwards to stay, there are some things you still need to do.

Keep searching

The community may be knowledgeable, but we don’t know everything. Sometimes nobody can timely provide a definitive solution to your issue, so it is important you keep looking for answers on your side.

Have the will to learn

Contrarily to systems that magically solve anything for you, or others that change slowly enough to avoid most troubles, Manjaro is a cutting-edge distribution which, despite regularly holding updates to provide an as smooth experience as possible, still stays very close to upstream and the changes they bring. As such, it is important for you to at least learn why issues arise.
We certainly do not ask you to learn how to debug application code nor to build a kernel, but simply knowing the overall logic behind some processes.

Highlight the solution

If someone does provide a solution to your thread, please mark it so. This way, other users sharing your issue will instantly know what to do. This will also show the thread as resolved when browsing and searching.
Solution

Share

As you may find solutions or knowledge by yourself, we would be very grateful if you contribute in return, sharing your findings – even for your own issues! – and maybe becoming a helper yourself on the long run. :wink:

18 Likes
Cannot run Manjaro Live from USB
Can not update OS update in package manager
Manjaro collapse
The Issue : Failed Remount Root and Kernel File Systems
No hardware accelerated video playback on Intel Iris 6100 (Macbook Pro 2015)
Bluetooth not working: not default controller available
Kodi locking up on opening
Video not working in all browser
Cups reports conflicts where there are none
Find the processes making a window
Frequent crashing when booting/Crashing when opening any programs
Fix of Xorg regression not working
SDDM / login scaling broken after 2022-01-02 update
Corrupt filesystems
Wol feature interrupt by adding manjaro system to the boot sequence
Newbie - MIcrophone and Bluetooth not working
New Manjaro install not booting (only black screen and silence) from grub2
[How to] Help a new forum member solve problems
Xfce4 startx doesn't work, while startxfce4 does work
The manjaro-sway iso is mostly unresponsive on my ThinkPad E540. Should it work better?
Disable networking on user inactivity
Mailspring mail client error
Where do I start - it all seems difficult to learn
Usb Mouse and Keyboard not working after Shutdown and Restart
Manjaro Version, Start Printer and Run Unclutter
Start Menu search broke after a reinstall of x11
Lenovo Yoga 7-15ITL5 Audio Not Working- Manjaro
KDE wayland boot not working
Advice of how to proceed with my current dual booting set up
Grub loaded from but then not detecting external SDD on X260
Inkscape crashing immediately after launch
WIFI reconnects after 5-30mins and I need to type in the password again
Can’t connect from MacBook to Netatalk service
[Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice
Random crashes after installing RX6600
Optimus manager doesn't work after upgrade
VS CODE installation
Manjaro cant start apps
How to remove ROOT user?
Manjaro KDE Plasma
Missing menu entries for settings after upgrading to Manjaro Qonos
X wouldn’t start properly after upgrade
Cannot turn on bluetooth
[Solved] Trying to modify /etc/fstab getting save error
Stuck on loop with blinking cursor after update
Manjaro Xfce linux
Moving linux to new drive and grub issue
Manjaro XFCE freezes when booting from USB
5.17 rc1 is screwed up
Some problems with fresh Manjaro XFCE install on 2nd gen Intel laptop
The system cannot find any bootable devices
MicroSD Card Reader Not Working
Snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to polling mode
Cannot change any Gnome Extension settings
Zsh changed overnight
Screen is black. Can't even access grub
Windows replacement linux distro for an old laptop
Swap Audio Channels permanently
Not booting without connected (hdmi) display
Replaced ChromeOS with Manjaro Gnome on Pixelbook 2015 No sound
Cinnamon Themes / Window-frame Mint-Y-dark not available since Dec. 21 Update
"Failed to Start Bluetooth Management Mechanism" shows up during boot up
Problems with booting Manjaro after updating
Issues with installing Manjaro Linux on my Hard Drive
How to get audio in Hyper-V?
Can't update due to gtk3-classic breaking dependency
Pc not booting [input not supported]
About the Support category
BBC Microbit - not mounting
Davinci Resolve Nothing Displays
Custom cursors dont work as expected
Frozen laptop screen
Missing window border on some flatpak apps
My Bluetooth is not working
Connecting my second monitor causes my desktop to crash
Headset is not forwarded to a Citrix session
Bluetooth Problem While Connecting an Audio Device
Mpris-proxy - anyone else it stopped working recently?
Unity only recognize VSCODE from Flatpak
Fonts not rendering
My computer won't boot up and will go to a black screen
Just now installed Manjaro gnome but no sound at all
5.15.12 suspend issues
Manjaro Neuinstallation - wie vorgehen?
Matray error on fetching news
Manual grub.cfg: It seems that the mirror of manjaro cannot be booted on the ntfs file system
Request help getting Belkin USB bluetooth adaptor working
GPU: AMD ATI Radeon HD 7750/8740
Realtime Kernel 5.15.7-1-rt23 and missing effivarfs/efibootmgr
Unable to boot to desktop after update from kernel 513 - kernel 515
Disabled all extensions after change Wayland to x11
Suckless patching, static variable in .h file error (C)
Wireless WiFi not working Manjaro KDE
Which program manages the GUI for logging in (including picking a desktop environment)? Where and when is the $PATH environment variable set?
Pantheon lockscreen+mouse&touchpad plug + system-tray
No password prompt asked, hence tasks like installing kernels, editing user profiles fail
My laptop is not connected to the power, bluetooth can not use, in windows10 without this problem
Can't access a bunch of sites
Desktop destroyed
Pixelated font issue on Manjaro-GNOME
After screen change graphic is displayed on wrong monitor
Install spotify with Aur
Touch pad on my old laptop is unusable
Latest libwacom 2.0.0 makes input devices unresposive
How to open a file on gdrive directly instead copy it to cache folder
Switching from integrated to dedicated gpu
Wlr_renderer=vulkan
Bluetooth connectivity issues in display manager with XFCE and KDE
Write issue with mounted drive
Linux, Grub, Uefi dont't see SSD
Xmodmap user configuration freezes Pc when Bluetooth device is Connected
Not booting, partition corrupt
The file path cannot be selected when running VBox. The terminal prompts as above
Moving Image to trash on digikam
Dual monitor display port no signal after logging in
Bluetooth Device not working just keep "SCANNING"
Manjaro XFCE doesn't boot everytime
Kernel updates keep breaking nvidia driver
WiFi Verbindung wird plötzlich extrem langsam / Neuverbinden hilft kurzzeitig
Strange systemd failed boot up messages
Sound Issue - Dummy Output
Window Compositor always turning off after reboot
System only shows _ and won't boot up
Can’t log in after changing SDDM
KDE Plasma desktop configuration resets after update
Screen got frozen, display 0 and 1, what happened
Gnome doesn't load when HDMI Monitor is connected
I3wm &/or xorg does not work after rebooting from having too many windows open
Erratic plasma desktop startup (desktop area black and unresponsive, panel works)
Resolution of external monitor gets reset once everytime after I switch it off and on
"No default controller available" when troubleshooting Bluetooth
New user, stuck in bios after trying to install Nvidia drivers
All Gnome extensions disabled after reboot since update
GPGME error: No data failed to synchronize all databases (invalid or corrupted database (PGP signature))
Could not connect to mobile hotspot, hotspot is not showing in menu
Manjaro deepin: cannot shutdown when empty passwords
Freeze when I change desktop
Grub broken after Windows 10 reinstallation. Which disk to fix grub on?
Add global menu
Printer Canon iP-1980 isn't working
Don't see app icons install with AUR
Is there a configuration file I need to fix or do I need a new monitor?
[HowTo] Provide System Information
Manjaro suspend doesn't save my current session and other unstability issues
USB sound device not detected
Problems with GRUB Bootloader
Laptop not suspend after closing lid at low power
Video.allow_duplicates=1 where to enter
Automouting nfs using systemd - dolphin is erratic
Not detecting my other 2 displays on my integrated graphics
Boot into a static Black Screen Upon a Fresh Install (Gnome Edition)
Cannot connect to Wired connection. Only wireless
Cursor disappears in fullscreen applications
Change display names in gnome wayland
Install grub manually
Can't boot past Manjaro splash screen
What is the difference between wine versions?
2 drivers was installed now I can't boot

Ca me rappelle les “RTFM” en réponse que je recevais à mes débuts dans les années 2000, demander de l’aide c’est bien et légitime mais en dernier recours en gros…oui ok mais quand on boot sur un écran noir demander de l’aide en premier recours c’est bien aussi, tout dépend de l’importance du cas en fait

2 Likes

Oui c’est légitime, mais l’idée est que bien souvent, la solution existe déjà, même pour des problèmes graves. :wink:

Après, je pense que dans la plupart des cas, quand la solution est déjà documentée, on continuera de simplement l’y lier. Si on lie ce tutoriel, c’est que l’utilisateur ne s’est vraiment pas foulé…

It is not that much comfortable to search from mobile device (also note that mobile internet connection may be not perfect to open many tabs in try to find solution for exact case) when you can’t boot your system and have no LiveCD to boot up from, so the importance is also a factor here.


Now this topic deserves to be linked to a user’s “please help”-described topics instead of “provide good information” thread as it is more general and links to “provide good info” thread also.

I think it is great defragmentation, consolidation, organization work done here to start to solve problems as by themselves and by providing well-described topics.
Thank you for [How to].
May be to made it to be wiki-post?


Further improvement ideas:

  1. (may be separate topic, which will be linked here): how to search a solution for the problem a user met.
  2. to post the problem description and solution which works for a user to make others to be able to find it.

PS

True. It is not the simplest work to search, find, several times to try and to finally solve a problem.

2 Likes

May be we can pin this thread in sub-category instead of “How to provide good information” or along side with it?
Can’t find that option from within my user account.