[Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice

Hmm … doesn’t work well with my custom configuration but Manjaro default seems to be good now.

On my first reboot after updating WiFi was not working at all, strangely one more reboot and all started working again.

What I did noticed is that I now get a kernel fault:

 4.304771] BUG: kernel NULL pointer dereference, address: 0000000000000000
[    4.304779] #PF: supervisor instruction fetch in kernel mode
[    4.304781] #PF: error_code(0x0010) - not-present page
[    4.304784] PGD 0 P4D 0 
[    4.304788] Oops: 0010 [#1] PREEMPT SMP NOPTI
[    4.304792] CPU: 0 PID: 1268 Comm: tpacpi-bat Tainted: G           OE     5.15.7-1-MANJARO #1 89d91431fe07b9fd339e5f86d7a009210c48fcc6
[    4.304797] Hardware name: LENOVO 20Y7CTO1WW/20Y7CTO1WW, BIOS R1OET28W (1.07 ) 07/15/2021
[    4.304799] RIP: 0010:0x0
[    4.304807] Code: Unable to access opcode bytes at RIP 0xffffffffffffffd6.
[    4.304808] RSP: 0018:ffffbb0a898e3e68 EFLAGS: 00010246
[    4.304811] RAX: 0000000000000000 RBX: ffffa03fc82c2900 RCX: 0000000000000001
[    4.304814] RDX: 0000000000000001 RSI: 0000000000000000 RDI: ffffa03fc37eda00
[    4.304816] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
[    4.304817] R10: 0000000000000001 R11: 0000000000000000 R12: 0000000000000001
[    4.304819] R13: ffffffffffffffea R14: ffffa03fc37eda00 R15: 0000000000000000
[    4.304821] FS:  00007fe9334ab740(0000) GS:ffffa04496e00000(0000) knlGS:0000000000000000
[    4.304824] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    4.304827] CR2: ffffffffffffffd6 CR3: 000000012439a000 CR4: 0000000000350ef0
[    4.304829] Call Trace:
[    4.304832]  <TASK>
[    4.304834]  proc_reg_llseek+0x49/0x90
[    4.304841]  ? __fdget_pos+0x13/0x60
[    4.304845]  ksys_lseek+0x83/0xc0
[    4.304849]  do_syscall_64+0x5c/0x90
[    4.304854]  ? do_user_addr_fault+0x20b/0x6b0
[    4.304861]  ? exc_page_fault+0x72/0x180
[    4.304865]  entry_SYSCALL_64_after_hwframe+0x44/0xae
[    4.304870] RIP: 0033:0x7fe93374299b
[    4.304873] Code: ff ff c3 0f 1f 40 00 48 8b 15 d1 04 0d 00 f7 d8 64 89 02 48 c7 c0 ff ff ff ff eb ba 0f 1f 00 f3 0f 1e fa b8 08 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 05 c3 0f 1f 40 00 48 8b 15 a1 04 0d 00 f7 d8
[    4.304875] RSP: 002b:00007ffc6602d1d8 EFLAGS: 00000246 ORIG_RAX: 0000000000000008
[    4.304879] RAX: ffffffffffffffda RBX: 00007fe933bc7de0 RCX: 00007fe93374299b
[    4.304881] RDX: 0000000000000001 RSI: 0000000000000000 RDI: 0000000000000003
[    4.304882] RBP: 000055edcd378d70 R08: 00007ffc6602d180 R09: 00000000ffffffff
[    4.304884] R10: 00007fe933813a00 R11: 0000000000000246 R12: 000055edcd3572a0
[    4.304886] R13: 00007ffc6602d3e0 R14: 000055edcd3573e0 R15: 000055edcd42e440
[    4.304890]  </TASK>
[    4.304892] Modules linked in: xt_conntrack xt_MASQUERADE nf_conntrack_netlink nfnetlink xt_addrtype iptable_filter iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 libcrc32c br_netfilter cmac algif_hash algif_skcipher af_alg bridge stp llc bnep overlay btusb uvcvideo btrtl btbcm videobuf2_vmalloc btintel videobuf2_memops videobuf2_v4l2 bluetooth videobuf2_common videodev mc ecdh_generic joydev mousedev intel_rapl_msr intel_rapl_common think_lmi wmi_bmof firmware_attributes_class edac_mce_amd qrtr ns snd_ctl_led kvm_amd mt7921e amdgpu snd_hda_codec_realtek mt76_connac_lib kvm snd_hda_codec_generic snd_hda_codec_hdmi mt76 snd_hda_intel irqbypass snd_intel_dspcfg crct10dif_pclmul crc32_pclmul mac80211 snd_intel_sdw_acpi ghash_clmulni_intel snd_hda_codec r8169 aesni_intel libarc4 snd_hda_core vfat crypto_simd thinkpad_acpi fat realtek cryptd snd_pci_acp5x snd_hwdep rapl gpu_sched ledtrig_audio ucsi_acpi mdio_devres cfg80211 psmouse pcspkr tpm_crb snd_pcm sp5100_tco
[    4.304965]  platform_profile drm_ttm_helper snd_rn_pci_acp3x typec_ucsi snd_timer ccp libphy snd_pci_acp3x typec snd rfkill ttm k10temp i2c_piix4 roles wmi soundcore tpm_tis tpm_tis_core video tpm pinctrl_amd mac_hid acpi_cpufreq i2c_scmi rng_core squashfs acpi_call(OE) loop ipmi_devintf ipmi_msghandler crypto_user fuse ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 serio_raw atkbd libps2 i8042 crc32c_intel xhci_pci serio
[    4.305006] CR2: 0000000000000000
[    4.305009] ---[ end trace 62691aa760c569a7 ]---
[    4.305011] RIP: 0010:0x0
[    4.305014] Code: Unable to access opcode bytes at RIP 0xffffffffffffffd6.
[    4.305015] RSP: 0018:ffffbb0a898e3e68 EFLAGS: 00010246
[    4.305018] RAX: 0000000000000000 RBX: ffffa03fc82c2900 RCX: 0000000000000001
[    4.305020] RDX: 0000000000000001 RSI: 0000000000000000 RDI: ffffa03fc37eda00
[    4.305022] RBP: 0000000000000000 R08: 0000000000000000 R09: 0000000000000000
[    4.305024] R10: 0000000000000001 R11: 0000000000000000 R12: 0000000000000001
[    4.305025] R13: ffffffffffffffea R14: ffffa03fc37eda00 R15: 0000000000000000
[    4.305027] FS:  00007fe9334ab740(0000) GS:ffffa04496e00000(0000) knlGS:0000000000000000
[    4.305030] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    4.305032] CR2: ffffffffffffffd6 CR3: 000000012439a000 CR4: 0000000000350ef0

Just a minor issue with Gnome extension Dash to Dock:
When I switch off the button “Angepasstes Thema dieser Erweiterung nutzen”, all icons in the dock are gone. The dock is empty no matter what options I set in the area below that button.

1 Like

I am still experiecing this problem with the screen set to blank out but after attempting to wake up the screen, I just get a blank screen until I type my password and the login prompt appears so I have to login again.

I changed light-locker to dm-tool to unlock it and I still encounter the same issue with this update. I think its similar to this:

Thanks its worked (:slight_smile:

This is little info to offer any help, could you make a new post in #support , keeping in mind these two post below on how to provide system information and increase the chances to solve the issue you are experiencing.

If the info in your profile is still correct please upgrade to a supported version of the kernel, 5.9 is no longer maintained.

Bluetooth has stopped working on Manjaro Gnome after this update. Running on a ThinkPad T14s Intel model. The Gnome Bluetooth settings panel shows Bluetooth as being turned off and I’m unable to move the toggle switch in the settings panel to the “on” position.

UPDATE:

I was able to (partially) resolve the issue. It is, perhaps, related to this issue reported as an upstream bug on the Ubuntu ticketing system. At any rate, the kludge discussed by this commenter there worked for me: Rebooting the laptop while plugged into power, opening the Gnome Bluetooth settings panel, disconnecting the power, and then toggling on Bluetooth in the settings panel. This is obviously not ideal, especially if the issue recurs, so I look forward to some kind of better resolution down the line.

1 Like

@thewhat Possibly a more permanent fix: it looks as though my default application for html/text files somehow ended up as winebrowser. Definitely not a choice I made so I’m not sure how it got set that way, but System Settings > Applications > text > html and then move winebrowser below Firefox or your default browser of choice.

3 Likes

yeah i remove it from there. i think its a problem happend in env paths bcz i already installed wine

Update to my own post:
the problem is the option Enable Unity7 like glossy backlit items under Customize windows counter indicators. When this option is set to on, the items in the dash have a glossy background. But when the extension is switched off and on again, the items in the dock are gone.

I verified it with another laptop that was not updated yet: this behaviour has not changed in the last update!

Sorry for any inconvenience

1 Like

Problems in computers with opensource video drivers are solved like so:
sudo pacman -Rd --nodep gdm
sudo pacman -S gdm
With proprietary drivers, I have not found a solution ???

Thank you for the great work! Can you please add a status flag to each issue? It may help users to know if any particular issue concerned is resolved.

After the update, optimus-manager (v 1.4-2 from official repository) completely stop working.

Error loading config file : Cannot find header for section [optimus]

I install the aur version (v 1.4-3) and it’s solves the problem.

yay -Sa optimus-manager

(Don’t forget the “a” or yay will install the old v 1.4-2 from official repository,
and I think it was python 3.9 to python 3.10 who break optimus manager.)

Otherwise everything else work fine. Thanks for all the updates :heart: !

4 Likes

Fix coming with 1.4-3 soon.

1 Like

I had this warning:

Installing graphviz (2.50.0-1)...                                        [53/81]
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.

ldd /usr/lib/graphviz/libgvplugin_gdk.so.6 said that libgdk-x11-2.0.so.0 was missing.
pamac search libgdk-x11 said it belongs in package gtk2.

I have no recollection of removing gtk2, but maybe it was removed as an orphan at some time.
Nevermind, pamac install gtk2 fixed he problem.

1 Like

not sure if its related to the update but im getting this error in virtual machine manager:

Error starting domain: internal error: qemu unexpectedly closed the monitor: 2021-12-17T21:12:09.862776Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.863790Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864289Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864664Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
qxl_send_events: spice-server bug: guest stopped, ignoring
kvm_set_irq: Input/output error

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 65, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 101, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/libvirtobject.py", line 57, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/object/domain.py", line 1329, in startup
    self._backend.create()
  File "/usr/lib/python3.9/site-packages/libvirt.py", line 1353, in create
    raise libvirtError('virDomainCreate() failed')
libvirt.libvirtError: internal error: qemu unexpectedly closed the monitor: 2021-12-17T21:12:09.862776Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.863790Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864289Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
2021-12-17T21:12:09.864664Z qemu-system-x86_64: warning: host doesn't support requested feature: MSR(48DH).vmx-posted-intr [bit 7]
qxl_send_events: spice-server bug: guest stopped, ignoring
kvm_set_irq: Input/output error

A post was split to a new topic: After latest stable update my computer won’t boot

Thank you for the comments. I’ll keep it in mind next time. It seems like it works after I re-installed pulse.

Hello Yochanan,

I updated to 1.4-3, but I still got the error on optimus-manager.

dic 18 00:22:35 tesla systemd[1]: Starting Optimus Manager Commands Daemon...
dic 18 00:22:35 tesla python3[609]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla python3[671]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla systemd[1]: Started Optimus Manager Commands Daemon.
dic 18 00:22:35 tesla python3[718]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla systemd[1]: optimus-manager.service: Main process exited, code=exited, status=1/FAILURE
dic 18 00:22:35 tesla python3[762]: /usr/bin/python3: Error while finding module specification for 'optimus_manager>
dic 18 00:22:35 tesla systemd[1]: optimus-manager.service: Control process exited, code=exited, status=1/FAILURE
dic 18 00:22:35 tesla systemd[1]: optimus-manager.service: Failed with result 'exit-code'.

My package is from official repository:

community/optimus-manager 1.4-3 [installed]
    Management utility to handle GPU switching for Optimus laptops

Is it necessary reinstall package??

Thanks for your help.

2 Likes

After this update I cannot longer launch my application by hitting Super+1,Super+2,… Any suggestions how to fix it? It breaks my whole workflow.

3 Likes