Calamares fails due to error concerning the EFI

Got a new laptop and I’m trying to install manjaro on it using a USB bootable drive. having installed the ISO and booted from the USB I attempted to use the installer to overwrite the Windows 11 installation already present on the SSD. However, it almost instantly crashed and having established the location of the executable in /usr/bin/calamares/ I ran in the command line to get the error output and was given this:
15:27:12 [1]: ASSERT: “efiSectorCount > 0” in file /build/calamares/src/calamares-3.2.60/src/modules/partition/core/PartitionActions.cpp, line 123

This is not the entire output but is the only error related part, the rest of it before that is not related.

Any ideas as to what has caused this issue and how to solve it would be much appreciated.

Hi @just_george, and welcome!

If your intention is to replace Windows, which is a wonderful thing BTW., is there any specific reason you don’t just format the hard drive and re-partition it? Because it doesn’t sound like this is what you did.

Hi, so no i havent formatted the drive on the laptop bc on my main pc i dual boot to game on windows (am working on doing it on linux) but installing manjaro on that machine like i have been doing here worked fine so i didnt think to do it this time. will formatting the drive remove the issue here and then installing onto a blank drive remove the issue here?

I have absolutey NO idea whatsoever. I don’t use, or really care for Windows.

Bur since you mentioned erasing it, formatting might help, especially since you said it worked on another machine.

Also, if you didn’t re-partition and format it, the drive might still be NTFS, and that’s unsupported for booting from AFAIK.

nah the thing that worked was not formatting it, that’s why i didn’t bother this time.

Well, care to share for anyone else potentially having this problem?

I mean I did it months ago so I can’t remember what i did differently. This issue stems from something concerning EFI sectors, but i don’t know what those are or what i can change to make the assert statement not crash the program. I know what the EFI is obviously just not it’s sectors. All i did was boot from the USB and run the install program when it worked on my PC but the install program is now crashing on my laptop due to the EfiSectorCount being less than 1 (?)

Ah, I thought you meant that wasn’t the issue, you found what it was.

Seems like the efi partition was not flagged with boot,esp. Set boot flag · Issue #1046 · calamares/calamares · GitHub

thanks man that looks solid, out of interest, is it usually preferred to get the error output and post it with the question when trying to tackle problems like this?

Yes. The more information we have, the better we can help. In fact, there are several different guides here:


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

oh alright thanks. I’ve had a look at the other issue that you linked to but I’m not sure which setting I would need to change. I should point out that I’m not an expert user, so to speak. Also i can’t find the file which is referenced in that github post in order to make any changes.

Should I do a new post with all of that information?