Bluez is not running lost icon for bluetooth in the panel

I read several nice articles with bluetooth, and though I think it should not be a bit issue, but I am not able to the icon for bluetooth applet into my panel… plz help. *(I mean that icon where I can do all the works with bluetooth functions as listed like turning BT on, making it visible, etc…)
I removed a bluetooth applet form my the panel, because after my wife did something it has shifted to other panel. When I was removing the applet from panel I saw a warning comment, that by doing so “It will also remove the configuration file”. Now I cannot add the applet back *(i do not remmeber what I did to put it into panel before, or all I tried did not ended up on adding the applet icon on pnal). When I do restart I cannot run bluetooth. The bluetooth manager give me feedback message that the “bluez daemon is not running. Blueman manger cannot continue…” I think the daemon is not running I tried to reinstall bluez, install bluez-util just in case if that can help, but no change.

here are some information that might help.


(blueman-manager:5286): Gtk-WARNING **: 18:08:13.798: Locale not supported by C library.
	Using the fallback 'C' locale.

(blueman-manager:5286): Gtk-CRITICAL **: 18:08:13.984: _gtk_css_image_get_concrete_size: assertion 'default_width > 0' failed

(blueman-manager:5286): Gtk-CRITICAL **: 18:08:13.984: _gtk_css_image_get_surface: assertion 'surface_height > 0' failed

(blueman-manager:5286): Gtk-CRITICAL **: 18:08:13.984: _gtk_css_image_get_concrete_size: assertion 'default_width > 0' failed

(blueman-manager:5286): Gtk-CRITICAL **: 18:08:13.984: _gtk_css_image_get_surface: assertion 'surface_height > 0' failed
blueman-manager 18.08.14 ERROR    Manager:147 on_dbus_name_appeared: Default adapter not found, trying first available.
blueman-manager 18.08.14 ERROR    Manager:151 on_dbus_name_appeared: No adapter(s) found, exiting


rfkill list
0: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no


systemctl status bluetooth
��� bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset>
     Active: inactive (dead)
       Docs: man:bluetoothd(8)


inxi --admin --verbosity=7 --filter --no-host  --width
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_ADDRESS = "es_ES.UTF-8",
	LC_NAME = "es_ES.UTF-8",
	LC_PAPER = "es_ES.UTF-8",
	LC_TIME = "es_ES.UTF-8",
	LC_NUMERIC = "es_ES.UTF-8",
	LANG = "en_GB.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
  Kernel: 6.1.80-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=61da08ab-fc73-4a13-92d4-0405ad3b8772 rw quiet
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm4 v: 4.18.0
    with: xfce4-panel tools: light-locker vt: 7 dm: 1: LightDM v: 1.32.0 2: SDDM
    note: stopped Distro: Manjaro base: Arch Linux
  Type: Laptop System: Star Labs product: LabTop v: Mk IV
    serial: <superuser required>
  Mobo: Star Labs Online model: LabTop v: Mk IV serial: <superuser required>
    part-nu: L4 uuid: <superuser required> UEFI: American Megatrends
    v: CN1_M1.1.0 date: 10/27/2020
  ID-1: BAT0 charge: 39.2 Wh (96.6%) condition: 40.6/45.6 Wh (89.1%) volts: 8.5
    min: 7.6 model: GDPT CN6613-2S3P type: Unknown serial: <filter>
    status: not charging
  System RAM: total: 16 GiB available: 15.49 GiB used: 6.71 GiB (43.3%)
  Message: For most reliable report, use superuser + dmidecode.
  Array-1: capacity: 32 GiB slots: 2 modules: 2 EC: None
    max-module-size: 16 GiB note: est.
  Device-1: ChannelA-DIMM0 type: DDR4 detail: synchronous size: 8 GiB
    speed: 2667 MT/s volts: note: check curr: 1 min: 1 max: 1 width (bits):
    data: 64 total: 64 manufacturer: Micron part-no: 4ATF51264HZ-2G3BZ
    serial: <filter>
  Device-2: ChannelB-DIMM0 type: DDR4 detail: synchronous size: 8 GiB
    speed: 2667 MT/s volts: note: check curr: 1 min: 1 max: 1 width (bits):
    data: 64 total: 64 manufacturer: Micron part-no: 4ATF51264HZ-2G3BZ
    serial: <filter>
  Info: model: Intel Core i7-10710U bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
    model-id: 0xA6 (166) stepping: 0 microcode: 0xF8
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 428 high: 536 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 507 7: 400 8: 536 9: 400 10: 500 11: 400 12: 400 bogomips: 26407
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand
    rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer
    vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Comet Lake UHD Graphics vendor: IP3 Tech driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: HDMI-A-1 off: eDP-1 empty: DP-1,HDMI-A-2 bus-ID: 00:02.0
    chip-ID: 8086:9bca class-ID: 0300
  Device-2: Realtek USB Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-7:5 chip-ID: 0bda:3031
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 compositor: xfwm4 v: 4.18.0 driver:
    X: loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: not-matched mapped: HDMI-1 pos: primary res: 1920x1080 hz: 60
    dpi: 305 size: 160x90mm (6.3x3.54") diag: 184mm (7.23") modes: N/A
  Monitor-2: not-matched mapped: eDP-1 size-res: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 1 drv: swrast gbm: drv: iris surfaceless: drv: iris x11: drv: iris
    inactive: wayland
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
    device-ID: 8086:9bca memory: 15.12 GiB unified: yes
  API: Vulkan v: 1.3.279 layers: 1 device: 0 type: integrated-gpu name: Intel
    UHD Graphics (CML GT2) driver: mesa intel v: 24.0.2-manjaro1.1
    device-ID: 8086:9bca surfaces: xcb,xlib
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Realtek driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:02c8 class-ID: 0403
  API: ALSA v: k6.1.80-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 0.125.0 status: off tools: N/A
  Server-3: PipeWire v: 1.0.3 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 17.0 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153]
    driver: r8152 type: USB rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 1-6.4:12 chip-ID: 2357:0601 class-ID: 0000 serial: <filter>
  IF: enp0s20f0u6u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: virbr0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 447.13 GiB used: 408.06 GiB (91.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: Star Drive PCIe SSD
    size: 447.13 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: ECFM22.6 temp: 26.9 C
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 446.83 GiB size: 438.75 GiB (98.19%)
    used: 408.06 GiB (93.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 61da08ab-fc73-4a13-92d4-0405ad3b8772
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: DB6E-2564
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 4 rev: 2.1
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-4:3 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 0bda:0129 class-ID: ff00 serial: <filter>
  Hub-3: 1-6:4 info: Genesys Logic Hub ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-6.2:6 info: Elan Micro ActiveJet K-2024 Multimedia Keyboard
    type: keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 1.5 Mb/s (183 KiB/s) lanes: 1 mode: 1.0 power: 100mA
    chip-ID: 04f3:0103 class-ID: 0300
  Device-2: 1-6.3:9 info: USB OPTICAL MOUSE type: mouse,keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s (183 KiB/s)
    lanes: 1 mode: 1.0 power: 100mA chip-ID: 4e53:5407 class-ID: 0301
  Device-3: 1-6.4:12 info: TP-Link UE300 10/100/1000 LAN (ethernet mode)
    [Realtek RTL8153] type: Network driver: r8152 interfaces: 1 rev: 2.1
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 200mA
    chip-ID: 2357:0601 class-ID: 0000 serial: <filter>
  Device-4: 1-7:5 info: Realtek USB Camera type: video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0
    power: 500mA chip-ID: 0bda:3031 class-ID: 0e02 serial: <filter>
  Hub-4: 2-0:1 info: super-speed hub ports: 6 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-5: 2-2:2 info: Genesys Logic Hub ports: 4 rev: 3.1
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 05e3:0626
    class-ID: 0900
  System Temperatures: cpu: 34.0 C pch: 31.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 338 Power: uptime: 1h 35m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: shutdown
    avail: reboot,suspend,test_resume image: 6.18 GiB
    services: power-profiles-daemon, upowerd, xfce4-power-manager Init: systemd
    v: 255 default: graphical tool: systemctl
  Packages: 2457 pm: pacman pkgs: 2410 libs: 539 tools: pamac pm: flatpak
    pkgs: 19 pm: snap pkgs: 28 Compilers: clang: 16.0.6 gcc: 13.2.1 alt: 11/12
    Shell: Bash v: 5.2.26 running-in: xfce4-terminal inxi: 3.3.33

I tried also

Please format your command outputs as code → this symbol </>

systemctl status bluetooth.service

says the service is not running - start it

Then there is the bluetooth applet in the panel - maybe it is just switched off (right klick).


please try the following

sudo rfkill unblock bluetooth && sudo systemctl restart bluetooth.service

and report

There’s a clue… :wink:

Yes, please do. See [HowTo] Post command output and file content as formatted text

Your post is very hard to read with numerous spelling errors and vague descriptions. Please edit your topic title to be more clear and concise about the actual issue. Please also edit your post to use proper formatting and include system details.

Please help us help you:

I put the commands that Olli has proposed and I received following:

systemctl status bluetooth.service
��� bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

Mar 14 22:32:35 dummysock systemd[1]: Bluetooth service was skipped because of an unmet condition check (ConditionPathIsDirectory=/sys/class/bluetooth

Sorry for my formatting before. I got disrupted here in the middle of writing the support request. Hopefully it is ok now.

1 Like

The service was inactive (dead)

Now the more complete output showed a reason for that:

together with the inxi output:

It appears that your bluetooth adapter is not present.

Hardware problem?
Electrical connection issue?

Looks like it.
To me.

Thank you for feedback. I think it is something with configuration, not a hardware problem. Thought from time to time I receive bluescreen amd O have to reset the time… I did not receive it for a long time now.

It is a kind of weird with bluetooth adapter on this Star LabTop for me. For long time I was not able to use it until I learned to use it, but I found out that if I have it as an applet I t is there and works well. But there is something happen with the applet configuration file, because when I look at Session and Startup ->Program, I can see that the Blueman applet us suppose to start at the startup, but because the daemon is not running maybe it does not load the applet too. I am hopefull that it is not defective, but I am also a bit suspiciout that it might be again a broken user profile. I don’t know why, but I had in the past a broken user profile that affects only in Thunderbird the way that it allows to have only one account active after some time,(and no matter what I do I only can use one account)
I also tried :heart:


(blueman-applet:4425): Gtk-WARNING **: 23:38:14.441: Locale not supported by C library.
	Using the fallback 'C' locale.
blueman-applet 23.38.14 WARNING  PluginManager:151 __load_plugin: Not loading DhcpClient because its conflict has higher priority

Your system info,

shows … no bluetooth adapter
no hardware present, none detected

Whatever the reason:
if there is no adapter detected - bluetooth cannot possibly work

Why is it not detected?

Who knows?
I don’t.

I am convinced it has bluetooth. I saw this issue before, I was using bluetooth before too. It is built-in one, not a HW key.

You will need to convince your system that it has got bluetooth. :face_with_peeking_eye:
Right now - it is not seen.

Either it came lose - then re-seat it
or it broke - it happens.
Only you can check or know.

I’m afraid I won’t be able to provide any help on this, but to assist others here who may be able to help, I just had a look at the specs page for the device & it states that it has Bluetooth 5.1 & is compatible with the following operating systems:

Ubuntu 20.04 LTS (64-bit) or later
elementary OS 5.1.5 (64-bit) or later
Linux Mint 20 (64-bit) or later
Manjaro 20.0 (64-bit) or later
MX Linux AHS 19.2 (64-bit) or later
Zorin OS 15.2 (64-bit) or later
Windows 10 RS3 (64-bit) or later