Yet another missing mic problem

I’ve been having problems with my built in mic not being detected.

I am using a System76 Gazelle I think it’s 15th generation. Here is some of the information to start with about the hardware:

Operating System: Manjaro Linux
KDE Plasma Version: 5.23.5
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Kernel Version: 5.16.5-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 16 × Intel® Core™ i7-10870H CPU @ 2.20GHz
Memory: 62.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics

Not sure if I was dong my research correctly, but some of the things I tried is replacing PulseAudio with manjaro-pipewire. But that didn’t seem to help.

I guess the first thing is of course, is what information you need to start with.

A full inxi output as described in the following link would be of some help:

1 Like

Thank you for your input. This is going to be very helpful. While some things I can say that I have done; I have a huge amount of weak spots. One of my worst, is my lack of patience.

I have bookmark the howto’s for later use, and It has helped me. I will use a separate reply for the issue at hand.

So what drawing from what I read about system information, I have this from my terminal.

    ~  inxi --admin --verbosity=7 --filter --width                                             ✔ 
  Kernel: 5.16.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-x86_64
    root=UUID=4ab500a8-bf4b-48ee-bbef-2b6ac3011690 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: System76 product: Gazelle v: gaze15
    serial: <superuser required>
  Mobo: System76 model: Gazelle v: gaze15 serial: <superuser required>
    UEFI: INSYDE v: 1.07.11a date: 12/02/2020
  ID-1: BAT0 charge: 44.9 Wh (100.0%) condition: 44.9/48.0 Wh (93.4%)
    volts: 16.5 min: 14.4 model: Notebook BAT type: Li-ion serial: <filter>
    status: Full
  Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter>
    charge: 70% rechargeable: yes status: Discharging
  RAM: total: 62.51 GiB used: 7.99 GiB (12.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-10870H bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 2 microcode: 0xEA
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1418 high: 3502 min/max: 800/5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2405 2: 3502 3: 800
    4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 3438 12: 2527
    13: 1855 14: 971 15: 801 16: 800 bogomips: 70421
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdrand rdseed
    rdtscp rep_good sdbg sep sgx sgx_lc smap smep ss ssbd sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: CLEVO/KAPOK
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300
  Device-2: NVIDIA TU117M vendor: CLEVO/KAPOK driver: N/A alternate: nouveau
    bus-ID: 01:00.0 chip-ID: 10de:1f99 class-ID: 0300
  Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 1-8:3
    chip-ID: 5986:9102 class-ID: 0e02
  Display: x11 server: X.Org compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 128
    size: 382x215mm (15.0x8.5") diag: 438mm (17.3")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Comet Lake PCH cAVS vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
  Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
    chip-ID: 10de:10fa class-ID: 0403
  Sound Server-1: ALSA v: k5.16.5-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  IF: wlp0s20f3 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: r8169 v: kernel port: 3000 bus-ID: 08:00.1
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp8s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 8.19 TiB used: 2.01 TiB (24.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 48.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:1 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 39.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital
    model: WD easystore 2647 size: 4.55 TiB block-size: physical: 4096 B
    logical: 512 B type: N/A serial: <filter> rev: 1020 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 187.34 GiB (10.2%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 4ab500a8-bf4b-48ee-bbef-2b6ac3011690
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 525E-13A9
  ID-3: /run/media/fuzzy/2c9a7512-307f-46cf-8ed3-378f33596e6d
    raw-size: 92.95 GiB size: 90.99 GiB (97.89%) used: 60 MiB (0.1%) fs: ext4
    dev: /dev/nvme1n1p2 maj-min: 259:3 label: N/A
    uuid: 2c9a7512-307f-46cf-8ed3-378f33596e6d
  ID-4: /run/media/fuzzy/Alternate raw-size: 838.56 GiB
    size: 824.4 GiB (98.31%) used: 76 MiB (0.0%) fs: ext4 dev: /dev/nvme1n1p1
    maj-min: 259:2 label: Alternate uuid: 30843b13-3a2e-4bb9-9040-bc8527a66ebf
  ID-5: /run/media/fuzzy/Backup raw-size: 1.91 TiB size: 1.91 TiB (100.00%)
    used: 1.83 TiB (96.0%) fs: btrfs dev: /dev/sdb1 maj-min: 8:17 label: Backup
    uuid: 879ea826-b529-4c48-957e-df0ae3081a77
  ID-6: /run/media/fuzzy/Meatballs raw-size: 653.59 GiB
    size: 653.59 GiB (100.00%) used: 3.8 MiB (0.0%) fs: btrfs dev: /dev/sdb3
    maj-min: 8:19 label: Meatballs uuid: bddaae39-38c3-4cd0-8c47-5a5ae271b36c
  ID-7: /run/media/fuzzy/Spaghetti raw-size: 1.91 TiB
    size: 1.91 TiB (100.00%) used: 3.8 MiB (0.0%) fs: btrfs dev: /dev/sdb2
    maj-min: 8:18 label: Spaghetti uuid: b7bf2a02-6a97-451f-99e9-4e6817de4e1a
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-6:2 info: VIA Labs VL813 Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 2109:2813 class-ID: 0900
  Device-1: 1-6.1:4 info: Logitech Unifying Receiver
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-2: 1-8:3 info: Acer BisonCam NB Pro type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:9102
    class-ID: 0e02
  Device-3: 1-14:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-1:2 info: Western Digital easystore 2647 type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.1 speed: 5 Gb/s power: 896mA
    chip-ID: 1058:2647 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 55.0 C pch: 67.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 533 Uptime: 2d 21h 13m wakeups: 71 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1732 apt: 0
  pacman: 1675 lib: 412 flatpak: 42 snap: 15 Shell: Zsh v: 5.8 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.12
    ~                                                                                          ✔ 

A System 76 laptop should not have any compatibility issues with Linux and I could not find any mention of audio issues on System76 or PopOS fora, so this might be a mis-configuration in ALSA if it does not work in both sound servers

I suggest you check ALSA audio capture settings:

alsamixer -c0 --view=Capture

(press F1 to see list of keyboard controls)

Check settings for Capture and Internal Mic have audio capture enabled and adjust audio capture level if needed

You might also want to disable capture and zero the level for the Front Mic and Headset Mic jack sockets if they are not in use

If any of the settings are changed, use this command to save ALSA settings

sudo alsactl store

Thank your for responding. So far it still doesn’t show capture devices.

Not sure if this helps, but looking else where there is also this:

    ~  sudo arecord -l                                                                                                                                                                            ✔ 
[sudo] password for fuzzy: 
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC293 Analog [ALC293 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
    ~  pacmd list-sources | grep -e index -e name: -e muted -e device.description                                                                                                          ✔  6s  
    index: 0
        name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
        muted: yes
                device.description = "Monitor of Built-in Audio Analog Stereo"
  * index: 1
        name: <combined.monitor>
        muted: no
                device.description = "Monitor Source of Simultaneous output to Built-in Audio Analog Stereo"
    ~  sudo dmesg | grep snd—                                                                                                                                                                     ✔ 
    ~                                                                                                                                                                                         0|1 ✘ 

I now have audio capture. I haven’t found apps that could record though.

PulseAudio data is showing 2 sources but neither are for microphone input
Monitor of Built-in Audio Analog Stereo is the monitor of audio playing to headphones/speakers
Monitor Source of Simultaneous output is the monitor for simultaneous output to play audio to 2 or more output sinks (which is redundant when only one other output sink is available)

I suggest turning off the simultaneous output option in KDE audio controls

Change the Profile for Built-in Audio from Analog Stereo Output to Off
(this should clear any user settings for the device)

Then change Profile to Analog Stereo Duplex to enable output sink and input source

And set the microphone input as default source:

pacmd set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

To check if card profiles and defaults are set correctly:

pacmd dump | grep -C1 -E 'card-profile|set-default'

I was about t post an update on inxi but I have looked at everything that you said above. Both sound and mic are now working. Thank you very much for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.