Geen geluid na update

Hallo allemaal,
Ter informatie; Na een update in januari 2022 had ik geen geluid meer. De kernel die ik gebruikte was 5.10. Na wat zoeken en informatie via het forum kwam ik op het idee om een andere kernel te gebruiken ( ik heb eens op een ander forum gelezen dat problemen soms opgelost worden door een andere kernel te gebruiken ) Toen heb ik kernel 5.4 actief gemaakt en het geluid werkte weer.
Later dacht ik straks wordt deze kernel niet meer ondersteund en zit ik weer met het probleem. Toen heb ik kernel 5.15 geïnstalleerd en daarbij had ik ook geen geluid, daarna ook kernel 5.16 geïnstalleerd en hierbij heb ik weer wel geluid.
@Piscatorius,
hartelijk bedankt voor uw hulp.

2 Likes

Ik weet ook niet waarom je met andere kernels geen geluid hebt, maar 5.4 is een LTS en wordt nog op zijn minst tot 31.12.2025 ondersteund.

Het mooie van Manjaro is dat het het gebruik van meerdere kernels ondersteunt. Daarom hoef je kernel 5.4 ook niet van het systeem te verwijderen als je momenteel liever kernel 5.16 (Stable) wilt gebruiken. Omdat kernel 5.4 (Longterm) naar verwachting tot december 2025 ondersteund zal worden, zou je deze voorlopig zonder problemen moeten kunnen blijven gebruiken, in elk geval als fallback kernel, als kernel dus waarop je kunt terugvallen wanneer er problemen optreden met een van de hogere kernels.

:link: The Linux Kernel Archives - Releases
:link: "What should I be aware of if I'm not on an LTS kernel?" - Manjaro

1 Like

Nog een aanvulling; Ondertussen heb ik geen geluid meer met kernel 5.16.
Ik heb nu wel geluid met 5.4 , maar met alle nieuwere kernels heb ik geen geluid.
Het vreemde is dat de terminal uitvoer nu bij alle kernels maar 1 geluidserver actief geeft, ook bij 5.10, zie onderstaand:
[rinus@rinus ~]$ inxi -Aa
Audio:
Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
vendor: Lenovo driver: snd_hda_intel v: kernel
alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:0e.0 chip-ID: 8086:3198
class-ID: 0403
Sound Server-1: ALSA v: k5.10.96-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.20 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.45 running: no
[rinus@rinus ~]$
Hoe dat kan dat het veranderd is weet ik niet. Het enige verschil wat ik heb ontdekt met kernel 5.4 ( waar ik wel geluid heb ) is via werkbalk op volume symbool klikken en dan geluidsinstellingen, en dan staat er bij uitvoer, als het geluid werkt, bij apparaat alleen “Line Out Ingebouwde audio”; en als het geluid niet werkt staat er bij apparaat “Headphones Ingebouwde audio” en ook “Line Out Ingebouwde audio”
Ik blijf nu de kernel 5.4 gebruiken, maar misschien is het goed als er een oplossing voor het geluidsprobleem bij de andere kernels gevonden kan worden.

Ik begin te vermoeden dat telkens wanneer je denkt dat je geen geluid hebt (via de luidsprekers van de computer), de uitgang voor de hoofdtelefoon aan staat. Heb je dit al eens gecontroleerd door gewoon een hoofdtelefoon aan te sluiten?

Wanneer ik bijvoorbeeld een hoofdtelefoon aansluit, wordt de uitgang voor de luidsprekers automatisch uitgeschakeld en de uitgang voor de hoofdtelefoon automatisch ingeschakeld. Het venster voor de volumeregeling

Instellingenbeheer > PulseAudio-volumeregeling > Uitvoerapparaten

ziet er bij mij onder Xfce dan als volgt uit:

Schermafdruk_2022-02-12_16-30-40

Als ik de hoofdtelefoon weer loskoppel, wordt de uitgang voor de hoofdtelefoon uitgeschakeld en de uitgang voor de luidsprekers weer ingeschakeld. Het venster voor de volumeregeling ziet er dan als volgt uit:

Schermafdruk_2022-02-12_16-32-20

Als het probleem zich opnieuw voordoet, zou je gewoon eens kunnen spelen met de instellingen in het venster volumeregeling en nagaan of de luidsprekers hier kunnen worden ingeschakeld.

Ik heb alles geprobeerd, luidsprekers op hoofdtelefoon uitgang. gewoon hoofdtelefoon aangesloten, bij beide ook in uitvoerapparaten de Line Out en ook Headphones ingeschakeld, er veranderd ook niets als ik een hoofdtelefoon aansluit bij poort. En steeds geen geluid.
Wel heb ik ontdekt het balkje onder stilte oven kleurt als ik het geluid test. zie scherm.


Jammer, maar het was het proberen waard. Ik ben bang dat ik je niet verder kan helpen met het oplossen van het probleem. De enige troost is dat het geluid lijkt te werken met kernel 5.4. Helaas kan ik je niet vertellen waarom het met hogere kernels niet werkt. Daar zal wel iets in zitten of juist aan ontbreken, waardoor er problemen met je computer optreden. Maar je kunt kernel 5.4 dus zonder zorgen gebruiken, omdat deze nog geruime tijd zal worden onderhouden en daarom niet ‘ouder’ of ‘slechter’ is dan hogere kernels.

Nog een vraag. Als ik het goed begrijp, gebruik je externe luidsprekers die op de computer zijn aangesloten via de hoofdtelefoonpoort. Werken tenminste de ingebouwde luidsprekers van de computer met de hogere kernels?

[Latere toevoeging:]

Ik heb trouwens net een interessant gesprek gelezen hier op het forum dat misschien een andere benadering bevat om je geluidsprobleem op te lossen. Hiervan uitgaande kan het interessant zijn om de ALSA-instellingen eens te bekijken.

:link: Headphones and external speakers not working

Ik heb geen ingebouwde luidsprekers, maar losse luidsprekers ingeplugd in de lijn uit, en er zit een aparte uitgang voor hoofdtelefoon. Ik had dus mijn luidsprekers op de lijn uit, en daarna op de hoofdtelefoon aansluiting aangesloten, en daarna ook de hoofdtelefoon op de lijn uit en daarna op de lijn uit. en dan nog bij al die testen in de instellingen lijn uit en daarna hoofdtelefoon actief gezet.
Heb zo goed mogelijk die discussie bekeken, maar de uitgaaf bij die commando’s verschild nogal.
In ieder geval vriendelijk bedankt voor het helpen en meedenken.

Ja, dat is natuurlijk het punt. Daarom vormen de outputs van de commando’s de basis voor de oplossing van het probleem. Het is een kwestie van ze te interpreteren en ernaar te handelen.

Mijn kennis van computers is te gering om dat interpreteren en ernaar te handelen goed te kunnen doen. Dat zou misschien wel lukken met stap tot stap begeleiding.
Als ik op de link [How To] Provide System Information, klik krijg ik steeds de nmelding “Sorry, we konden dit topic niet laden, mogelijk door een verbindingsprobleem. Probeer het opnieuw. Als het probleem zich blijft voordoen, laat het ons dan weten.”
pactl info:
[rinus@rinus ~]$ pactl info
Server tekenreeks: /run/user/1000/pulse/native
Bibliotheek protocolversie: 35
Server protocolversie: 35
Is Local: ja
Cliënt-index: 9
Tegelgrootte: 65472
Gebruikersnaam: rinus
Hostnaam: rinus
Servernaam: pulseaudio
Serverversie: 15.0
Standaard-bemonsteringsspecificatie: s16le 2ch 44100Hz
Standaard-kanalenkaart: front-left,front-right
Standaardafvoer: alsa_output.pci-0000_00_0e.0.analog-stereo
Standaardbron: alsa_input.pci-0000_00_0e.0.analog-stereo
Cookie: 1c14:5883
[rinus@rinus ~]$
pacmd list-cards:
[rinus@rinus ~]$ pacmd list-cards
1 card(s) available.
index: 0
name: <alsa_card.pci-0000_00_0e.0>
driver: <module-alsa-card.c>
owner module: 6
properties:
alsa.card = “0”
alsa.card_name = “HDA Intel PCH”
alsa.long_card_name = “HDA Intel PCH at 0x82310000 irq 130”
alsa.driver_name = “snd_hda_intel”
device.bus_path = “pci-0000:00:0e.0”
sysfs.path = “/devices/pci0000:00/0000:00:0e.0/sound/card0”
device.bus = “pci”
device.vendor.id = “8086”
device.vendor.name = “Intel Corporation”
device.product.id = “3198”
device.product.name = “Celeron/Pentium Silver Processor High Definition Audio”
device.form_factor = “internal”
device.string = “0”
device.description = “Ingebouwde audio”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-pci”
profiles:
input:analog-stereo: Analoog stereo invoer (priority 32833, available: unknown)
output:analog-stereo: Analoog stereo uitvoer (priority 39268, available: unknown)
output:analog-stereo+input:analog-stereo: Analoog stereo duplex (priority 39333, available: unknown)
output:hdmi-stereo: Digital Stereo (HDMI) uitvoer (priority 5900, available: no)
output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) uitvoer + Analoog stereo invoer (priority 5965, available: unknown)
output:hdmi-surround: Digital Surround 5.1 (HDMI) uitvoer (priority 800, available: no)
output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) uitvoer + Analoog stereo invoer (priority 865, available: unknown)
output:hdmi-surround71: Digital Surround 7.1 (HDMI) uitvoer (priority 800, available: no)
output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) uitvoer + Analoog stereo invoer (priority 865, available: unknown)
output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) uitvoer (priority 5700, available: no)
output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) uitvoer + Analoog stereo invoer (priority 5765, available: unknown)
output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) uitvoer (priority 600, available: no)
output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) uitvoer (priority 600, available: no)
output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) uitvoer (priority 5700, available: no)
output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) uitvoer + Analoog stereo invoer (priority 5765, available: unknown)
output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) uitvoer (priority 600, available: no)
output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) uitvoer (priority 600, available: no)
output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) uitvoer (priority 5700, available: no)
output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) uitvoer + Analoog stereo invoer (priority 5765, available: unknown)
output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) uitvoer (priority 600, available: no)
output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) uitvoer (priority 600, available: no)
output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) uitvoer (priority 5700, available: no)
output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) uitvoer + Analoog stereo invoer (priority 5765, available: unknown)
output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) uitvoer (priority 600, available: no)
output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) uitvoer (priority 600, available: no)
output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) uitvoer + Analoog stereo invoer (priority 665, available: unknown)
off: Uit (priority 0, available: unknown)
active profile: output:analog-stereo+input:analog-stereo
sinks:
alsa_output.pci-0000_00_0e.0.analog-stereo/#0: Ingebouwde audio Analoog stereo
sources:
alsa_output.pci-0000_00_0e.0.analog-stereo.monitor/#0: Monitor of Ingebouwde audio Analoog stereo
alsa_input.pci-0000_00_0e.0.analog-stereo/#1: Ingebouwde audio Analoog stereo
ports:
analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: yes)
properties:
device.icon_name = “audio-input-microphone”
analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
properties:

	analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
		properties:
			device.icon_name = "audio-headphones"
	hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"
	hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"
	hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"
	hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"
	hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
		properties:
			device.icon_name = "video-display"

[rinus@rinus ~]$

amixer -c0
[rinus@rinus ~]$ amixer -c0
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 81 [93%] [-4.50dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Line Out',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]
Simple mixer control 'Mic',1
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',1
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 63 [100%] [30.00dB] [on]
  Front Right: Capture 63 [100%] [30.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [off]
  Front Right: Capture 0 [0%] [-17.25dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Mic' 'Mic 1'
  Item0: 'Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Mic' 'Mic 1'
  Item0: 'Mic'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
[rinus@rinus ~]$

[rinus@rinus ~]$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor>
     Active: active (running) since Fri 2022-02-18 19:44:59 CET; 35min ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 917 (pulseaudio)
      Tasks: 7 (limit: 4492)
     Memory: 23.1M
        CPU: 513ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulsea>
             ├─ 917 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─1059 /usr/lib/pulse/gsettings-helper

feb 18 19:44:51 rinus systemd[833]: Starting Sound Service...
feb 18 19:44:59 rinus pulseaudio[917]: stat('/etc/pulse/default.pa.d'): Bestand>
feb 18 19:44:59 rinus systemd[833]: Started Sound Service.
lines 1-15/15 (END)
Hier blijft de terminal hangen als ik die wil sluiten krijg ik melding "in de terminal is nog een proces actief" 

Ik heb nog niet getest of dat ook zo is bij kermel 5.4, dat zal ik nog doen```
Dan nog een vraag zo'n uitvoer van de terminal hier plaatsen op de juiste manier ( ik denk dat ik het niet goed doe met kopiëren en plakken ) hoe doe ik dat? 
Toevoeging: kernel 5.4

[rinus@rinus ~]$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor>
Active: active (running) since Fri 2022-02-18 20:53:57 CET; 4min 17s ago
TriggeredBy: ● pulseaudio.socket
Main PID: 959 (pulseaudio)
Tasks: 7 (limit: 4499)
Memory: 23.4M
CPU: 338ms
CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulsea>
├─ 959 /usr/bin/pulseaudio --daemonize=no --log-target=journal
└─1091 /usr/lib/pulse/gsettings-helper

feb 18 20:53:53 rinus systemd[869]: Starting Sound Service…
feb 18 20:53:57 rinus pulseaudio[959]: stat(’/etc/pulse/default.pa.d’): Bestand>
feb 18 20:53:57 rinus systemd[869]: Started Sound Service.
lines 1-15/15 (END)

Ik ben ook geen Linux-expert, slechts een geïnteresseerde hobbyist. Met behulp van de informatie die ik in relevante wiki’s en forums heb gevonden, heb ik me met veel moeite en geduld vertrouwd gemaakt met de materie. En ik ben ook bereid om elke dag weer iets nieuws te leren en anderen te helpen.

Het is belangrijk om de informatie die het eigen systeem biedt te vergelijken met de informatie die in wiki’s en forums te vinden is. Natuurlijk helpt het als deze informatie op een duidelijke, gestructureerde en gemakkelijk te volgen manier wordt gepresenteerd.

Helaas kan ik dat niet zeggen over de inhoud van je laatste bericht. De presentatie van de verstrekte informatie is verwarrend en niet te volgen. Het is me ook niet duidelijk welke terminaloutputs onder welke kernel werden bereikt. Het spijt me, maar ik ben bang dat ik je zo niet kan helpen.

:link: [HowTo] Increase your chances of solving your issue
:link: [HowTo] Provide System Information

Excuus voor mijn onduidelijk en verwarrend bericht. Ik heb al die opdrachten (uit de discussie waar u een link voor gemaakt had) in de terminal ingevoerd. Ik dacht misschien kan iemand er iets mee.
De terminaloutputs waren met kernel 5.10; alleen de laatste (systemctl --user status pulseaudio) was met kernel 5.4 om te kijken of de terminal daar ook bleef hangen, en dat was ook het geval, misschien hoort dat ook zo.
Ik neem u niets kwalijk, het is mijn fout als ik niet duidelijk genoeg ben.
Maar ik heb heel weinig ervaring met problemen oplossen, en weinig tijd om zoveel te zoeken.
Als u mij niet verder kunt helpen wil ik u toch hartelijk bedanken voor de tijd en moeite die u voor mij gedaan hebt.
Gelukkig doet het geluid het nog steeds met kernel 5.4