Wifi issue on a notebook connected to an external screen (via USB-C/Thunderbolt3)

Dear all. I am facing a bit of a strange issue:
Wifi is sometimes not working when using a Manjaro notebook plugged-in an external screen (via USB-C/Thunderbolt3 that serves as well for supplying power).

For now I am unable to determine when exactly the issue is appearing, it often happens often when connecting a running notebook computer but disconnects as well after it has been connected for several hours. Once the computer is disconnected from the screen, it captures again Wifi signal.

Often (but not always) when the connection is cut Wifi indicator turns into a question mark.

MY system is an up-to-date Manjaro Gnome. My notebook computer is a Lenovo T480s, the screen is a Dell p2720dc. But the problem already appeared on the predecessor model (T470s) with the same screen. All firmware is up to date. The issue is not related to unavailable internet.

I am facing this issue already for several months. It took me some time to figure out that is not related to a bad internet connection at all. For the moment it is really a big annoyment.

May this be a driver issue?
Is there anyone out there with a guess or even a pathway for a solution?
Thanks in advance.

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.10.96-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=bbcb79bf-b4e6-4ac4-b049-9c73365aa6c4 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20L7001SGE v: ThinkPad T480s
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20L7001SGE v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: N22ET72W (1.49 )
    date: 11/17/2021
  ID-1: BAT0 charge: 49.7 Wh (100.0%) condition: 49.7/57.0 Wh (87.1%)
    volts: 12.8 min: 11.6 model: LGC 01AV478 type: Li-poly serial: <filter>
    status: Full cycles: 118
  Device-1: hid-0003:17EF:60EE.0007-battery
    model: Lenovo TrackPoint Keyboard II serial: N/A charge: N/A status: N/A
  RAM: total: 15.4 GiB used: 14.05 GiB (91.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-8250U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1243 high: 2708 min/max: 400/3400 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2708 2: 1734 3: 1101
    4: 800 5: 800 6: 800 7: 802 8: 1200 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
    bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: Acer SunplusIT Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-8:8 chip-ID: 5986:2113 class-ID: 0e02
  Display: wayland server: X.org compositor: gnome-shell driver:
    loaded: modesetting alternate: fbdev,vesa display-ID: 0
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.96-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: yes
  Device-1: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15d8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
    bus-ID: 3d:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp61s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: wwp0s20f0u6 state: down mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.75 TiB used: 1.27 TiB (46.3%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN730 SDBPNTY-1T00-1101 size: 953.87 GiB block-size:
    physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD
    serial: <filter> rev: 11170001 temp: 39.9 C scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: JMicron Tech model: Generic
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B type: N/A
    serial: <filter> rev: 0208
  Message: No optical or floppy data found.
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 52.36 GiB (53.5%)
    fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6 label: N/A
    uuid: bbcb79bf-b4e6-4ac4-b049-9c73365aa6c4
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 2.5 MiB (0.5%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: B480-72A9
  ID-3: /home raw-size: 350 GiB size: 343.44 GiB (98.13%)
    used: 312.45 GiB (91.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: 698c1dac-9ef8-4ac2-b3b1-6b3d863cefc3
  ID-4: /run/media/ralph/SSD MySilverMini raw-size: 1.82 TiB
    size: 1.82 TiB (100.00%) used: 761.18 GiB (40.9%) fs: ntfs dev: /dev/sdb
    maj-min: 8:16 label: SSD MySilverMini uuid: 261D7BA34B9CE6F0
  ID-5: /run/timeshift/backup raw-size: 323.73 GiB size: 317.58 GiB (98.10%)
    used: 171.18 GiB (53.9%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
    label: N/A uuid: 9f5b2e88-a28a-4ab5-91a7-3288555b3e43
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 23.39 GiB used: 8.11 GiB (34.7%)
    priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4 label: N/A
    uuid: 67c1d045-a522-475c-8e7e-79cb42566d39
  ID-1: /dev/nvme0n1p3 maj-min: 259:3 size: 156.25 GiB fs: ntfs label: N/A
    uuid: 4BEE2B5E0F28C7EC
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 50mA
    chip-ID: 058f:9540 class-ID: 0b00
  Hub-2: 1-4:18 info: Dell ports: 6 rev: 2.1 speed: 480 Mb/s
    chip-ID: 413c:8442 class-ID: 0900
  Device-1: 1-4.1:19 info: Lenovo TrackPoint Keyboard II
    type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 17ef:60ee class-ID: 0300
  Device-2: 1-4.2:21 info: Xiaomi Mi Wireless Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s power: 50mA
    chip-ID: 2717:5013 class-ID: 0301
  Device-3: 1-4.3:22
    info: JMicron / JMicron USA JMS583Gen 2 to PCIe Gen3x2 Bridge
    type: Mass Storage driver: uas interfaces: 1 rev: 2.1 speed: 480 Mb/s
    power: 500mA chip-ID: 152d:0583 class-ID: 0806 serial: <filter>
  Device-4: 1-4.5:25 info: Texas Instruments type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 480 Mb/s
    chip-ID: 0451:82ff class-ID: 0300
  Device-5: 1-6:27 info: Fibocom L830-EB-00 LTE WWAN Modem
    type: Communication,CDC-Data,Abstract (modem) driver: cdc_acm,cdc_mbim
    interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 100mA chip-ID: 2cb7:0210
    class-ID: 0a00 serial: <filter>
  Device-6: 1-8:8 info: Acer SunplusIT Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 5986:2113 class-ID: 0e02
  Device-7: 1-9:26 info: Synaptics Metallica MIS Touch Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 06cb:009a class-ID: ff00 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-3:2 info: Realtek Card Reader type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 800mA
    chip-ID: 0bda:0316 class-ID: 0806 serial: <filter>
  Hub-4: 2-4:4 info: Dell ports: 2 rev: 3.2 speed: 5 Gb/s chip-ID: 413c:8440
    class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 45.0 C pch: 40.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
  Processes: 432 Uptime: 21h 48m wakeups: 48200 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1470
  pacman: 1389 lib: 355 flatpak: 60 snap: 21 Shell: Zsh v: 5.8
  running-in: gnome-terminal inxi: 3.3.12

If you format your post, it will be readable

Please set 3 Backticks in a line bevore the inxi, and 3 Backticks in a line after. Like this:

In the following posts you find advice for formatting to.

How to increase your chances of solving your issue:

Please provide Information:

Do you have an option that can connect to the screen without supplying power (to test)?

Depending on the placement of the network card, I have heard of laptops where the electricity passing through thunderbolt has caused interference with 802.11.

Thanks. I tried that (the bug just did not appear for all the last days). What I tested now

  1. I run Manjaro/Gnome conntected the the external screen (as power supply and external screen as only screening device.).
  2. After unplugging and replugging, Wifi connection is interrupted.
  3. Deselecting external screen as screening device (but keeping it connected to USB-C). Now the Internet connection works again.
  4. Swapping back (USB-C external screen as power supply and external screen as only screening device) → Wifi internet connection stops working. Even switching off and on Wifi connector does not help.
  5. Deselecting the external screen as screening device (but keeping it connected to USB-C). Now the Internet connection works again.
    Unfortunately I did not find a way to provoke the problem appear. I am sure after some time (at least after a restart of the device) everything works normal again.

Could that behavior be related to the cable (it is explicitly for connecting to USB-external screens)?