Why does kate use so much cpu?

whenever I open a file with kate, it uses as much as 25% cpu, but usually hovers around 15-13% usage.I have to kill kate in system monitor if I want it to stop running. my power consumption also jumps from 6 watts to 18.
kate version 22.04.3-1
has kate always used this much cpu?
let me know what other information I need to include

thank you for your time

Have you checked for errors by launching it from the terminal?

That doesn’t tell much without knowing what kind of CPU you use.

Hi @jake3,

I’ve just checked, and Kate uses 0.0% of my CPU. So I think it’s one of two reasons, or a combination of the two:

  1. Your CPU is finding it that difficult to process Kate, even when idle. So it’s wotking that much harder.
  2. An add-on/extension.

Which one? :man_shrugging:

I get no errors when launching from terminal, and the cpu I have is a intel i7-1165g7 I have turbo turned on in bios, its a 4 core processor, runs at 4.70 Ghs max. I can run other things like games with not super intensive graphics, like minecraft and tabletop simulator at 60 fps without needing to turn down graphics settings. as far as I can remember, kate has never used this much resources before. maybe I was just not paying attention, but it is hard not to notice my fans ramping dramatically, and my battery level decreasing far faster than it was a moment ago

If you just let Kate sit their idle without doing anything, does she get lonely?

If you just let Kate sit their idle without doing anything, does the CPU still hover around 15%?

Does the increased CPU activity remain, even after much time has passed without using Kate? Even if Kate is minimized?

What if you temporarily disable Kwin’s compositor? Same behavior?

What GPU is this?

Are you using a particular theme or one of the standard ones shipped with Manjaro KDE?

Did you test this on a live USB of the latest Manjaro ISO? (To rule out a persistent user setting.)

(Posting more complete system information can help as well.)

As an aside, I personally would disable Intel’s “Turbo Boost” feature. It’s more of a sales gimmick than useful for typical desktop/laptop home user. Even when it’s “enabled” and supported, it doesn’t really confer much benefit except for very specific use-cases.

is with all files or some ?

kate can use some plugins …
for exemple LSP can take a lot of resources

I suppose a plugin

letting kate Idle brings the cpu usage down to a normal level
forcing block compositor in special window settings immediately fixes the issue.
No GPU, only integrated graphics
my theme is brise dark lightly
16 gig ram, 500 gb ssd, framework laptop
turbo came pre-enabled on the device when I got it and I haven’t touched it since

Can you post your system info in here?

My hunch is removing xf86-video-intel, clearing any extraneous configs under /etc/X11, and finally rebooting might help.

output from inxi -v7azy:
   Kernel: 5.18.17-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
     parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
     root=UUID=f6898bf0-f23e-4f8c-8f59-2b16eaa17936 rw
     resume=UUID=f6898bf0-f23e-4f8c-8f59-2b16eaa17936 resume_offset=11597824
     quiet apparmor=1 security=apparmor udev.log_priority=3
   Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
     Distro: Manjaro Linux base: Arch Linux
   Type: Laptop System: Framework product: Laptop v: AB
     serial: <superuser required>
   Mobo: Framework model: FRANBMCP0B v: AB serial: <superuser required>
     UEFI: INSYDE v: 03.10 date: 07/19/2022
   ID-1: BAT1 charge: 46.6 Wh (100.0%) condition: 46.6/55.0 Wh (84.8%)
     volts: 17.4 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
     status: discharging cycles: 51
   RAM: total: 15.42 GiB used: 9.65 GiB (62.6%)
   RAM Report: permissions: Unable to run dmidecode. Root privileges
   Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
     model-id: 0x8C (140) stepping: 1 microcode: 0xA4
   Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
     L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
     L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 939 high: 1091 min/max: 400/4700 scaling:
     driver: intel_pstate governor: powersave cores: 1: 532 2: 1072 3: 1050
     4: 622 5: 1047 6: 1091 7: 1087 8: 1011 bogomips: 44864
   Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
     arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
     avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
     avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
     cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
     cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
     flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
     hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt invpcid
     invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
     movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
     pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
     rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
     sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
     tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
     vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
   Type: itlb_multihit status: Not affected
   Type: l1tf status: Not affected
   Type: mds status: Not affected
   Type: meltdown status: Not affected
   Type: mmio_stale_data status: Not affected
   Type: retbleed status: Not affected
   Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
   Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
   Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
     filling, PBRSB-eIBRS: SW sequence
   Type: srbds status: Not affected
   Type: tsx_async_abort status: Not affected
   Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
     arch: Gen-12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1
     empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0 chip-ID: 8086:9a49
     class-ID: 0300
   Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
     compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
     gpu: i915 display-ID: :0 screens: 1
   Screen-1: 0 s-res: 2256x1504 s-dpi: 96 s-size: 596x397mm (23.46x15.63")
     s-diag: 716mm (28.19")
   Monitor-1: eDP-1 model: BOE Display 0x095f built: 2019 res: 2256x1504
     hz: 60 dpi: 201 gamma: 1.2 size: 285x190mm (11.22x7.48") diag: 343mm (13.5")
     ratio: 3:2 modes: 2256x1504
   OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 22.1.6
     direct render: Yes
   Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
     v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
     chip-ID: 8086:a0c8 class-ID: 0403
   Sound Server-1: ALSA v: k5.18.17-1-MANJARO running: yes
   Sound Server-2: JACK v: 1.9.21 running: no
   Sound Server-3: PulseAudio v: 16.1 running: yes
   Sound Server-4: PipeWire v: 0.3.56 running: yes
   Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
     pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: aa:00.0 chip-ID: 8086:2725
     class-ID: 0280
   IF: wlp170s0 state: up mac: <filter>
   IP v4: <filter> type: dynamic noprefixroute scope: global
     broadcast: <filter>
   IP v6: <filter> type: noprefixroute scope: link
   IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
     mac: <filter>
   IP v6: <filter> type: noprefixroute scope: global
   IP v6: <filter> type: noprefixroute scope: link
   IF-ID-2: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
   IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
   IP v6: <filter> virtual: stable-privacy scope: link
   WAN IP: <filter>
   Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
     bus-ID: 3-10:4 chip-ID: 8087:0032 class-ID: e001
   Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
   Message: No logical block device data found.
   Message: No RAID data found.
   Local Storage: total: 465.76 GiB used: 175.79 GiB (37.7%)
   SMART Message: Unable to run smartctl. Root privileges required.
   ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
     model: WDS500G3X0C-00SJG0 size: 465.76 GiB block-size: physical: 512 B
     logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
     rev: 111130WD temp: 49.9 C scheme: GPT
   Message: No optical or floppy data found.
   ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%) used: 175.79 GiB
     (38.5%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
     uuid: f6898bf0-f23e-4f8c-8f59-2b16eaa17936
   ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 292 KiB
     (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: NO_LABEL
     uuid: 85C4-F9C5
   Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
   ID-1: swap-1 type: file size: 20 GiB used: 1.72 GiB (8.6%) priority: -2
     file: /swapfile
   Message: No unmounted partitions found.
   Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
     speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
   Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
     chip-ID: 1d6b:0003 class-ID: 0900
   Device-1: 2-1:5 info: Silicon Motion - Taiwan (formerly Feiya ) USB DISK
     type: Mass Storage driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s
     power: 504mA chip-ID: 090c:3350 class-ID: 0806 serial: <filter>
   Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
     speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
   Device-1: 3-4:6 info: Framework HDMI Expansion Card type: Billboard,HID
     driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
     power: 100mA chip-ID: 32ac:0002 class-ID: 0300 serial: <filter>
   Device-2: 3-9:3 info: Shenzhen Goodix USB2.0 MISC type: <vendor specific>
     driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
     chip-ID: 27c6:609c class-ID: ef00 serial: <filter>
   Device-3: 3-10:4 info: Intel AX210 Bluetooth type: Bluetooth driver: btusb
     interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0032
     class-ID: e001
   Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
     chip-ID: 1d6b:0003 class-ID: 0900
   System Temperatures: cpu: 56.0 C mobo: N/A
   Fan Speeds (RPM): N/A
   Processes: 371 Uptime: 10h 19m wakeups: 11294 Init: systemd v: 251
   default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
   Packages: 1816 pacman: 1777 lib: 477 flatpak: 25 snap: 14 Shell: Zsh v: 5.9
   default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.20

Remove the package xf86-video-intel

Make sure there are no custom configs under/etc/X11/ (or its subdirectories) that you might have created at one point. (You can leave alone the included defaults.)


I don’t think that fixed it, its still using 15% CPU

Does this happen with any other native KDE application besides Kate?

not as far as I can tell
I also tried reinstalling kate but no dice

Can you repeat this test, but with the standard default theme?

by test do you mean opening kate or do you mean rebooting after removing xf86-video-intel?
if the former, then no change

I literally wrote “Reboot” in my post…

no change

After changing the theme or after rebooting without xf86-video-intel? (Or both?)

well I did not add xf86-video-intel back after removing it the first time and I changed the theme and rebooted, so, both?

Then I would test this on a live USB session.

Or even create a new user account on your current system, log in with it, and then test this.

If it does not happen with the temporary new user account, then it points to a configuration/config file on your main user account.