Computer randomly restarts, regardless of OS

Hi there, the title is pretty self explanatory.

I’ve tried installing Manjaro a few times on my PC but for some reason, it will just randomly restart. I know it isn’t an overheating issue as I am trying to dual-boot Windows and Manjaro at the same time, and Windows seems to work perfectly fine with no overheating problems.

The timing of when the computer restarts in Manjaro seems to be pretty random, as sometimes it would let me install the OS, but when I tried updating some software it would randomly restart, and generally when I tried doing anything it would restart. Checking journalctl didn’t give me much as it only gave an error about a ‘touchegg daemon’ being unable to connect. I did at least try disabling this module by running the command ‘systemctl disable --now touchegg’ but this didn’t fix my issue.

It also doesn’t seem to be a gnome specific issue as it still happened with KDE and XFCE. I also tried installing Fedora but it still gave the same problem. I also tried both the proprietary graphics drivers and the open-source drivers just in case, but neither fixed my issue.

When the computer did restart the actual components themselves wouldn’t switch off, the screen would just randomly go blank and then go through the boot sequence again. As far as I’m aware, I think it doesn’t switch off when idle.

System specs (if helpful):
CPU: Ryzen 5 5600x
GPU: MSI RTX 3070 Gaming X Trio
Boot drive: Samsung 970 EVO 500gb
RAM: 16GB Corsair Vengeance Pro

EDIT: It was the XMP profile being turned on in the BIOS that caused the issue.

post formated output from:
inxi -Fazy
mhwd -l && mhwd -li

Hi @kergelan, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

Here’s what outputted after doing the inxi command:

  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=dcbdec0e-515b-4e37-81b5-3a057959b095 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 41.5 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.50
    date: 01/20/2021
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 3017 high: 3600 min/max: 2200/4650 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3137 2: 3595
    3: 2876 4: 2876 5: 2877 6: 2872 7: 2878 8: 3600 9: 2873 10: 2873 11: 2878
    12: 2879 bogomips: 88840
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate]
    vendor: Micro-Star MSI driver: nvidia v: 510.60.02
    alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 2d:00.0 chip-ID: 10de:2488
    class-ID: 0300
  Display: x11 server: v: with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 4480x1440 s-size: <missing: xdpyinfo>
  Monitor-1: DP-0 pos: primary,top-left res: 2560x1440 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-2: HDMI-0 pos: bottom-r res: 1920x1080 dpi: 102
    size: 480x270mm (18.9x10.63") diag: 551mm (21.68") modes: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02 direct render: Yes
  Device-1: NVIDIA GA104 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2d:00.1 chip-ID: 10de:228b class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: no
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: f000 bus-ID: 26:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 28:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:2
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Local Storage: total: 2.27 TiB used: 11.06 GiB (0.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 40.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM008-2FR102
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: 0001 scheme: GPT
  ID-1: / raw-size: 181.7 GiB size: 177.79 GiB (97.85%) used: 11.04 GiB (6.2%)
    fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 25.2 MiB (26.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 308 Uptime: 1m wakeups: 0 Memory: 15.61 GiB used: 1.11 GiB (7.1%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
  Packages: pacman: 1134 lib: 294 flatpak: 0 Shell: Zsh v: 5.8.1
  running-in: gnome-terminal inxi: 3.3.15

Here’s what outputted from the mhwd command:

   0000:2d:00.0 (0300:10de:2488) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!

It appears to be a hardware problem rather than a software problem. I had the same problem as you and I found out with the memtest86 that I had broken RAM. Also try disabling the Precision Boost Overdrive from the bios and see if it’s a power issue.

1 Like

If it happens regardless of OS, it suggests a hardware issue and not software. Quite possibly RAM, like @Dullnets said. Test your RAM with memtest86. Find out more here:


You can also use memtester, available in the community repository:

1 Like

I recommend a BIOS update too


You forgot to mention the PSU.
My opinion (as of last month) is that the PSU is the most important component - as it just took out my ancient computer - rendering the motherboard/cpu/RAM unusable (as replacements just aren’t cost efficient).

I’d seriously look at that before plugging in my 5600G/Steel Series/Samsung Evo/16GB RAM or my other hard drives (as it was the original crappy HP Pavillion power supply which crapped out my first 500GB hard disk upgrade due to insufficient power delivery).

to run memtest is a good idea. i would recommend to shut down the pc,unplug the RAM and plug it back. contact-problems with the pinnings at RAM are more common than people expect.

1 Like

Hi, I did the default memtest and the results turned out fine. I found out the issue did have to do with the RAM though, as it turned out the XMP profile being turned on seemed to be causing the issue, as when I turned it off it started working fine. Thanks for the help, though!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.