Can't mount hard disk. A new problem occurred

Hey guys. I was going to mount my hard disk from reading this Mount a external hard drive with execute permissions - #4 by DeLinuxCo. However this problem appeared.

Can you boot the system without the external drive ?

Yes, I have windows 10 too

Hi everyone. I was trying to mount my hard disk and this happened. If anyone knows this please help me.

More infos please…

Did you try to mount this HDD in Fstab or what was the change?

How did you mount this HDD? Are you talking about the temporary mount option in Dolphin?

Are you talking about External USB?

I don’t remember that.

I was doing that by this guide Mount a external hard drive with execute permissions - #4 by DeLinuxCo

As i said more infos needed… did you use KDE Partition Manager and clicked on Mount on Start?

Or did you use gnome disk under KDE? :crazy_face:

2.Do you have your External USB Drive connected now, while you booting?

3.How did this Emergency mode appeared, just after a normal restart?

It fixed. Do you know how. Let me tell you about it. Well, I just write password in that and run startx command then my system open different Manjaro but there are all of my application. Then, I deleted gnome disk and rebooted. After that, I entered my windows system because I use those as dual boot. Then, I just rebooted windows. Finally it worked.

Okay, you have a pretty unique setup here :wink:

If you want a rely able mount option, and if you always has this drive connected i would recommend fstab instead this GUI stuff… anyways, i hope you can archive your goal from here.

If not… let me know.

Thanks bro

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

1 Like

What do you want to do ?
Start Manjaro from a external disc ?

Don’t mount a removable device in fstab.

Use systemd mount unit and automount unit to avoid a missing device in fstab.

1 Like

Why not?

If the mount options contain nofail, then the system won’t stall if the drive is not present during boot.

Can you post /etc/fstab ?

That is correct - remember though - the nofail option only allows a continued boot - it does not make the device available when attached - unless you manually execute a sudo mount -a.

You can have both with ...,x-systemd.automount,nofail,...