WiFi on my HP laptop is very slow and ocasionally drops out

System:
  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=77a807a5-0e29-4758-be33-9b01611311da rw quiet apparmor=1
    security=apparmor resume=UUID=06a59da7-241f-45ef-a404-d6c0c4d32489
    udev.log_priority=3
  Desktop: Xfce v: 4.16.1 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC
    v: 0884100000305A10000620100 serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 196F v: 95.32 serial: <superuser required>
    UEFI: Insyde v: F.21 date: 12/04/2013
Battery:
  ID-1: BAT0 charge: 43.5 Wh (100.0%) condition: 43.5/43.5 Wh (100.0%)
    volts: 12.4 min: 10.8 model: Hewlett-Packard Primary type: Li-ion
    serial: N/A status: full
Memory:
  RAM: total: 11.58 GiB used: 1.84 GiB (15.9%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
    required.
CPU:
  Info: model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge
    gen: core 3 level: v3 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1202 high: 1214 min/max: 1200/2400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1197 2: 1214 3: 1197
    4: 1200 bogomips: 19162
  Flags: acpi aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    erms est f16c flush_l1d fpu fsgsbase fxsr ht ibpb ibrs lahf_lm lm mca mce
    md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good
    sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc
    tsc_deadline_timer vme x2apic xsave xsaveopt xtopology xtpr
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
    active: HDMI-A-1,LVDS-1 empty: DP-1,VGA-1 bus-ID: 00:02.0
    chip-ID: 8086:0166 class-ID: 0300
  Device-2: Realtek HP Truevision HD type: USB driver: uvcvideo
    bus-ID: 3-3:3 chip-ID: 0bda:571c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 3286x1080 s-dpi: 96 s-size: 869x286mm (34.21x11.26")
    s-diag: 915mm (36.02")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,top-right
    model: Samsung C24F390 serial: <filter> built: 2019 res: 1920x1080 hz: 60
    dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: LVDS-1 pos: bottom-l model: Samsung 0x4551 built: 2012
    res: 1366x768 hz: 60 dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1e20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Realtek RTL8188EE Wireless Network Adapter vendor: Hewlett-Packard
    driver: rtl8188ee v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 4000
    bus-ID: 01:00.0 chip-ID: 10ec:8179 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 238.47 GiB used: 29.15 GiB (12.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SKC600256G
    size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 0105 scheme: GPT
  Optical-1: /dev/sr0 vendor: hp model: DVDRAM GU70N rev: U703
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition:
  ID-1: / raw-size: 225.43 GiB size: 220.84 GiB (97.96%) used: 29.15 GiB
    (13.2%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: 77a807a5-0e29-4758-be33-9b01611311da
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
    uuid: 84A8-4009
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 12.74 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda3 maj-min: 8:3 label: swap
    uuid: 06a59da7-241f-45ef-a404-d6c0c4d32489
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 3-2:2 info: Apple Hub in Aluminum Keyboard ports: 3 rev: 2.0
    speed: 480 Mb/s power: 300mA chip-ID: 05ac:1006 class-ID: 0900
  Device-1: 3-2.2:4 info: Apple Aluminum Keyboard (ISO) type: Keyboard,HID
    driver: apple,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s power: 20mA
    chip-ID: 05ac:0221 class-ID: 0300
  Device-2: 3-2.3:5 info: Primax Dell N889 Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 98mA chip-ID: 0461:4d81 class-ID: 0301
  Device-3: 3-3:3 info: Realtek HP Truevision HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:571c class-ID: 0e02 serial: <filter>
  Hub-7: 4-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 191 Uptime: 7m wakeups: 1 Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1118
  pm: pacman pkgs: 1114 libs: 326 tools: pamac pm: flatpak pkgs: 0 pm: snap
  pkgs: 4 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.21

Hello, WiFi on my HP laptop is super slow - 3Mbps compared to 44Mbps on my Dell Windows laptop in the same location.

Any suggestions for improving the speed gratefully received. Please note I am not technical at all so will need significant hand holding :grimacing: Thank you.

Hi @kurt, and welcome!

While the info given is awesome, please provide the full output of:

inxi --admin --verbosity=7 --filter --no-host --width

…as described here:

Please also see:

Hope you manage!

1 Like

Generally it is a power saving feature, which is not enabled on Windows or it is badly optimized on Linux.

So the following is only terminal stuff…

Looking at the driver parameter:

modinfo rtl8188ee

There is something you can try:

sudo -su root
systemctl stop NetworkManager
modprobe -rv rtl8188ee
modprobe -v rtl8188ee ips=0 swlps=1 fwlps=0 aspm=0
systemctl start NetworkManager && journalctl -u NetworkManager -f

When running modprobe -v it loads verbosely the driver with all set parameters.

Note that this is temporary and must be written in a modeprobe config to be permanent.

And also note that not all parameters are necessary. You can try them step by step and combine them as I showed already.

You can also disable the powersaving in NetworkManager:

echo -e "[connection]\nwifi.powersave = 2" | sudo tee /etc/NetworkManager/conf.d/10-powersave.conf

NetworkManager Wi-Fi powersaving configuration · GitHub

Good success. :wink:

2 Likes

Thank you @Mirdarthos for your kind welcome and info. I’ve updated my original post as you suggest :grinning:

Thank you @megavolt I tried the first block of commands you posted:

sudo -su root
systemctl stop NetworkManager
modprobe -rv rtl8188ee
modprobe -v rtl8188ee ips=0 swlps=1 fwlps=0 aspm=0
systemctl start NetworkManager && journalctl -u NetworkManager -f

This seemed to briefly increase performance but then download and upload speeds dropped again.

I also tried disabling the powersaving in NetworkManager which I see created this file:

/etc/NetworkManager/conf.d/10-powersave.conf

I’m not certain yet whether that had any impact - will keep testing. Do I simply delete that file to reverse that change?

I’m starting to think that the fluctuating speeds are more to do with my Virgin ‘SuperHub’ 3 than Manjaro or the particular wireless card in my laptop.

Many thanks,
Kurt

did you try with different kernel, for example with the 5.19?
and 10-powersave.conf for this to work, you need to reboot

Hi @brahma I did read something about downgrading the kernel - haven’t tried it yet but may give it a go.

On a different note, do I literally just delete 10-powersave.conf to undo that config change?

Thanks,
Kurt

yes you can delete it, and install the 5.10 kernel, select it in grub/advanced options and see if that helped

1 Like

Hi @brahma I tried with various different kernels and 4.19.257-1-MANJARO seems to be a slight improvement. I’m starting to lose the will though as speeds are still only about 5mbs down and 3 up :frowning: Think I’ll try a Windows 11 install and see how those speeds compare arrgghhhhhh

Ok edit my last comment - the issue does seem to be the wireless card / manjaro :frowning:

You shall clear the temporary files.

Thanks Danny how do I do this please

you could try installing a driver from aur, but first post output from:
mhwd-kernel -li && inxi -N

  1. In the search box on the taskbar, type disk cleanup, and select Disk Cleanup from the list of results. Select the drive you want to clean up, and then select OK.

This is not Windows, dear @Danny525 :man_facepalming:

Output is:

Currently running: 4.19.257-1-MANJARO (linux419)
The following kernels are installed in your system:
   * linux419
   * linux510
   * linux515
Network:
  Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169

and for info I have the 10-powersave.conf file in place.

I’ve tried each of the other installed kernels.

have you already tried to boot a live-iso and check if the connection is correct in a live-session ? If not i would recommend to test this and report if there is a difference.
there had been reported problems with the dns-resolving in the past, that might be an issue but it’s hard to give support from through the inet. please check this step with a live-iso. that would be a good starting-point.

try @Olli s advice, and the driver from aur i suggested above, you can forget about it, its 3 years old, so maybe it would not even build, and if so, it would not make a difference…

If it is really a dns problem, then I would recommend to add a dns cache service… as that solves most problems in that area. NetworkManager has not a DNS Cache by itself by default, so it will send a request to the DNS-Server of your Provider every time when it asks for the IP of a Domain.

echo -e "[main]\ndns=dnsmasq" | sudo tee /etc/NetworkManager/conf.d/10-dns.conf

and install dnsmasq if not there:

pamac install dnsmasq

Keep sure that the service is not running:

systemctl status dnsmasq
systemctl disable --now dnsmasq

since NetworkManager will start it on its own.

And restart NetworkManager:

systemctl restart NetworkManager && journalctl -b0 -f -u NetworkManager

In the log there should be now dnsmasq mentioned.

1 Like

I am guilty; I relied on one of my colleagues with this reply, and he misled me. :disappointed:

1 Like