Unity only recognize VSCODE from Flatpak

I already installed mono and .net core sdk. I try vscode’s from aur and snap but when i opens a file this message appear “Visual Studio Code is required to edit Unity scripts.
Would you like to install it?”, it redirect to flathub. I tried use “browse…” option and selected a code executable file of vscode, nothing happens when i to try open a file… i tried select code symbolic link in /usr/bin/code but it was not showed in file explorer. I can’t use the vscode because the itself version is unnoficial and the .net core sdk could be not founded(solve this is a possible solution too): issue link

Increase your chances of solving your issue:

Provide Information:

Which package have you tried? There are several available, using different sources and options, and not-branded ones may be prevented from using some extensions.

i tried visual-studio-code-bin package

Have you tried the last part of that answer?

Yes, but i cant do. My explorer don’t have a field to insert the path manually and “code” file is not showed when i navigate to /usr/code/

My UnityHub was installed from Flatpak, i’m removing it and installing the UnityHub from AUR. I think it could work.

finally, this work. when i was install Unity3D i have the vscode insiders from AUR (visual-studio-code-insiders-bin) installed and the Unity3D was recognize the vscode insiders in two paths “/usr/bin/code and /bin/code”, i selected /bin/code and worked. After this i removed vscode insiders and installed vscode from AUR(visual-studio-code-bin) and everything keep working correctly… Thanks for your help

note: the intellisense works too.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.