Borked dual boot Manjaro


Long time reader, first time poster.

Background: Running Manjaro, Cinnamon 6.1 for a while. No problems.

Running it on a 1 TB nvme drive. EPS partition and a root partition and some extra space.

Decided i wanted to test out Pop!OS before buying a system76 laptop.

The cause: the pop installer failed and broke boot/efi. (Issue seemed to be a combination of the 1 TB usb (yes not thr nvme drive) and what i used to make the install usb)

I figured fixing grub would be easy but i had no working os. Disclaimer, maybe i was using efi or maybe grub? It was a while ago and im tired (kids) not sure whats what now lol. Maybe thats the issue.

Used a laptop to make a manjaro live disk. I may have picked gnome? (Important below)

I installed a new version of manjaro on a different partition, same disk. Now i have working grub and an working os.

I tried the chroot fix, verified the old installation using os-prober, used grub-mkconilfig.

Finally got the old os to show in grub (without manually making a grub.cfg

Issue: now booting into the original manjaro i get errors. I also see gnome errors. (not sure if that always shows since it boots fast.

This is everything errors. (Wont let me upload a photo)

Failed to start:
System logging service
Etc etc

Everything fails. Everything is not awesome

Ive verified the UUID, tried loading 6.1 all the way to 6.6.

I’m forgetting/missing something.

I can send follow up screenshots of outputs when i get back to my office.

I appreciate it if yoh got this far. Tried to post images from my phone and it said no. Will post from pc or in reply


No idea how to fix this, but for the next time… just create a timeshift snapshot and it will also backup/restore your bootfiles.

1 Like

Same. Can but to suggest to reformat and I highly recommend format using BTRFS file system instead of ext4 as it works amazing when making system snapshots (backups) as I think are essential in any OS, specially on GNU/Linux systems. Those snapshots are created instantly, accessible from Grub. Just open Timeshift and enjoy. They are even created automatically every update so you can rollback any changes without a second though…

Honestly don’t know why this isn’t default or recommended but there are my virtual 10 cents. Cheers!


Did you check the files on the old Manjaro install? Are you sure you didn’t overwrite it? My theory is the EFI partition survived and /boot but the rest are gone. Because it sounds like SystemD is not working/finding anything.

Is the /boot-folder still there? Does it contain what it usually does on Manjaro? Is your /home-folder intact? What about /usr/? What’s the date on files inside that folder?

It’s just a theory.

Would be easier if you listed the partitions, what is what.

Hi @topj and welcome to the Manjaro community.

Screenshots are not as useful as you might imagine.

Please provide any command outputs as text. The following command will output your partition layout sufficiently for others to take a better guess as to your current state:

sudo lsblk -f

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

I hope this helps. Cheers.

Im using ext4 and timeshift works perfectly flawless here also.

Since your network isn’t working with your failed old Manjaro install, you can save the journal errors and inxi system report in a .txt file and post them later from a live boot or from your other Linux installations.