Kernel 5.4 panic error after latest update

After last update of manjaro , lts kernel 5.4 won’t boot , showing kernel panic message . I currently have a 6.1 kernel, but 5.4 worked better on my not-so-new laptop.I tried reinstalling kernel 5.4 but that didn’t help , also mkinitcpio -P didn’t change anything.

were there any errors when reinstalling the 5.4?
try with the 5.10:
sudo mhwd-kernel -i linux510
reboot, select it, and test…

Check the compression type in /etc/mkinitcpio.conf. It may be set to zstd, but kernel 5.4 does not support that. zstd compression support for the initramfs was only added in 5.10.

If it’s set to zstd, change it to gzip and rebuild your initcpios.

I got the same problem installing linux510 fixed it.

This is my current mkinitcpio.conf

# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(amdgpu radeon)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap consolefont filesystems fsck"

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

Following some older forum posts for fixing kernel panic i got a error running depmod -a missing kernel 6.xxxx model file.

mhwd-kernel -i linux54
mkinitcpio -P
depmod -a

Fixed my own problem by uncommenting COMPRESSION=gzip and then running

mkinitcpio -P

Also got a kernel panic:.I uncommented the gzip compression line in mkinitcpio.conf using my second manjaro installation. Kernel panic still there. I cannot switch to any terminal using ctrl+alt+Fx. How to boot/switch to terminal after kernel panic so that I can rebuild my initcpios?

Hi @dingdong, and welcome!

Please open a new thread since this is a new problem. See

Also, please see:

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

I think you’d need to do it from a *chroot environment.

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Once there, consult the Arch wiki regarding the rest:

Hope this helps!

1 Like

How did you run the two commands if kernel panic interrupts booting?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.