My voice sounds 'high-pitched' when recording via pipewire

Hi there!

Issue summary

I’ve installed pipewire via “sudo pacman -S manjaro-pipewire”. I’ve also installed the EasyEffects and Jack2 packages (pipewire-jack package as well) since I’m also planning on doing music production on this machine. So far, my audio outputs and inputs technically work however my voice sounds high-pitched on playback when using Discord or recording via Audacity (I couldn’t get Reaper to record). It’s like a full whole step or two increase in tone and definitely noticeable. I’ve been googling around but I can’t seem to resolve this issue.

Steps I’ve taken to resolve

  • appending ‘usbcore.autosuspend=-1’ to the variable “GRUB_CMDLINE_LINUX_DEFAULT” in /etc/default/grub
  • uncommenting “default.clock.rate = 48000” in /etc/pipewire/pipewire.conf
  • further messing with sample rates but with no real understanding of what I’m doing

Note that “pw-top” indicates that all my devices are using a samplerate of 48000.

Furthermore, do I even need Jack2? I’d also like to route my microphone through a Reaper track to add several effects like compression, de-esser and reverb. Guides on audio production on youtube almost always use Jack2 but it’s unclear to me if it’s necessary anymore with pipewire.


Output device: JDS Labs Element II amplifier
Input Device: Focusrite Scarlett 6i6 Audio Interface

Thanks for any help in advance!

Did you already try another kernel like 5.10 or 5.15

How to increase your chances of solving your issue:

Please provide Information:


I have 5.15 installed. I’ve just installed 5.10 and am having the exact same issues.

Here’s the output of inxi:

  Kernel: 5.10.93-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.10-x86_64
    root=UUID=018333fa-e803-412b-aa36-c45865c44acd rw rootflags=subvol=@ quiet
    splash apparmor=1 security=apparmor
    resume=UUID=aacc5c70-c193-4192-8b99-9de334e00f2a udev.log_priority=3
  Desktop: GNOME 41.3 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 5851
    date: 06/16/2021
  Message: No system battery data found. Is one present?
  RAM: total: 31.32 GiB used: 3.58 GiB (11.4%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 1x32 MiB
  Speed (MHz): avg: 4298 high: 4300 min/max: 2200/6055:5732:5568:5404:5896
    boost: enabled scaling: driver: acpi-cpufreq governor: schedutil cores:
    1: 4299 2: 4298 3: 4299 4: 4300 5: 4299 6: 4300 7: 4297 8: 4298 9: 4299
    10: 4299 11: 4298 12: 4299 bogomips: 103247
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_vmsave_vmload vaes
    vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt xgetbv1 xsave xsavec
    xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: always-on, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA102 [GeForce RTX 3080] driver: nvidia v: 495.46
    alternate: nouveau,nvidia_drm bus-ID: 08:00.0 chip-ID: 10de:2206
    class-ID: 0300
  Display: x11 server: compositor: gnome-shell driver:
    loaded: nvidia resolution: <missing: xdpyinfo>
  OpenGL: renderer: NVIDIA GeForce RTX 3080/PCIe/SSE2 v: 4.6.0 NVIDIA 495.46
    direct render: Yes
  Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel v: kernel
    bus-ID: 08:00.1 chip-ID: 10de:1aef class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0a:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Device-3: XMOS JDS Labs Element II type: USB driver: snd-usb-audio
    bus-ID: 3-1:2 chip-ID: 20b1:30da class-ID: fe01
  Device-4: Focusrite-Novation Scarlett 6i6 type: USB driver: snd-usb-audio
    bus-ID: 3-2.1.4:8 chip-ID: 1235:8012 class-ID: fe01 serial: <filter>
  Sound Server-1: ALSA v: k5.10.93-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    port: e000 bus-ID: 06:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.62 TiB used: 42.03 GiB (2.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 QVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: MBR
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: Cruzer Glide
    size: 29.81 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 431.01 GiB size: 431.01 GiB (100.00%)
    used: 42.03 GiB (9.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: 018333fa-e803-412b-aa36-c45865c44acd
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 568 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 label: NO_LABEL
    uuid: 2CFB-C7BE
  ID-3: /home raw-size: 431.01 GiB size: 431.01 GiB (100.00%)
    used: 42.03 GiB (9.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: 018333fa-e803-412b-aa36-c45865c44acd
  ID-4: /var/cache raw-size: 431.01 GiB size: 431.01 GiB (100.00%)
    used: 42.03 GiB (9.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: 018333fa-e803-412b-aa36-c45865c44acd
  ID-5: /var/log raw-size: 431.01 GiB size: 431.01 GiB (100.00%)
    used: 42.03 GiB (9.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18 label: N/A
    uuid: 018333fa-e803-412b-aa36-c45865c44acd
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 34.45 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sdb3 maj-min: 8:19 label: swap
    uuid: aacc5c70-c193-4192-8b99-9de334e00f2a
  ID-1: /dev/sda1 maj-min: 8:1 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/sda2 maj-min: 8:2 size: 931.5 GiB fs: ntfs label: Data
    uuid: 104A46964A46790C
  ID-3: /dev/sdc1 maj-min: 8:33 size: 579 MiB fs: ntfs
    label: System Reserved uuid: 5AD6D5CCD6D5A891
  ID-4: /dev/sdc2 maj-min: 8:34 size: 232.32 GiB fs: ntfs label: N/A
    uuid: AACED69CCED6605D
  ID-5: /dev/sdd1 maj-min: 8:49 size: 3.31 GiB fs: iso9660
  ID-6: /dev/sdd2 maj-min: 8:50 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: 928C-E79F
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: XMOS JDS Labs Element II type: Audio
    driver: snd-usb-audio interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 20b1:30da class-ID: fe01
  Hub-4: 3-2:3 info: Microchip (formerly SMSC) USB2734 ports: 5 rev: 2.1
    speed: 480 Mb/s chip-ID: 0424:2734 class-ID: 0900
  Hub-5: 3-2.1:4 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 3-2.1.2:6 info: SteelSeries ApS Mouse type: HID,Mouse
    driver: hid-generic,usbhid interfaces: 3 rev: 1.1 speed: 12 Mb/s
    power: 200mA chip-ID: 1038:1720 class-ID: 0300
  Device-2: 3-2.1.3:7 info: SanDisk Cruzer Glide type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 224mA
    chip-ID: 0781:5575 class-ID: 0806 serial: <filter>
  Device-3: 3-2.1.4:8 info: Focusrite-Novation Scarlett 6i6 type: Audio
    driver: snd-usb-audio interfaces: 6 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1235:8012 class-ID: fe01 serial: <filter>
  Device-4: 3-2.5:5 info: Microchip (formerly SMSC) Hub Controller type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 480 Mb/s
    chip-ID: 0424:274c class-ID: 0300
  Hub-6: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-7: 4-2:2 info: Microchip (formerly SMSC) USB5734 ports: 5 rev: 3.1
    speed: 5 Gb/s chip-ID: 0424:5734 class-ID: 0900
  Hub-8: 4-2.1:3 info: Genesys Logic hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 05e3:0616 class-ID: 0900
  Hub-9: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 5-1:2 info: Generic Dygma Shortcut Keyboard
    type: Abstract (modem),CDC-Data,HID driver: cdc_acm,hid-generic,usbhid
    interfaces: 4 rev: 2.0 speed: 12 Mb/s power: 500mA chip-ID: 1209:2201
    class-ID: 0300 serial: <filter>
  Hub-10: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 48.8 C mobo: N/A gpu: nvidia temp: 41 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 381 Uptime: 2m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1307 pacman: 1303 lib: 353
  flatpak: 4 Shell: Zsh v: 5.8 running-in: alacritty inxi: 3.3.12


Try with a Real Time Kernel by installing it via MSM-Kernels and also, try wireplumber instead of pipewire-media-session.

Might want to update the BIOS too

Thanks for the reply. I’ve updated my BIOS very recently as I’ve updated my CPU and it needed it.

I’ve installed wireplumber and went through the official instructions found here. So this includes installing wireplumber, enabling the user systemd services and configuring the “exec” section of /etc/pipewire/pipewire.conf. Unfortunately this doesn’t work and makes the system worse.

I couldn’t open firefox and respond with the error messages in the terminal when trying to manually start wireplumber and checking the wireplumber systemd status. The sound engine was going nuts which caused firefox to reliably freeze every time it’s opened. So, I’ve had to timeshift back to before I’ve installed wireplumber in order to finish this very post.

Briefly, when starting manually via “wireplumber” in the terminal, it responded saying it couldn’t start and could find “the bus”. Inputting systemctl --user --now status wireplumber produced a systemd unit that was enabled but was not started due the same error. Next, inputting sudo systemctl status wireplumber and sudo systemctl enable wireplumber both produced errors as wireplumber wasn’t able to be found by root.

I’m not sure where to go from here. An important note here though is that my voice briefly was normal at some point when trying to resolve the issue on my own and I created a timeshift snapshot of it. I’m fairly certain rebooting reverted the state back to microphone inputs being high-pitched again. I’m not sure what I have done.

Again, currently, my voice through my microphone is high-pitched. When recording through reaper, I can also hear that the track is freezing/popping at some points. Perhaps this has something to do with xruns and sampling rate? My sampling rate is set to 48Khz here which is the same as Windows so I’m not sure how that could be a problem.

Thanks again for all your help and apologies for the wall of text.


I haven’t found a permanent solution however I have recreated the state in which my machine does not output my voice as high-pitched. NOTE: I timeshifted my machine to before I’ve installed wireplumber.

in the terminal I launched reaper via:

    /etc/pipewire/media-session.d  pw-jack reaper                                                   ✔
jack: created client
jack: setting TIME_CRITICAL = 81
jack: activated client
/dev/cpu_dma_latency: permission denied
jack: deactivated client
jack: close client

(NOTE: The output above produces jack: deactivated client and jack: close client when I changed the reaper Audio System from JACK to PulseAudio)

which launched Reaper. I created a track but it didn’t sound correct. I went to Options > Preferences > Audio > Devices and set the Audio System from JACK to PulseAudio. All of a sudden, all my microphone tests system wide sounded at the correct pitch. For instance, when testing it via Discord, I hear my voice as it is normally.

Now if I log off or reboot the system, the problem comes back. Perhaps this can give someone insight into the root of the problem and how I can fix this permanently?

Having rebooted and retrying the methods described above, I can’t get my system to have the correct pitch of my voice when talking through my microphone again. I’m losing patience with this issue. Does anyone have any other ideas, at all?