I just Timeshiftereded back becauseafter update restart no internet


Recent windows xfer here, and I am loving everything about linux. Like everyone else I’m at an impass about the best next step here. Rather than beat myself up and spend the next weeks being stubborn, Trying the new approach lol. So far I was thinking : get the default updates like before, run some systemctrl status stuff from boot and diagnose that way maybe? so far with all my random problems(and fun solutions!) that’s where it leads. To the screen where if xserver fails and I get a login prompt.

Will be babysitting my post since I know there are some commands others might want output to them. Thank you in advance for your time and effort :slight_smile:

Same problem occurred on my PC with this update.
After several tests, I tried a Live session on an USB stick where ethernet was OK. So I tried a Timeshift restore and my network is now OK on Manjaro with the previous update.

Welcome to the forum! :vulcan_salute:

First of all, if you want help, then you’re going to have to give us a lot more information than “it doesn’t work”. Please read these two posts below… :arrow_down:

If your network adapter is the Realtek RTL8111/8168/8411, then open up the Manjaro Settings Manager, uninstall the r8168 driver, delete the blacklist for r8169 under /etc/modprobe.d — although removing r8168 should do that automatically already — and reboot.

The r8168 driver module is the driver from Realtek, and it is an out-of-tree module, because the official kernel driver for that chipset is r8169, which is already in the kernel.

The installation of the r8168 driver automatically blacklists r8169, and Manjaro used to do this by default because some people with older hardware were having problems with the in-kernel r8169 driver. But this is no longer applicable, and in fact, it is now r8168 that’s giving people problems. So remove it and use the in-kernel driver.

At least, the above all under the assumption that this is what’s going on with your computer, given that you didn’t provide us with any information. But we’re seeing a lot of issues with this network driver nowadays, so that’s why I’m writing this in advance.

[Stable Update] 2023-09-18 - Known issue and solutions

:arrow_right: 2023-09-18

▼ linux515-r8168 and linux61-6168 drivers fail to load r8168 driver

See this post for how to revert to using r8168 driver or install r8168-dkms driver from AUR
Problem with 6.5 kernel and-r8168 module

1 Like

Still, it bears preference to use the in-kernel r8169 driver over an out-of-tree driver from the AUR, and especially with hardware that’s less than four years old.

ding ding ding. Above and beyond you gawd. It was indeed network-r8168 that I have. going to re-get the updates and try the fix of removing it after the update. brb!

I did notice, before I restart. In my application manager (pacman GUI?) when i clicked the update tab, it was glitched out like a key on my keyboard was making it tab to another window. something about failed to sync to databases? AUR failed to sync? this was pre-update.

pamac — not pacman, which is command-line-only — has had some issues lately. Possibly yours had not been properly fixed yet.

This reply is being sent from a solved issue. Damn your good sir! Just so I understand it all correctly. My original r8168 (driver?) had its layer instead of the kernel’s base driver? the update has problems with the drivers I had, so just knocking back to base drivers allowed the connection?

:partying_face: :tada:

I just put new batteries in my crystal ball. :stuck_out_tongue:


Manjaro used to come with the r8168 driver installed by default if you have that chipset — we’re probably going to change this soon, but the latest ISOs still do it this way — and as such, the r8168 package automatically added the in-kernel r8169 driver to the blacklist.

But due to changes in all of the recent kernels, r8168 doesn’t properly work anymore, and unless you have really old hardware, you are better off with the official r8169 from the kernel developers.

Removing r8168 also removes the blacklist on r8169, and thus upon the next boot, r8169 will be loaded automatically. :wink:

1 Like


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.