Screen flickering issue after updating to Manjaro 6.1.12


I recently updated to 6.1 via pacman -Syu, and started having problems with one of my screens flickering. Though it only happens in certain conditions.
I have two monitors, one 1920x1080 240hz monitor and one 2560x1440 144hz monitor.
I have the 2560 screen left-rotated and the other in the normal orientation.
If i have both screens at their max refresh rates (240hz and 144hz respectively) while also having the 2560 monitor left oriented, I get screen flickering on the 1920 screen.
Setting the 1920 screen refresh rate to 60hz fixes the problem. Setting the 2560 screen to regular orientation instead of left orientation also fixes the problem.

The problem is present in both i3 and xfce, and I’ve tried killing picom which made no difference either.
It seems to be related to mouse movement in some way also though. If I let the mouse sit still for a few seconds, it seems to stop the flickering until I start using the mouse again.

Only the 1920 screen flickers. It flickers when I move the mouse, but not all the time. 10 seconds of mouse movement generates 3-5 flickers maybe.

nvidia-smi shows this:

| NVIDIA-SMI 525.89.02    Driver Version: 525.89.02    CUDA Version: 12.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
|  0%   48C    P5    37W / 175W |    561MiB /  8192MiB |     39%      Default |
|                               |                      |                  N/A |

| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      2184      G   /usr/lib/Xorg                     356MiB |
|    0   N/A  N/A      2281      G   alacritty                           8MiB |
|    0   N/A  N/A      2427      G   ...020387278939323895,131072      142MiB |
|    0   N/A  N/A      3404      G   alacritty                           8MiB |
|    0   N/A  N/A      3562      G   alacritty                           8MiB |


 ~  ➜ inxi --admin --verbosity=7 --filter --width
  Kernel: 6.1.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=bcbad29f-cd0e-4e57-8257-345dccd46e89 rw quiet apparmor=1
    security=apparmor resume=UUID=f1776472-c640-42dd-983f-18f98b518229
  Desktop: i3 v: 4.22 info: i3bar vt: 7 dm: LightDM v: 1.32.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME Z370-P II v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 0411
    date: 09/21/2018
  RAM: total: 31.29 GiB used: 4.37 GiB (14.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-9600K bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xF0
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 800 min/max: 800/4600 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
    bogomips: 44412
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA TU106 [GeForce RTX 2070] vendor: Micro-Star MSI
    driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 2 speed: 5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:1f02
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 compositor: Picom v: git-b700a driver:
    X: loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3360x2560 s-dpi: 93 s-size: 917x698mm (36.10x27.48")
    s-diag: 1152mm (45.37")
  Monitor-1: DP-4 pos: bottom-l res: 1920x1080 hz: 60 dpi: 90
    size: 544x303mm (21.42x11.93") diag: 623mm (24.52") modes: N/A
  Monitor-2: HDMI-0 pos: top-right res: 1440x2560 dpi: 93
    size: 392x697mm (15.43x27.44") diag: 800mm (31.48") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce RTX
    2070/PCIe/SSE2 direct-render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel
    bus-ID: 1-6.2:5 v: kernel bus-ID: 00:1f.3 chip-ID: 08bb:2902 class-ID: 0300
    chip-ID: 8086:a2f0 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-3: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.12-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: speed: Unknown
    lanes: 63 link-max: gen: 6 speed: 64 GT/s port: d000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: ASUSTek USB-N53 802.11abgn Network Adapter [Ralink RT3572]
    type: USB driver: rt2800usb bus-ID: 1-4:2 chip-ID: 0b05:179d class-ID: 0000
    serial: <filter>
  IF: wlp0s20f0u4 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 82.54 GiB (8.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 39.06 GiB size: 38.15 GiB (97.67%) used: 26.48 GiB (69.4%)
    fs: ext4 dev: /dev/sda6 maj-min: 8:6 label: N/A
    uuid: bcbad29f-cd0e-4e57-8257-345dccd46e89
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/sda5 maj-min: 8:5 label: NO_LABEL
    uuid: C919-25E5
  ID-3: /home raw-size: 195.31 GiB size: 191.19 GiB (97.89%)
    used: 56.06 GiB (29.3%) fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: N/A
    uuid: 3b122eae-ee4c-44e1-ade3-ccb9cf04d48f
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: f1776472-c640-42dd-983f-18f98b518229
  ID-1: /dev/sda1 maj-min: 8:1 size: 512 MiB fs: vfat label: N/A
    uuid: 51B1-91F1
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: ext4 label: N/A
    uuid: 3d2cde99-654c-4a17-a3fc-ea3b7f72307f
  ID-3: /dev/sda3 maj-min: 8:3 size: 628.26 GiB fs: ntfs label: N/A
    uuid: D2A6C7ABA6C78E83
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: ASUSTek USB-N53 802.11abgn Network Adapter [Ralink
    RT3572] type: Network driver: rt2800usb interfaces: 1 rev: 2.0
    speed: 480 Mb/s power: 450mA chip-ID: 0b05:179d class-ID: 0000
    serial: <filter>
  Hub-2: 1-6:3 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-6.1:4 info: Logitech G203 Gaming Mouse type: Mouse,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 300mA
    chip-ID: 046d:c084 class-ID: 0300 serial: <filter>
  Device-2: 1-6.2:5 info: Texas Instruments PCM2902 Audio Codec
    type: Audio,HID driver: hid-generic,snd-usb-audio,usbhid interfaces: 4
    rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 08bb:2902 class-ID: 0300
  Device-3: 1-6.3:6 info: TG3 RGB POK3R type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0f39:0617 class-ID: 0300
  Hub-3: 2-0:1 info: Super-speed hub ports: 10 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 2-6:2 info: Genesys Logic Hub ports: 4 rev: 3.2 speed: 5 Gb/s
    chip-ID: 05e3:0626 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: nvidia temp: 50 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 236 Uptime: 1h 7m wakeups: 1 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1250 pm: pacman pkgs: 1242 libs: 333 tools: pamac,yay pm: flatpak
  pkgs: 0 pm: snap pkgs: 8 Shell: Zsh v: 5.9 running-in: alacritty inxi: 3.3.25

Let me know if I can run any commands or share any relevant logs!

Any help is appreciated.

Hi @loofv, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

Phew What a mouthful! Now I’ve got to ask you:

  1. have you tried using a different kernel?
  2. I see you’re using the 5.25 Nvidia driver. Have you tried downgrading it?

I have added output of inxi, I don’t think I missed anything else from your links. Please let me know if I can do anything else.

I considered downgrading the kernel, but won’t that risk making all my packages out of sync?
Same with the nvidia driver, I would have to downgrade all the other nvidia-related packages. I’m worried more things will break that way.

If you use Manjaro’s own tools to do it, I recommend mhwd, then there’s no problem Manjaro allows you to have multiple kernels installed. I, myself, have 3 installed:

$ mhwd-kernel --listinstalled
Currently running: 6.2.0-1-MANJARO (linux62)
The following kernels are installed in your system:
* linux515
* linux61
* linux62

To install a different one:

(Version 5.15 for example.)

mhwd-kernel --install linux515

More here:

The Nvidia drivers are a bit more tricky in that you can have 1 installed. To see which ones are available top you, tun:

mhwd --list

For example:

$ mhwd --list
> 0000:01:00.0 (0300:10de:1401) Display controller nVidia Corporation:
NAME               VERSION          FREEDRIVER           TYPE
video-nvidia            2021.11.04               false            PCI
video-nvidia-470xx            2021.11.04               false            PCI
video-nvidia-390xx            2021.11.26               false            PCI
video-linux            2018.05.04                true            PCI
video-modesetting            2020.01.13                true            PCI
video-vesa            2017.03.12                true            PCI

You have the 525.xx series, same as me. so the previous one would be the 470.xx series. You have to remove the current one first:

mhwd --remove pci video-nvidia

!Do not reboot!

Then install the other driver:

mhwd --install pci video-nvidia-470xx

If done without errors, you can say a little prayer, do a little good luck dance, cross you heart, and reboot.

If it worked, heap on the praise. If, however, it didn’t, I’m innocent and not here.

More here:

1 Like

Thanks for your tips!

Maybe I’m being silly now, but after installing 5.15 and rebooting it’s still running 6.1.12. Shouldn’t it change after a reboot or do I need to do anything else?
EDIT: Yes I was silly, I changed to 5.15 at the GRUB screen. But the nvidia problem persists.

 ~  ➜ mhwd-kernel --listinstalled
Currently running: 6.1.12-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux513
   * linux515
   * linux61

Nvidia is also acting strange:

 ~  ➜ mhwd --list
> 0000:01:00.0 (0300:10de:1f02) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

 ~  ➜ sudo mhwd --remove pci video-nvidia
[sudo] password for loveh:
Error: config 'video-nvidia' is not installed!
 ~  ➜

Only shows what’s available, not installed. To see what’s installed, tun:

mhwd --listinstalled

Regarding the kernel, once you’ve installed it, you have to select it on reboot. To do so:

  1. Reboot your computer.
  2. Just after it has switch on, during the BIOS/UEFI splash screen, press the Esc and Left Ctrl, respectively, repeatedly.
  3. This should cause the GRUB boot menu to appear. On it, select the Advanced… menu and press Enter to select it.
  4. On this screen, select the kernel you wish to use, and boot with it by pressing Enter.

More here:

Hope this helps!

1 Like

Yes, I brainfarted and forgot that you have to manually select at the GRUB screen, thanks!

It seems to think I have no nvidia drivers installed:

~  ➜ mhwd --listinstalled
Warning: No installed PCI configs!
Warning: No installed USB configs!
 ~  ➜ sudo mhwd --install pci video-nvidia-470xx

> Installing video-nvidia-470xx...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-470xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
:: ffmpeg optionally requires nvidia-utils: Nvidia NVDEC/NVENC support
:: ffmpeg4.4 optionally requires nvidia-utils: Nvidia NVDEC/NVENC support
:: steam optionally requires vulkan-driver: packaged vulkan driver
:: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver
warning: dependency cycle detected:
warning: eglexternalplatform will be removed after its nvidia-utils dependency

Packages (5) egl-wayland-2:1.1.11-3  eglexternalplatform-1.1-2  libxnvctrl-525.89.02-1  linux515-nvidia-525.89.02-3  nvidia-utils-525.89.02-1

Total Removed Size:  715,73 MiB

:: Do you want to remove these packages? [Y/n]
:: Processing package changes...
removing linux515-nvidia...
removing nvidia-utils...
removing libxnvctrl...
removing egl-wayland...
removing eglexternalplatform...
:: Running post-transaction hooks...
(1/6) Reloading system manager configuration...
(2/6) Reloading device manager configuration...
(3/6) Arming ConditionNeedsUpdate...
(4/6) Updating module dependencies...
(5/6) Reloading system bus configuration...
(6/6) Updating the desktop file MIME type cache...
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
error: target not found: linux513-nvidia-470xx
Error: pacman failed!
Error: script failed!
 ~  ➜

Maybe I should remove my 5.13 kernel so it doesn’t look for that target? If that’s even how it works.

Ah! That is because you have an EOL kernel still installed. And since it’s been EOL for quite some time, I have to wonder if your system’s updated. But anyway, remove that kernel first:

mhwd --remove linux513

Again, do not reboot and try again.

1 Like

That did the trick, thank you! kernel 5.15 with the 470 Nvidia drivers works again. Marking your last entry as the solution.
I updated my system with pacman -Syu, maybe that’s not the way to go on Manjaro. I’m learning about Arch as well on another computer so I’m sort of in between atm.

Huge thanks for your help!

You’re welcome!

For updating your system, I recommend:

pamac upgrade && pamac upgrade --aur --devel || echo -e '\033[0;91mThere was an error upgrading the system. AUR packages not upgraded.\e[0m'

This will update your system and ONLY if that was successful update any AUR packages.

a Reminder: While use of the AUR is possible, it’s neither recommended nor supported.

I recommend pamac instead of pacman, especially for newcomers as pamac was developed by Manajaro (developers) for Manjaro and just takes care of more thing than pacman.

Since there was an EOL kernel installed, try using the newer drivers again? If you want to…

Thank you! I’ll give that a try next time :slight_smile:

It seems that new driver + manjaro61 was the issue, but I might try them both again with the EOL kernel removed to see if that made it work.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.