Very unstable system?!

Hi, this is my first post on this forum and you need to know this is my last resort.
I know this post is long and my english is not perfect, but I don’t have other options.

I have bee using manjaro for almost three years now, most of the time with no issue.
Last month I accidentally damaged the system, and I was forced to reinstall it. It was a mess. For some reason windows was on MBR and manjaro was on GPT and it was working fine for almost three years, but now I was not able to recreate it, boot loader kept installing the wrong way (from what I have read installing multiple systems on both GPT and MBR should be impossible, but I did it somehow not even knowing what I was doing)
So I created a backup, set UEFI to factory settings and reinstalled both systems on GPT…

…and that is the point where things started going sideways.

An update broke somehow something associated with graphic driver, and i did not manage to find what, because running mhwd command have erased all my data on that drive. (I know that is not what this command usually does)
I have reinstalled manjaro only to find grub rescue displayed on the screen. I have reinstalled grub from live usb and found that every time I reinstall grub from that iso It works only once. So I have tried to flash that usb using first usb imager i have found in official repository. Probably it had to be something with the faulty manjaro iso, (I don’t know what really have happen) but it have flushed on all connected usb devices, so that is my backup gone.
Anyway after installing manjaro from last release (previously I have tried to find the same iso i have used years ago to install manjaro on GPT while windows would stay on MBR, but I failed to do so) almost once a week boot loader of manjaro (I have two boot loaders on both disks) went missing leaving me with grub rescue. So every time I just chrooted from live usb and reinstalled grub. It was annoying but manageable (I have checked this disk a few times and everything seems to be ok, so most likely it have to be something with manjaro).
Today I did not manage to reinstall grub. Manjaro-chroot -a did not work (==> ERROR: No Linux partitions detected!). Neither manjaro partition nor the boot partition is mountable, so RIP my files again.
I have tried to fix that using fsck.
Before the problem was: “mount(2) system call failed: Structure needs cleaning.”
now: “mount(2) system call failed: No such file or directory.”.

Something different that could be meaningful: from time to time manjaro would just crash for no reason. It is much less frequent since I have installed video-nvidia-470xx.

I do not know what to do, I do not have time reinstall manjaro over and over.
I have lost so many time already. (I study IT so most of my work is gone) I am so frustrated.
Is any of this supposed to happen? Is it normal? What am I doing wrong?
It seems like the only thing that have worked for me was this stupid GPT-MBR system.
I was big fan of manjaro from the moment I have first installed it, but now I am torn apart
Is really this garbage from microS###t really superior if it stand on reliability?
I hate so much every their system after seeing how much is possible on linux but now I just do not know.

Considering you mention later you have two disks, i suppose you mean to have Windows on a disk with MBR, and Manjaro on the other with GPT. This is entirely feasible.
Here GPT and MBR are about disk partition tables. There is only one such table per disk (hence the name), and each disk uses its own. So you can very well have multiple disks, mixing MBR and GPT.
You may confuse this with MBR and EFI, in the sense of boot loading. Those are different methods of staring and booting entries for operating systems, and usually can’t be mixed without issues.

On a side note, there have also been numerous reports of Windows updates overriding the boot loader. Though your situation does seem more complicated.

Well, there are many occurrences of that discussed here, usually because of a kept unsupported kernel.

More than not what is “usually” does, rather definitely not what it can do: mhwd is a utility for managing specific packages, namely kernels and drivers. I highly doubt you lost all your data because of it.

Have you checked your drives’ health? If the file system begins behaving erratically, this is usually a sign of drive failure…

Please also provide information about your system.

Yeah, I didn’t know that back there. I’ve got windows on MBR disk and I have later installed manjaro with /boot/efi partition on GPT disk. It was the only stable configuration I ever got on current device.

The last thing I have done, was running mhwd while trying to reinstall graphics driver, then screen went black. After booting from usb I have found most of metadata missing.

smartctl output:

Model Number:                       addlink M.2 PCIE G3x4 NVMe
Serial Number:                      CAF407020D7A00994222
Firmware Version:                   ECFM22.6
PCI Vendor/Subsystem ID:            0x1987
IEEE OUI Identifier:                0x6479a7
Total NVM Capacity:                 512,110,190,592 [512 GB]
Unallocated NVM Capacity:           0
Controller ID:                      1
NVMe Version:                       1.3
Number of Namespaces:               1
Namespace 1 Size/Capacity:          512,110,190,592 [512 GB]
Namespace 1 Formatted LBA Size:     512
Namespace 1 IEEE EUI-64:            6479a7 303013700f
Local Time is:                      Wed Nov  9 22:53:32 2022 UTC
Firmware Updates (0x12):            1 Slot, no Reset required
Optional Admin Commands (0x0017):   Security Format Frmw_DL Self_Test
Optional NVM Commands (0x005d):     Comp DS_Mngmt Wr_Zero Sav/Sel_Feat Timestmp
Log Page Attributes (0x08):         Telmtry_Lg
Maximum Data Transfer Size:         512 Pages
Warning  Comp. Temp. Threshold:     75 Celsius
Critical Comp. Temp. Threshold:     80 Celsius

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +     5.55W       -        -    0  0  0  0        0       0
 1 +     4.49W       -        -    1  1  1  1        0       0
 2 +     3.97W       -        -    2  2  2  2        0       0
 3 -   0.0490W       -        -    3  3  3  3     2000    2000
 4 -   0.0018W       -        -    4  4  4  4    25000   25000

Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 +     512       0         2
 1 -    4096       0         1

SMART overall-health self-assessment test result: PASSED

SMART/Health Information (NVMe Log 0x02)
Critical Warning:                   0x00
Temperature:                        27 Celsius
Available Spare:                    100%
Available Spare Threshold:          5%
Percentage Used:                    4%
Data Units Read:                    41,041,053 [21.0 TB]
Data Units Written:                 25,558,126 [13.0 TB]
Host Read Commands:                 249,305,378
Host Write Commands:                110,977,615
Controller Busy Time:               771
Power Cycles:                       2,454
Power On Hours:                     5,219
Unsafe Shutdowns:                   107
Media and Data Integrity Errors:    0
Error Information Log Entries:      2,042
Warning  Comp. Temperature Time:    0
Critical Comp. Temperature Time:    0

Error Information (NVMe Log 0x01, 16 of 63 entries)
Num   ErrCount  SQId   CmdId  Status  PELoc          LBA  NSID    VS
  0       2042     0  0x6017  0x4004  0x028            0     0     -

inxi -v7azy output:

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2137 quiet systemd.show_status=1
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 5851
    date: 06/16/2021
  Message: No system battery data found. Is one present?
  RAM: total: 15.53 GiB used: 3.41 GiB (22.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x71 (113)
    stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2560 high: 3603 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2192 2: 3369
    3: 2092 4: 2202 5: 2213 6: 2200 7: 3603 8: 3599 9: 2058 10: 2800 11: 2200
    12: 2202 bogomips: 86425
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme smep ssbd sse
    sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
    topoext tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme
    vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nvidia v: 515.65.01
    alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current (as of
    2022-07) arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.0 chip-ID: 10de:1b81
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.87x11.85")
    s-diag: 610mm (24")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: NVIDIA GP104 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 09:00.1 chip-ID: 10de:10f0
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0b:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: ASUSTeK
    driver: bcma-pci-bridge v: N/A modules: bcma pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 06:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 07:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-3: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
    bus-ID: 1-4:3 chip-ID: 0cf3:9271 class-ID: ff00 serial: <filter>
  IF: wlp2s0f0u4 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 957.44 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:5 vendor: Kingston model: SA2000M8500G
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: S5Z42105 temp: 30.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Addlink model: M.2 PCIE G3x4
    NVMe size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: ECFM22.6
    temp: 26.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 type: USB vendor: A-Data model: USB Flash
    Drive size: 14.74 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 0.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:6 size: 50 MiB fs: vfat label: N/A
    uuid: 0EBF-0962
  ID-2: /dev/nvme0n1p2 maj-min: 259:7 size: 232.83 GiB fs: ntfs label: N/A
    uuid: 06DC71A0DC718AA7
  ID-3: /dev/nvme0n1p3 maj-min: 259:8 size: 232.34 GiB fs: ntfs label: N/A
    uuid: B6D6C5F9D6C5B9BF
  ID-4: /dev/nvme0n1p4 maj-min: 259:9 size: 551 MiB fs: ntfs label: N/A
    uuid: C4C0664EC06646B0
  ID-5: /dev/nvme1n1p1 maj-min: 259:1 size: 97.7 GiB fs: ntfs label: N/A
    uuid: 36924AB76AAD6230
  ID-6: /dev/nvme1n1p2 maj-min: 259:2 size: 100 GiB fs: f2fs label: manjaro
    uuid: a4a835f9-373e-40f2-abf2-f1c0d31d6b9e
  ID-7: /dev/nvme1n1p3 maj-min: 259:3 size: 18.73 GiB fs: swap label: N/A
    uuid: 35499b25-fd6f-4455-818c-cc127c936e2b
  ID-8: /dev/nvme1n1p5 maj-min: 259:4 size: 260 GiB fs: f2fs label: N/A
    uuid: 9411274b-a94b-4b09-805d-1cd5e28ec11e
  ID-9: /dev/sda1 maj-min: 8:1 size: 3.32 GiB fs: iso9660
  ID-10: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: C80E-8B3F
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: A-DATA C008 Flash Drive type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 480mA
    chip-ID: 125f:c08a class-ID: 0806 serial: <filter>
  Device-2: 1-4:3 info: Qualcomm Atheros AR9271 802.11n type: Network
    driver: ath9k_htc interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0cf3:9271 class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 5-1:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 5-1.1:3 info: Pixart Imaging HID Wireless Dongle
    type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 093a:8312 class-ID: 0301
    serial: <filter>
  Device-2: 5-1.3:4 info: Logitech Unifying Receiver
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-3: 5-1.4:5 info: Microsoft Wireless Receiver 1461C
    type: Keyboard,Mouse,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 045e:07a5 class-ID: 0300
  Hub-7: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 42.6 C mobo: N/A gpu: nvidia temp: 33 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
  Processes: 273 Uptime: 33m wakeups: 0 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: pacman: 1204 lib: 316 flatpak: 0 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.20

Partitioning of the “manjaro disk”:

# fdisk -l /dev/nvme1n1                                                                    ✔ 
Disk /dev/nvme1n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: addlink M.2 PCIE G3x4 NVMe              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: A45D7796-60C2-BE45-9F05-D761B58A0140

Device             Start        End   Sectors  Size Type
/dev/nvme1n1p1 250054656  454946815 204892160 97.7G Microsoft basic data
/dev/nvme1n1p2      2048  209717247 209715200  100G Linux filesystem
/dev/nvme1n1p3 209717248  249006079  39288832 18.7G Linux swap
/dev/nvme1n1p5 454946816 1000214527 545267712  260G Linux filesystem

Partition table entries are not in disk order.

There was vfat partition, but I have tried to reinstall grub a few times and formatted it. Now it is unallocated space.
nvme1n1p2 is partition on which manjaro is installed. It can not be mounted. I did not preform any actions on it besides fsck.f2fs
Even if both nvme1n1p1, nvme1n1p5 are on the same disk they are fully mountable and functional.

On nvme1n1p2 There is(or was) mostly the same software setup. I kept everything up to date, some drivers may differ but I am not able to recall evertything

This “tells” me that your system was not updated in quite some time. Stable has 5.15.76-1now.

Would aim to use only one sound server.

I would use at least a swapfile or zram-generator

If for some reason you have to use a lower version kernel, older, than the one you used to create the partition, things can get really messy. Mentioned too in the Warning section of F2FS - ArchWiki

1 Like

Sorry if I was not clear about it: I have generated this info using live USB, I’m not able to mount my system partition and chroot into it. It’s mostly the same, but on my system I kept everything up to date.

you mentioned two disk, one with win and one with manjaro, but in the

there is windows and also manjaro installed on the same disk?

what file system are you using? is it encrypted?

fast boot disabled in bios - you may not have this option;
secure boot disabled in bios;
AHCI enabled in bios - if you have RAID, and switch to AHCI, you will not be able to boot into windows;

how did you flash the iso? did you use Ventoy?

From live session you do not have access to any of the linux data you have, you can’t mount those partitions from a File Manager either?

might be helpful:

Windows is on the other one.

For linux I’m using f2fs with no encryption.

Those are disabled.

If you are referring to this:

It is likely but, I don’t really remember. It’s more probable there was something wrong with my copy of a old manjaro iso I have been using back then. I’ve just remembered that I had to quickly compile some c++ code on that system, and it did not compile properly. It was not sequential: it randomly jumped from line to line, always in the same wrong order (sometimes it tried to disallocate memory even before it was allocated)

Now I am using “Win32DiskImager” on windows.

I was not able to mount either vfat with grub nor f2fs with manjaro. File manager also can’t mount them. Other partitions work fine.

Thanks! I will try this when I’m back.

This tool seems to be really amazing, but sadly I had little to no use out of it.
After running “fix linux system” (or something similar, there was only one option that seemd like it could help)
I believe it just runs fsck.

Something worth mentioning: this system couldn’t mount my linux system partition.
After running almost any of it’s repair tools, there is a prompt to select partition to run it on. Next to this system partition there is: “unable to mount” message.

use Ventoy, and download the latest iso from

also check this link regarding f2fs - which also could be a reason for your issues:

I really do not know how I didn’t have found this tool before. It makes life so much easier.

I’ve got that problem before. I did solve it by physically removing drive containing windows and connecting it again after installation.

yes ventoy is very good…
did you run fsck on your system?:

sudo fsck.f2fs -f /dev/nvme1n1p2
sudo fsck.f2fs -f /dev/nvme1n1p5


The output now says:

fsck from util-linux 2.38.1
Info: Force to fix corruption
Info: MKFS version
  "Linux version 5.15.60-1-MANJARO (builduser@fv-az462-678) (gcc (GCC) 12.1.1 20220730, GNU ld (GNU Binutils) 2.39) #1 SMP PREEMPT Thu Aug 11 13:14:05 UTC 2022"
Info: FSCK version
  from "Linux version 5.15.60-1-MANJARO (builduser@fv-az462-678) (gcc (GCC) 12.1.1 20220730, GNU ld (GNU Binutils) 2.39) #1 SMP PREEMPT Thu Aug 11 13:14:05 UTC 2022"
    to "Linux version 5.15.60-1-MANJARO (builduser@fv-az462-678) (gcc (GCC) 12.1.1 20220730, GNU ld (GNU Binutils) 2.39) #1 SMP PREEMPT Thu Aug 11 13:14:05 UTC 2022"
Info: superblock features = 0 : 
Info: superblock encrypt level = 0, salt = 00000000000000000000000000000000
Info: Segments per section = 1
Info: Sections per zone = 1
Info: total FS sectors = 209715200 (102400 MB)
Info: CKPT version = 5ee4987f
Info: Checked valid nat_bits in checkpoint
Info: checkpoint state = 281 :  allow_nocrc nat_bits unmount
[ASSERT] (sanity_check_nid: 404)  --> nid[0x3] ino is 0

[FSCK] Max image size: 244 MB, Free space: 100666 MB
[FSCK] Unreachable nat entries                        [Ok..] [0x0]
[FSCK] SIT valid block bitmap checking                [Ok..]
[FSCK] Hard link checking for regular file            [Ok..] [0x0]
[FSCK] valid_block_count matching with CP             [Ok..] [0x0]
[FSCK] valid_node_count matching with CP (de lookup)  [Ok..] [0x0]
[FSCK] valid_node_count matching with CP (nat lookup) [Ok..] [0x0]
[FSCK] valid_inode_count matched with CP              [Ok..] [0x0]
[FSCK] free segment_count matched with CP             [Ok..] [0xc71b]
[FSCK] next block offset is free                      [Ok..]
[FSCK] fixing SIT types
[FSCK] other corrupted bugs                           [Fail]
Info: Duplicate valid checkpoint to mirror position 512 -> 1024
Info: Write valid nat_bits in checkpoint

Done: 0.000000 secs

Does this mean that for some reason all data was erased?

if its the 100gb nvme1n1p2, then it looks like its really empty …
and you cant access the f2fs partitions?
and if you check in kde partition manager, did it shows that there are some files?

Only system one now, I couldn’t access vfat /boot/efi pratition before, but I have erased it few times trying to reinstall grub. Other partitions work fine.

Partition manager says nothing about files, but I don’t really believe what it says, there was never anything about flags or mount points, just blank spae.

with files i meant, if it shows how much is used, or if it shows the partition as empty…
since you cant access it, you could try reinstall again, but this time dont use f2fs

I can’t force it to work. It just shows:

Size:         100.00 GiB
Available:    --
Used:         --

I will try, but before that I will create bit to bit copy of that partition using dd. Maybe I will find a way to restore damaged part of that partition.

I don’t think f2fs is a reason of this failure. I’ve been using it for years now without an issue. Only recently after I’ve reinstalled windows (this time on GPT, before it was on MBR) strange stuff started to happen.