Desktop environment doesn't start up after switching to a AMD Radeon 3700 XT

I’m going to start this out by mentioning that I previously had an Nvidia GPU.
I now have a new GPU, but now when I start my PC, I only get this:

/dev/sdb2: recovering journal
/dev/sdb2: clean, 2770081/28712960 files, 92343931/114828068 blocks

I have tried looking for a solution for this
But this did not work.
Thx in advance :slight_smile:

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

(Wisdom lies in asking → listening → reading :wink: )

1 Like

I cannot send you this output. I am currently in my shell. If I was able to send output here I would’ve.
(Also I know you probably copy that text but it comes off as extremely patronizing)

If possible, try to use a live-manjaro :wink:

You even can compare the inxi from there, with the inxi you get now from tty.
(or even better post both)

Most people don’t say how familiar they are with:

  • TTY
  • Formatting in a forum
  • English (some posts are poorly translated)
  • Linux at all
  • what they have already tried
  • what they did before the problem arose :wink:

It is possible to retrieve this information individually. And you will find threads that have >100 posts because important information was missing at the beginning.

Therefore, the “demand” for information is necessary so that anyone who reads it can see if they can help you in any way. (also translated :wink: )

I am open to any suggestion that would make the text more acceptable. However, I can’t change anything in the linked posts :wink:

here it is

  Kernel: 6.1.30-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_GNOME_2213 quiet
    systemd.show_status=1 splash driver=free nouveau.modeset=1 i915.modeset=1
  Desktop: GNOME v: 43.5 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM v: 44.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: B550-A PRO (MS-7C56) v: 1.0
    serial: <filter> UEFI: American Megatrends LLC. v: A.50 date: 01/15/2021
  Message: No system battery data found. Is one present?
  System RAM: available: 7.68 GiB used: 2.22 GiB (28.9%)
  Array-1: capacity: 128 GiB slots: 4 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM 0 type: no module installed
  Device-2: DIMM 1 type: no module installed
  Device-3: DIMM 0 type: no module installed
  Device-4: DIMM 1 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: 3000 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits):
    data: 64 total: 64 manufacturer: Crucial part-no: BL8G30C15U4B.M8FE1
    serial: <filter>
  Info: model: AMD Ryzen 5 3500X socket: AM4 bits: 64 type: MCP arch: Zen 2
    gen: 3 level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 2433 high: 3600 min/max: 2200/4120 boost: enabled
    base/boost: 3600/4100 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 2200 2: 2200 3: 3600 4: 2200
    5: 2200 6: 2200 bogomips: 43215
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sev sev_es sha_ni skinit smap smca smep ssbd sse sse2
    sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext
    tsc tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M/6850M XT]
    vendor: Sapphire driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    ports: active: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 2d:00.0
    chip-ID: 1002:73df class-ID: 0300
  Display: server: v: with: Xwayland v: 23.1.1
    compositor: gnome-shell driver: gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-size: <missing: xdpyinfo>
  Monitor-1: DP-3 model: 27E1Q serial: <filter> built: 2021 res: 2560x1440
    hz: 60 dpi: 108 gamma: 1.2 size: 600x330mm (23.62x12.99") diag: 685mm (27")
    ratio: 16:9 modes: max: 2560x1440 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon RX 6700 XT (navi22
    LLVM 15.0.7 DRM 3.49 6.1.30-1-MANJARO) direct-render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 2d:00.1 chip-ID: 1002:ab28
    class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.1.30-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    with: pulseaudio-alsa type: plugin tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 2a:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp42s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.36 TiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM010-2EP102
    family: BarraCuda 3.5 (CMR) size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B sata: 3.0 speed: 6.0 Gb/s tech: HDD rpm: 7200
    serial: <filter> fw-rev: CC43 temp: 40 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 1y 347d 20h cycles: 529
    read: 47.36 TiB written: 62.6 TiB Pre-Fail: attribute: Spin_Retry_Count
    value: 100 worst: 100 threshold: 97
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400M8480G
    family: Driven SSDs size: 447.13 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.2 speed: 6.0 Gb/s tech: SSD serial: <filter>
    fw-rev: 62B3 temp: 40 C scheme: GPT
  SMART: yes state: enabled health: PASSED on: 1y 345d 14h cycles: 529
    read: 74627 GiB written: 29316 GiB
  ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: Cruzer Blade
    size: 14.91 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 1.00
    scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Optical-1: /dev/sr0 vendor: MATSHITA model: DVD-RAM SW830 rev: 1.00
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 931.51 GiB fs: ext4 label: steam
    uuid: 8429e1cf-59ff-4c60-8719-afef771111fb
  ID-2: /dev/sdb1 maj-min: 8:17 size: 300 MiB fs: vfat label: NO_LABEL
    uuid: 61E7-70C5
  ID-3: /dev/sdb2 maj-min: 8:18 size: 438.03 GiB fs: ext4 label: N/A
    uuid: 1ac35c4b-154d-4d98-94b4-2d5193b3401e
  ID-4: /dev/sdb3 maj-min: 8:19 size: 8.8 GiB fs: swap label: N/A
    uuid: 10f62d63-c416-461c-9990-b380d99d2019
  ID-5: /dev/sdc1 maj-min: 8:33 size: 3.45 GiB fs: iso9660
  ID-6: /dev/sdc2 maj-min: 8:34 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: D0A3-C7FC
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 05e3:0608 class-ID: 0900
  Device-1: 1-2.3:4 info: SINOWEALTH Game Mouse type: mouse,keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 256mA chip-ID: 258a:1007 class-ID: 0301
  Device-2: 1-2.4:6 info: Microdia USB DEVICE type: keyboard,mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 400mA chip-ID: 0c45:7698 class-ID: 0301
  Device-3: 1-7:3 info: Micro Star MYSTIC LIGHT type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 500mA chip-ID: 1462:7c56 class-ID: 0300
    serial: <filter>
  Device-4: 1-10:5 info: SanDisk Cruzer Blade type: mass storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s (57.2 MiB/s)
    lanes: 1 mode: 2.0 power: 200mA chip-ID: 0781:5567 class-ID: 0806
    serial: <filter>
  Hub-3: 2-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-4: 3-0:1 info: hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-5: 4-0:1 info: super-speed hub ports: 4 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 53.8 C mobo: N/A gpu: amdgpu temp: 49.0 C
    mem: 46.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 272 Uptime: 1m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1240 libs: 315 tools: gnome-software,pamac pm: flatpak pkgs: 0
  Shell: Zsh (sudo) v: 5.9 default: Bash v: 5.1.16 running-in: gnome-terminal
  inxi: 3.3.27

Please I really need help

I can’t do much for you since graphics cards are not my area of expertise

(I’m afraid it could get worse :wink: )
And all the people here help in their free time. Therefore, you may have to wait for someone to sign up who can help you.
In the meantime, you can re-read what has already been posted and linked, or you can try using forum search.

Hello @mattus,

did you install/uninstall/change graphic drivers before you change the gpu’s?

Normally if you still can login you can try to install the drivers with 'mhwd’ like discribed in the wiki.

This should install the right (nonfree) drivers:

sudo mhwd -a pci nonfree 0300 

If you want to use the free drivers change 'nonfree’ to 'free'. This is what I would try at first. :slightly_smiling_face:

1 Like

You can also save command output to a file from within a TTY.
Here is an example:

sudo inxi --admin --verbosity=7 --filter --no-host --width > ~/output.txt

Notice the > ~/output.txt at the end? This effectively redirects the output that would have been printed to screen, to the named text file instead. In this way you can take that file and post the content later, any way you see fit.

The drivers seem to be installed already,
I get the result:

> Skipping already installed config 'video-linux' for device: 0000:2d:00.0 (0300:1200:73df) Display controller in ATI Technologies Inc Navi 22 [Radeon RX 6700/6700 XT / 6800M]

There is a recent thread Switch from Nvidia gpu to Amd gpu basically on the same topic that might be helpful.

1 Like

I have now made progress and it’s booting but stops at

Starting Hold until boot process finishes up...
Starting Terminate Plymouth Boot Screen...

post pic of:
mhwd -l -li
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"

it didnt detected any available drivers… check again with:
mhwd -l
inxi -G

so you are in chroot? so you can normally boot into manjaro live usb?
post output also from:
mhwd-kernel -li
pacman -Qm
and if you can provide normal text output …

Plymouth is unnecessary and can often cause boot issues. I suggest you uninstall it according to the instructions at Plymouth Manjaro under the heading Removal. Cheers.

Aside:- Once you’re up and running again, you might like to take a look at RustDesk as an alternative to anydesk-bin.

yeah, i am in chroot. I didn’t want to manually take photos of my screen.
Anyways, here’s the stuff:

sudo chroot /run/media/manjaro/1ac35c4b-154d-4d98-94b4-2d5193b3401e
[manjaro-gnome /]# mhwd-kernel -li
Currently running: 6.1.30-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux419
   * linux510
[manjaro-gnome /]# pacman -Qm
android-emulator 33.1.23-1
android-sdk 26.1.1-2
android-studio 2023.1.1.26-1
anydesk-bin 6.3.0-1
archlinux-java-run 10-1
arcus 5.0.0-3
audiorelay 0.27.5-3
balena-etcher 2:1.18.13-1
breath2-wallpaper 1.0.18-5
cef-minimal 119.4.3-1
celt 0.11.3-6
cura 5.3.0-1
cura-resources-materials 5.6.0-1
curaengine 4.13.1-3
debtap 3.5.1-1
ebsynth-git r16.2f5c97c-1
electron19 19.1.9-5
electron7-bin 7.3.3-5
evince-no-gnome 44.1-1
gamemaker-beta 2023.200.0.299-1
gb-studio 3.1.0-1
gconf 3.2.6+11+g07808097-10
genymotion 3.5.1-1
gnome-icon-theme 3.12.0-7
gnome-icon-theme-symbolic 3.12.0-6
google-chrome 120.0.6099.71-1
gtk-theme-breath 5.9.0-1
jre 21.0.1-1
js78 78.15.0-4
libcpufeatures-git 0.7.0+15.r284.d20220617.3c4801d-1
libgbinder 1.1.35-1
libglibutil 1.0.74-1
libopenaptx 0.2.0-1
libsavitar 4.13.0-1
libsidplay 1.36.59-10
lxc-git 4.0.0.r2149.g2ac414d56-1
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
mcreator 2023.3.36712-1
minecraft-launcher 1:1.0.1221-1
noto-fonts-compat 20151217-1
opencolorio1 1.1.1-3
parsec-bin 150_86e-4
python-argparse 1.4.0-14
python-backcall 0.2.0-8
python-gbinder 1.1.2-1
python-mapbox-earcut 1.0.1-1
python-pep517 0.13.0-4
python-progress 1.6-8
python-pyglet 2.0.10-1
python-pyinstrument 4.6.1-1
python-pynest2d 4.12.0-1
python-sip4 4.19.25-5
python-svg.path 6.2-1
python-trimesh 4.0.5-1
qt5-webkit 5.212.0alpha4-20
rarcrack 0.2-6
sidequest-bin 0.10.38-1
steamcmd latest-3
substance-painter 8.1.3-1
systemd-fsck-silent 239-1
teamviewer 15.48.4-1
transcode 1.1.7-42
twitch-bin 1.0.4-8
uranium 5.0.0-2
urn-git r133.09c0756-1
visual-studio-code-bin 1.85.0-1
waydroid 1.4.2-1
waydroid-image-gapps 18.1_20231125-1
wine-gui-git 0.14alpha.54.gff60462-1
xclicker 1.5.0-1
xkb-switch 1.8.5-1
xp-pen-tablet 1:
yay-git 12.2.0.r1.g643830f-1

these are your kernels, they are older, so install a newer one, the 6.1:
pacman -S linux61
remove this:

pacman -R celt breath2-wallpaper manjaro-documentation-en manjaro-firmware

exit chroot and reboot…