Firefox runs without interface

I am on KDE Plasma desktop version of Manjaro.

Tried running from terminal. No error, nothing it just ran without any GUI window spawning.

pgrep firefox

reported me 3 separate PIDs (same as windows count that should show). I did a whole lot of tryouts … and eventually, I ran it with

firefox --safe-mode

This asked me for a complete reset and refresh and even asked me to create a new profile. … and that finally spawned a single window. But this didn’t 100% solve the issue. Thankfully I tried then the


URL in Firefox (didn’t know about that one) and could restore open windows and Bookmarks from old one (saved me a lot of time).
… And then we return to today … and Firefox is as unstable as it was before.
The key there is number of processes. With pgrep firefox if it spawns 3 Process identities (same number as there were windows) it will not show any GUI window.
You need to kill the Firefox with

kill $(pgrep firefox)

If you eventually do run the Firefox with only 1 single Process Identity then it works and you will get all the GUI windows restored (not a single one).

I even did downgrade from 106.0.4 to 106.0.2 and even 105. But downgrading to older version or upgrading to never version didn’t help … maybe cause I didn’t completely remove, just install-over.

Not sure whether you have a problem or whether you wanted to share your way to fix some issue.

What is “normally” the easiest way to reset and start from scratch is:

  • make sure no firefox process is running
  • mv ~/.mozilla ~/.mozilla.backup

Then start firefox. It will create a fresh profile with no extensions
and you can use the backup you just made (the old profile) to import things like stored passwords or bookmarks etc. into the new one.


Just wanted to share a slight observations (and what users can still do as a way around it - although there really is none at the moment) about the issue that is still here with Mozilla Firefox 106.x installed from Manjaro repositories.

I removed the .mozilla folder with configuration … uninstalled Firefox, rebooted computer and installed Firefox anew.

And result: No! This isn’t about personal configuration or about profiles of Firefox even. Removing or renaming personal configuration of browser didn’t resolve anything. Still have to try to run and kill Firefox 106.x version multiple times before I actually see Firefox GUI window being shown.

So visually this is the problem users were reporting since last upgrade at start of November 2022:
Firefox visually appears not to be starting. But in truth it does start,
just no window frames of Firefox are being shown. So all I did is report my findings that Firefox maybe starts incorrectly, but sooner or later you do start it correctly, with only one, single process identity (this is the only situation when Firefox GUI windows actually appear on screen - at least on KDE Plasma).

Your reported solution unfortunately has no effect at least for me and I bet many other users too. Because sooner or later … on the same day or tomorrow Firefox will again start incorrectly and no GUI window(s) will appear.

What is actual simplest and unfortunately 100% working solution as I see it given we are already in the middle of November 2022 and “the situation persist” is: Use some other browser. Which is a shame since I love using Firefox.

I hope this clarified the situation with this “Firefox not starting issue”

What you may have done here - you did not say what you did - is:
you may have just replaced the old (backed up) profile with the newly created one
and thus ended up with the very same that you had before you created the fresh profile

When I said that the old profile contents can be used to import bookmarks, saved passwords and the like,
I was thinking/speaking about the procedure to migrate profile contents.

This is done by:

  • shutting down firefox
  • manually copying the relevant files from the old profile to overwrite the same named ones in the new profile - selectively, one by one

Since I haven’t seen any problems like yours being reported here (or anywhere)
and since I myself have no problem whatsoever
I think your issue is something different - and with different causes

You attached your issue to an already marked as solved thread.
And even while responding to you now I always am nagged/reminded, that this is the case.

Create a new, your own, thread for your issue. …

I split the thread this time, but please think about it from now on…

thanks @maycne.sonahoz for splitting/moving the thread!

Thank you @maycne.sonahoz from me too.

Although I still want to emphasize that wiping configuration from HOME folder changed nothing.

And I bet must of people did not notice what I did and were looking at “Firefox doesn’t start issue”. I mean some probably just gave up. And maybe went on with another browser. “Lots of fishes in this sea”. But still better to at least report this issue being out there.

a quote from “Star Treck” (I guess)
Princess Lea:
“you assume too much”

… or no one else but you had the issue :wink:

@Pingouache in the thread

did mention issues. And then in linked thread

Although it reports different issue with colours.But @DanielFortCe did mention his Firefox doesn’t start at all.

But yeah in details our issues possibly do differ and it is indeed just me.

Is there output in the terminal if you run it from there?

1 Like

I tried to run it from terminal to get more insight on the error, but both

  • zsh (default terminal) and
  • explicitly called /bin/bash

did not print any error when no GUI window is spawned. But since I did kill $(pgrep firefox) only in /bin/bash it does report Firefox being


(And I actually thought this might give us more insight on the issue…)
But a successful run - when only one process identity is spawned and windows do pop out … spawns a few messages in /bin/bash:

ATTENTION: default value of option mesa_glthread overridden by environment.

These are spawned the same number as there ar Firefox windows (4 warnings per 4 windows). And

[2022-11-12T23:18:59Z ERROR viaduct::backend::ffi] Missing HTTP status

But these are one less (so 3 while having 4 Firefox windows open) than there are windows …

The way I see it it’s perhaps just something in KDE Plasma default graphics. Drivers if it does help in any way. Mostly kept stock settings from first installation of Manjaro KDE Plasma from the iso:

And who knows maybe with next KDE Plasma upgrade, trouble might just vanish like it was never here …

So there is no output at all when running from terminal?

That does not look like a graphics issue. to me.

I find it hard to believe the issue is KDE Plasma. I’m using KDE Plasma 5.26, and I often have multiple Instances (not Windows, separate Firefox instances ) of Firefox open.

I am also on KDE plasma desktop.
I have exact the same firefox issues, which “ff8idiot” described above.
In my case I have three user accounts on my laptop.
On two user accounts there are the firefox issues.
On one user account firefox start normally.
I have searched in each account for suspected files …
no luck.

@ Fafnir

That makes it look less like a Graphics issue than before.

Assuming it is KDE Plasma related? Are all accounts set up the same, using same theme, widgets etc, or are there differences?

What happens if you create a new account , with same settings as the account where FF starts normally?

Have you run a diff on the .mozilla folder of the account that works and the .mozilla folder of the accounts that don’t work?

is there any output you can pst here?

This is not an KDE-Issue.
Exacly same problems as ff8 and Fafnir on XFCE.
Neither reinstallation nor additional profiles changes the situation. The problem persists across multiple Linux user profiles:
Firefox starts several processes on startup and blocks each other. Terminating a task establishes functionality. Opening another instance creates a new task as it should, but these cannot be terminated via the GUI but remain as running processes in the background. Constantly terminating processes manually via console or even changing browsers cannot be the solution here. Helpful ideas?

@Fafnir mentioned multiple user accounts. I also have 2:

  1. Administrator account (initially created one from Manjaro setup)
  2. normal (unprivileged) account I use basically all the time since initial setup of Manjaro.

But when I tried Firefox under administrator account the exact same problem happened … and “3rd time wasn’t a charm”. Had to kill and start Firefox 8 times till it finally started correctly and I finally got the Firefox GUI window frame to pop out.

But after I logged off and into normal one. On the first try the Firefox started correctly.

So this is also not related to specific account nor to user permissions either in any way … also upgrade 2022-11-14 didn’t change the situation, but with upgrades who knows … what “the future” brings.

I had the same problem just after the last update : no window on the desktop but several processes running. Restart FF (killing processes before) or even reboot did not change anything. No message in Terminal when I launched FF from there.
FF restarted when, in Thunderbird, I clicked on a link (for a new password) and I got a FF window with all my tabs ! Since then no more problem with FF, reboot or not.
A bit strange isn’t ? :wink:

Yes, the upgrade didn’t change the situation.
Ok. After upgrade firefox do not run on all my user accounts. after more and more starts, till the firefox message “firefox is already running …” popped up then I killall firefox processes. Start firefox and it come up immediatly. So I do this in all my three user accounts.
Then I go in firefox “settings” to “performance” and mark out. Also on “hardware acceleration”.
This is done for all my accounts. And then I make a reboot. Login in first account - start firefox - he comes up. Logout. Login in secound account start firefox - nothing. start … start … firefox (procedure described above …) firefox comes up. In the third account firefox come also up! What is that?

After having read on - and wondered about this strange phenomenon
which is apparently not cured by

  • reboot
  • log in
  • remove the current profile
    (mv ~/.mozilla ~/.mozilla.defunct)
  • only then start firefox, which will create a fresh profile
    (this procedure is suggested to make sure that indeed no firefox process is already running
    while trying to replace the old profile)

I’ll now look around in the interwebs for similar occurences
and so should you
as I have never experienced the likes of it and it is unlikely to be Manjaro specific
as no one else but three people seem to encounter this.

I presume that all have a fully updated system …