Sound not working Only Dummy output

Hi I use external USB card steinberg UR12, which doesn’t work in Manjaro.
In pulse audio in output i see only dummy output. In inxi i can see card but when i try AlsaMixer
and select that car i get this “This sound device does not have any controls.”

inxi -SMA
System:
  Host: HOST Kernel: 5.15.25-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.16.0
    Distro: Manjaro Linux
Machine:
  Type: Desktop System: LENOVO product: 10116 v: Lenovo H535
    serial: <superuser required>
  Mobo: LENOVO model: N/A v: 31900058 STD or WIN
    serial: <superuser required> BIOS: LENOVO v: I7KT32AUS date: 12/26/2013
Audio:
  Device-1: AMD FCH Azalia driver: snd_hda_intel
  Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
  Device-3: Yamaha Steinberg UR12 type: USB driver: snd-usb-audio
  Sound Server-1: ALSA v: k5.15.25-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.47 running: yes

AlsaMixer

Hi @frntax, and welcome!

In order for us, or anyone for that matter, to be able to help you, more information is necessary. To that end, please see:

While I really don’t think I’ll be able to help you, this and more information that I don’t know at the moment will be necessary, I think.

Hope you manage!


Tip:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

```
pasted text
```

This will just cause it to be rendered like this:

Portaest sed
elementum
cursus nisl nisi
hendrerit ac quis
sit
adipiscing
tortor sit leo commodo.

Instead off like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Steinberg UR12 is probably similar to many other audio interfaces that only have hardware controls for audio and do not need alsamixer controls
The device should be visible in ALSA for audio playback/capture:

aplay -l && arecord -l

PulseAudio will create a dummy output if there are no hardware devices available for audio playback

Check PulseAudio Configuration for device Profile. I suspect that all 3 devices are set to Off

If any audio device is changed to Analog Stereo Output PulseAudio will remove Dummy output and use the active output sink for audio playback

If USB interface Profile is changed to Analog Stereo Duplex PulseAudio will use USB interface for audio playback and capture

If you cannot find device Profile settings in audio GUI controls please post response to this command to show PulseAudio configuration

pactl list cards
  1. Upgrade the kernel to 5.18 in manjaro setting.
  2. reboot
  3. open terminal, alsamixer, then pres f6 to change the soundcard.
  4. fill the bar to full, all of them.
  5. close

this is my solution for my PC, and it’s worked.
try and inform me the result.

Upgrading kernel should not be necessary - Steinberg UR12 interface has been reported to work well on Linux for many years

Screenshot in OP shows that there are no audio level controls in ALSA for the USB interface
Increasing audio level is not possible in ALSA for this device, but audio levels can be adjusted using the hardware controls

If PulseAudio cannot detect ALSA hardware devices for audio output changing ALSA settings will not help