My Bluetooth automatically get disabled after login

I enabled AutoEnable option, and the Bluetooth is available at the login screen, but it will be disabled as I login, I need to enable it manually. I am a starter at linux, can you help me with that?

1 Like

Hi @devin,

Please provide the output of:

systemctl status bluetooth.service

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Hi, @Mirdarthos
Here is the output:

     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; preset: disabled)
     Active: active (running) since Thu 2023-06-29 21:49:58 CST; 2min 21s ago
       Docs: man:bluetoothd(8)
   Main PID: 4811 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18904)
     Memory: 1.1M
        CPU: 383ms
     CGroup: /system.slice/bluetooth.service
             └─4811 /usr/lib/bluetooth/bluetoothd

Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSink/sbc
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSource/sbc
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSink/sbc_xq_453
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSource/sbc_xq_453
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSink/sbc_xq_512
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSource/sbc_xq_512
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSink/sbc_xq_552
Jun 29 21:49:58 devin-man bluetoothd[4811]: Endpoint registered: sender=:1.76 path=/MediaEndpoint/A2DPSource/sbc_xq_552
Jun 29 21:49:58 devin-man bluetoothd[4811]: src/device.c:set_wake_allowed_complete() Set device flags return status: Invalid Parameters
Jun 29 21:49:59 devin-man bluetoothd[4811]: src/adv_monitor.c:btd_adv_monitor_power_down() Unexpected NULL btd_adv_monitor_manager object upon power down

Is your system a computer or a laptop? Actually, please go through this and provide the info:

This is the system info.

  Kernel: 6.1.31-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=786eafd2-d905-4802-98da-d6fb952d96b4 rw quiet splash
    udev.log_priority=3 i8042.dumbkbd nouveau.modeset=0 acpi=force
  Desktop: KDE Plasma v: 5.27.5 tk: Qt v: 5.15.9 wm: kwin_wayland vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82NC v: Lenovo XiaoXinPro 14IHU 2021
    serial: <superuser required> Chassis: type: 10 v: Lenovo XiaoXinPro 14IHU
    2021 serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76479 WIN
    serial: <superuser required> UEFI: LENOVO v: FJCN65WW date: 07/22/2021
  ID-1: BAT1 charge: 53.5 Wh (94.9%) condition: 56.4/61.0 Wh (92.5%)
    volts: 17.2 min: 15.4 model: Sunwoda L19D4PH3 type: Li-poly serial: <filter>
    status: not charging
  Device-1: hidpp_battery_1 model: Logitech MX Master 3S serial: <filter>
    charge: 50% rechargeable: yes status: discharging
  Info: model: 11th Gen Intel Core i5-11320H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 2
    microcode: 0x2A
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 2545 high: 4499 min/max: 400/4500 scaling:
    driver: intel_pstate governor: performance cores: 1: 3200 2: 958 3: 3200
    4: 3200 5: 1385 6: 721 7: 3200 8: 4499 bogomips: 51008
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Chicony Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-1:2 chip-ID: 04f2:b6cb
    class-ID: fe01 serial: <filter>
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: kwin_wayland driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 res: 1646x1029 size: N/A modes: N/A
  API: OpenGL v: 4.6 Mesa 23.0.4 renderer: Mesa Intel Xe Graphics (TGL GT2)
    direct-render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  API: ALSA v: k6.1.31-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:3 chip-ID: 8087:0026
    class-ID: e001
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Local Storage: total: 476.94 GiB used: 47.63 GiB (10.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB512HBJQ-000L2
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 3L1QEXF7 temp: 38.9 C
    scheme: GPT
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 47.59 GiB (48.6%)
    fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 34.1 MiB (13.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 272 Uptime: 1m wakeups: 35 Memory: available: 15.41 GiB
  used: 3.85 GiB (25.0%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7 Packages: 1346
  pm: pacman pkgs: 1340 libs: 419 tools: pamac,yay pm: flatpak pkgs: 6
  Shell: Bash v: 5.1.16 running-in: console inxi: 3.3.27

Because of that t might be disabled for battery saving. Please provide the output of:

systemctl status tlp
Unit tlp.service could not be found.

Well, that might be a problem. However, a GUI app might help. Sp let’s install it. Run:

pamac install tlpui

This will pull in and use tlp, the actual software we’re after.

Yes, I installed tlpui, what do I need to configure?

Cool, just realized I didn’t say anything else. :tongue:

Anyway, it should be in your launcher somewhere. I don’t know, since I don’t have it installed, using a desktop and all. But in there, you should be able to set it up, enable it, and more.


For more, see


I had the same issue until an update fixed it.

In this (post)[[SOLVED] I have to open Blueman everytime I want to use bluetooth. / Laptop Issues / Arch Linux Forums], @Drito says that

EDIT: that happens when I restart the Xorg desktop without restarting computer.

And this issue surely happened every time my computer shutdown abnormally which is caused by (sddm)[SDDM restarting on shutdown · Issue #1479 · sddm/sddm · GitHub].

sddm restarted when I shutdown, it will cause the computer freezed when shuting down.

I guese the issue of Bluetooth is related to this, but I don’t know how to fix that.

Do you have the issue that manjaro hangs at shutdown for 90 seconds caused by sddm?

I don’t think so. Sometimes it takes longer to shutdown but I never had an issue with it.

Hi @devin

I was having the same issue as gtrudax and searching for a solution I stumbled upon your comment.

I am having this 90 seconds issue besides the bluetooth disabled after login, do you have a tip for me? :slight_smile: