Kernel panic after update 2022-11-14

i am new user to this forum. Experience in Win7 and older. But fan from arch linux since several years, first Antergos, then Manjaro. But still needing step by step help.
If i am in the wrong category please move to right one. I couldn’t decide between update or support…

My PC crashed with kernel panic after yesterday evening update. In all three installed kernels the same:
Screen freezes after showing kernel panic (picture can be shown if wanted).
As i remember, there were errors when building systemd and its modules. They could not be built and were not found afterwards.
PC: Fujitsu Celsius, i5-4690 @ 3.5GHz; OS: mj kernel 61, 60 and 5.19
I have a dualboot Manjaro - Win7, which i need for special banking software.

Is there hope to repair? And how?
My system has grown up since several years, so i’d like to fix it even if complicated. At least i’ll try.

Right now i’m writing in Windows, since my linux desktop is not working any more.

Thanks in advance for any help, mj-fan
How can i add my screenshot_1024|690x460, since error message says i cannot imbed media in post?

Use a Live-USB and reinstall the kernels from chroot.

From there, you can also run inxi -Fazy to give us the specs of your system.


Hi @mj-fan, and welcome!

What @mithrial suggested, but Also from the chroot environment, you can provide the neccessary info:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang: Also, if your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.


@mithrial - Thank you so much for your helping hints!
I tried one after another.
1 and 2 didn’t apply because my screen was totally frozen after giving kernel panic infos
3 didn’t apply cause i couldn’t find the pacman.conf which was to be changed (“ignore pkg”)
4 solved my problem, pcman.conf changed, sudo pacman -Syyu.

Now i’m back in manjaro desktop again! And it’s a look forward to christmas time for me, thanks :slight_smile:

A last question i have: in your last point “issue with file conflicts” isn’t it useful to also update archlinux-keyring?

@Mirdarthos - Also a big thank to you!
I’ll try your tips when needing them.
My last question about screenshot adding in my first post is answered with the Howto’s on your post.

Thanks to this forum and your kind answers, which is not natural nowadays, even if calling friendly “into the forest”, as we say in german (“… so it echoes back - you reap what you sow”).

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.