Black screen on login/logout - xfce4

I click on logout button and after that i see black screen.
I turn of my pc and after turn on it when i login i see black screen again.

  Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=8c8f00aa-778a-4034-8e12-47267d93ab19 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Console: pty pts/1 DM: LightDM v: 1.32.0 Distro: Manjaro base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A
  Mobo: ASUSTeK model: TUF GAMING B660-PLUS WIFI D4 v: Rev 1.xx
    serial: <filter> part-nu: SKU uuid: 099c8b2a-5634-e364-be6a-c87f5405edd9
    UEFI: American Megatrends v: 2014 date: 10/13/2022
  Message: No system battery data found. Is one present?
  System RAM: total: 32 GiB available: 31.16 GiB used: 955.6 MiB (3.0%)
  Array-1: capacity: 128 GiB slots: 4 modules: 2 EC: None
    max-module-size: 32 GiB note: est.
  Device-1: Controller0-ChannelA-DIMM0 type: no module installed
  Device-2: Controller0-ChannelA-DIMM1 type: DDR4 detail: synchronous
    size: 16 GiB speed: 2400 MT/s volts: curr: 1.2 min: 1.2 max: 1.35
    width (bits): data: 64 total: 64 manufacturer: Team Group Inc
    part-no: TEAMGROUP-UD4-3200 serial: <filter>
  Device-3: Controller1-ChannelA-DIMM0 type: no module installed
  Device-4: Controller1-ChannelA-DIMM1 type: DDR4 detail: synchronous
    size: 16 GiB speed: 2400 MT/s volts: curr: 1.2 min: 1.2 max: 1.35
    width (bits): data: 64 total: 64 manufacturer: Team Group Inc
    part-no: TEAMGROUP-UD4-3200 serial: <filter>
PCI Slots:
  Slot: 0 type: PCIe lanes: 16 status: in use length: long volts: 3.3
    bus-ID: 01:01.0
  Slot: 1 type: PCIe lanes: 1 status: available length: short volts: 3.3
    bus-ID: 04:1b.2
  Slot: 2 type: PCIe lanes: 1 status: available length: short volts: 3.3
    bus-ID: ff:1b.3
  Slot: 3 type: PCIe lanes: 16 status: available length: long volts: 3.3
    bus-ID: ff:1b.4
  Info: model: 12th Gen Intel Core i5-12400F socket: LGA1700 bits: 64
    type: MT MCP arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x97 (151) stepping: 5
    microcode: 0x32
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 480 KiB desc: d-6x48 KiB; i-6x32 KiB L2: 7.5 MiB desc: 6x1.2 MiB
    L3: 18 MiB desc: 1x18 MiB
  Speed (MHz): avg: 800 min/max: 800/4400 base/boost: 3960/4400 scaling:
    driver: intel_pstate governor: powersave volts: 1.1 V ext-clock: 100 MHz
    cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 9: 800
    10: 800 11: 800 12: 800 bogomips: 59916
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri
    msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pclmulqdq pdcm pdpe1gb pebs
    pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdtscp rep_good
    sdbg sep serialize sha_ni smap smep split_lock_detect ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip user_shstk vaes vme vmx vnmi
    vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106 [GeForce RTX 3060 Lite Hash Rate]
    vendor: Micro-Star MSI driver: nouveau v: kernel non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: HDMI-A-1 empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0
    chip-ID: 10de:2504 class-ID: 0300
  Display: server: v: driver: X: loaded: modesetting
    alternate: fbdev,vesa dri: nouveau gpu: nouveau tty: 204x62
  Monitor-1: HDMI-A-1 model: MSI MD241PW serial: <filter> built: 2022
    res: 1920x1080 dpi: 92 gamma: 1.2 chroma: red: x: 0.655 y: 0.329 green:
    x: 0.220 y: 0.682 blue: x: 0.149 y: 0.051 white: x: 0.310 y: 0.329
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") ratio: 16:9
    modes: 1920x1080, 1680x1050, 1280x1024, 1440x900, 1280x800, 1152x864,
    1280x720, 1024x768, 832x624, 800x600, 720x576, 720x480, 640x480, 720x400
  API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 drv: nouveau
    device: 1 drv: swrast gbm: drv: nouveau surfaceless: drv: nouveau
    inactive: wayland,x11
  API: OpenGL v: 4.5 compat-v: 4.3 vendor: mesa v: 24.0.2-manjaro1.1
    note: console (EGL sourced) renderer: NV176, llvmpipe (LLVM 16.0.6 256 bits)
  Device-1: Intel Alder Lake-S HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:7ad0
    class-ID: 0403
  Device-2: NVIDIA GA106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-3: Razer USA USB Sound Card driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-9.3:5
    chip-ID: 1532:0529 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.6.19-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.3 status: off with: 1: pipewire-pulse status: off
    2: wireplumber status: off 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-S PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:7af0 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel pcie:
    gen: 2 speed: 5 GT/s lanes: 1 port: N/A bus-ID: 05:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Info: services: NetworkManager, sshd, wpa_supplicant
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:7 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 953.87 GiB used: 14.95 GiB (1.6%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: SSD NM620 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: V1.19.B3 temp: 31.9 C
    scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 953.57 GiB size: 937.53 GiB (98.32%) used: 14.95 GiB (1.6%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: 8c8f00aa-778a-4034-8e12-47267d93ab19
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:1 label: N/A uuid: 5ADF-3DFA
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-2:2 info: ASUSTek AURA LED Controller type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 16mA chip-ID: 0b05:19af class-ID: 0300
    serial: <filter>
  Hub-2: 1-9:3 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 power: 100mA
    chip-ID: 174c:2074 class-ID: 0900
  Device-1: 1-9.3:5 info: Razer USA USB Sound Card type: audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 100mA
    chip-ID: 1532:0529 class-ID: 0300 serial: <filter>
  Device-2: 1-10:4 info: Holtek USB Gaming Mouse type: mouse,keyboard,HID
    driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 100mA chip-ID: 04d9:fc5e class-ID: 0300
  Device-3: 1-11:6 info: Evision RGB Keyboard type: keyboard,mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s)
    lanes: 1 mode: 1.1 power: 400mA chip-ID: 320f:5000 class-ID: 0301
  Device-4: 1-14:7 info: Intel AX201 Bluetooth type: bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1
    power: 100mA chip-ID: 8087:0026 class-ID: e001
  Hub-3: 2-0:1 info: super-speed hub ports: 9 rev: 3.1
    speed: 20 Gb/s (2.33 GiB/s) lanes: 2 mode: 3.2 gen-2x2 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-4: 2-8:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 power: 8mA
    chip-ID: 174c:3074 class-ID: 0900
  System Temperatures: cpu: 24.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Packages: 1091 pm: pacman pkgs: 1076 libs: 328 tools: pamac,yay pm: flatpak
    pkgs: 0 pm: snap pkgs: 15
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
  CPU top: 5 of 260
  1: cpu: 0.8% command: zsh pid: 1636 mem: 8.43 MiB (0.0%)
  2: cpu: 0.4% command: zsh pid: 1007 mem: 9.40 MiB (0.0%)
  3: cpu: 0.2% command: [kworker/2:1-cgroup_destroy] pid: 159
    mem: 0.00 MiB (0.0%)
  4: cpu: 0.2% command: redis-server pid: 841 mem: 13.8 MiB (0.0%)
  5: cpu: 0.1% command: init pid: 1 mem: 13.0 MiB (0.0%)
  Memory top: 5 of 260
  1: mem: 87.4 MiB (0.2%) command: lightdm-gtk-greeter pid: 932 cpu: 0.0%
  2: mem: 76.0 MiB (0.2%) command: Xorg pid: 896 cpu: 0.1%
  3: mem: 41.1 MiB (0.1%) command: snapd pid: 714 cpu: 0.0%
  4: mem: 26.8 MiB (0.0%) command: NetworkManager pid: 708 cpu: 0.0%
  5: mem: 15.9 MiB (0.0%) command: systemd-journald pid: 313 cpu: 0.0%
  Processes: 260 Power: uptime: 10m states: freeze,mem,disk suspend: deep
    avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
    suspend, test_resume image: 12.45 GiB Init: systemd v: 255
    default: graphical tool: systemctl
  Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Sudo (sudo) v: 1.9.15p5
    default: Bash v: 5.2.26 running-in: pty pts/1 (SSH) inxi: 3.3.33

when i run xfce4-panel i get:

xfce4-panel: Cannot open display: .

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=8 --filter --no-host --width --repos
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )


Edited title for better search compatibility, and also spelling

1 Like

i do it.

i delete sessions from ~/.cache and actually delete

exec zsh 

from head of my ~/.bashrc and its worked.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.