Apps are closing

I just installed switch to manjaro from Ubuntu but I’ve been having issues after installation. First, it takes a very long time to boot. Second, when I open the web browser and try to type something, it closes. even when I go to desktop settings and I go to the icon tab, it closes. I haven’t even done anything on it yet. please help because even if I want to switch back to Ubuntu, I still need to create the boot drive. I have nothing to work with.

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

Not a solution for now, but could come in handy later on:
use Ventoy to create your boot drive
Depending on how much space there is on the drive, you can put multiple .iso files on it and choose which one to boot
instead of having the whole drive occupied by just one bootable system.

1 Like

I just installed manjaro and using is has been very difficult. First, it takes a very long time to boot and sometimes it just doesn’t boot and shows “failed to start tlp system startup/shutdown” that made me reinstall more than 3 times. Another problem is when i left it idle while installing Firefox, it went to sleep and didn’t come back up. The pc light was on but the screen is blank and I force shut it down and now it is stuck on the loading screen when I turned it back on.
I’m new to Linux generally and I just moved from Ubuntu to manjaro.

Neither here nor in your other … thread/question did you provide any useful system information or feedback.
Perhaps you should indeed stick to Ubuntu
which seemed to have worked for you so far

I suspect a bios setting is not correct.

Make sure fast boot is disabled and efi is enabled.

And as above stated, we know nothing about your system or how you installed.

Is TLP still the default?

Are you installing using a current .iso or a rather old one?

Let me ask, did Ubuntu work? If not then what ever is not working now, is still not working. Maybe you just want to try KDE Plasma vs what ever Ubuntu is using now then why not try Kbuntu? But like others you really need to supply more info if you expect help.

I’m sorry. I’m new to all of this and I don’t know what other information I’m meant to provide. What other info do I need to provide?

Ubuntu did work and yes, I wanted to try something new.

I downloaded the iso yesterday from manaro’s website.

I sticked the boot drive in and I followed the installation procedure I was provided with, I didn’t do anything outside of that. Also, I do not know what other information I’m supposed to provide. What other information do I need to provide and how can I get them? Thank you.

TLP might still be default on some of the community spin ISOs.

Its also unlikely to be related to the issues here … but rather just the last thing printed/seen on the screen.

Common enough when, for example, there are GFX problems.


To begin please provide the output of

inxi -Fazy

(for more information on how to get and share information see the links above)

I checked my bios and there is no fast boot option. I changed the boot mode to UEFI and I get a “failed: failed to start light display manager” and “failed: failed to start TlP system startip/shutdown” and failed for user login management.

You cannot install one way then try to boot another.
If it was installed in Legacy/BIOS … then you need to boot that way, or to start using UEFI then you will need to reinstall, making sure to boot the ISO in UEFI mode.
(there are conversion tutorials out there … but why suffer headaches when its a new install and a fresh one will only take a few minutes)

Starting a fresh installation with the UEFI boot mode. I already picked installation with open source drivers and now I’m on the installation page. Do I choose swap or no swap? Does it have any effect?

If you want to configure an alternative like zram then choose no SWAP.
We can configure it after the install.

(That is what I use… and I recently wrote a quick tutorial for someone else here: Awful performance since install - #2 by cscs)

Otherwise, yes, you will want some form of SWAP and if you dont want one of the other methods then go ahead and allow it to be created.

1 Like

Now it’s installed and working, I don’t know if the problem will come up again but how do I get to the terminal from the boot so I can get system information for future questions. I’ve tried “e”, “CTR + c”, “ctrl + alt + F2”. It’s not taking me anywhere.

If you mean TTY then you dont need to get system information that way.
I can just input inxi -Fazy into your regular terminal.

As to how to get to TTY or runlevel 3 when needed then the steps are outlined in guides like this one:

Ctrl+c is a common invocation for cancelling a currently running process in the terminal.
(example: ping … wait a bit, hit ctrl+c … and it stops)

Ctrl+Alt+Fx (where x is a number, so F1, F2, F3, etc) is usually what we would use to drop to TTY from a currently running system. Such as from your desktop.
(note these numbers can vary - I believe Plasma desktop now boots into TTY2 [so ctrl+alt+F2] by default. Meaning in that case ctrl+alt+f3 would be a TTY, and ctrl+alt+F2 would bring you back to the desktop.)

The e part you are referring to is probably for editing boot options during boot . so this means at grub when selecting a kernel you would press e to edit … then make changes. Such as adding 3 to the options to boot into runlevel 3 (no gfx) as outlined in the guide above.

1 Like

There are many tutorials available. Here are a few that might be useful to bookmark.

That is all. Cheers.