Manjaro not installing the Bootloader

Hello, I am new to Linux in general. I switched to Manjaro (KDE Plasma) form Windows 11 recently. Today I tried installing Manjaro (GNOME) on my Windows 8 tablet, that was running Windows 11, and I got an error about installing the bootloader, (I’ll try to include log files but I can’t include links now). I nuked the complete drive, so I have Manjaro on this drive, but not the bootloader, which sucks, because I can’t boot to it.

Anyone wiling to help?


Can you boot Manjaro USB stick and post fdisk -l and blkid ?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

I sure can boot to the USB stick, but post? should I use these commands in Terminal?
anyways I’ll try them in the terminal

OKOK, I can run both commands, but the first one (fdisk -l) says that it cannot open something.
The second one dosent give any output

because it should be



sudo fdisk -l

There are some devices, esp. tablets with touchscreens and arm devices, that are firstly, not well supported because of missing drivers, and secondly, with locked bootloaders and uefi settings. But let us see the partitions first.
And it would have been helpful to note what error did the installer gave you. There is no such thing as successfully installed system without bootloader, under normal circumstances. Either it did not fully install, or you configured something wrong at the installer.

Generally speaking, a bootloader is easy to install on a normal computer, but as i said there are some special phone-like cases in which it is not so easy.

Give the output of the commands and the inxi and the name and model of the device and we will see.

1 Like

Ok, the commands were succesfull now, but uhhh this is a Thinkpad 10 (I think (ok it is infact the Thinkpad 10, an x64 tablet)). Oh yeah, the installer said that it couldn’t install the bootloader and sonething returned with 1. The partitions look the same as a normal install, but the bootloader is a normal fat32 300 MiB partition.

Remove those “links” and post actual text - there is already a how-to guide few posts up.

You could have connected to wifi and pasted the output from the live usb session or at least used </> like
Anyway, i opened the photos. Well, it is certainly not the typical desktop or laptop setup. There seem to be 2 flash memories, windows on one, manjaro and ESP on the other. And 2 4MB boot partitions that i cannot understand. Maybe it is a mixed MBR/GPT setup…no idea.
On one of the first results in google is written this UEFI is 32 bit…this could also be a problem. No idea if it is true. Seems like that model has several iterations.
Also, according to the manual there is a windows recovery, which i do not see…maybe you used that partition to install manjaro…?
At least the user manual tells us how to enter UEFI

1. Restart the tablet.
2. Immediately press and hold the volume-up button until the ThinkPad Tablet Setup app starts.

so you can enter it, look at the boot order and put the manjaro partition first, also disable secure boot.

1 Like

oh, with that there’s an issue. I can’t go to the UEFI, because when I enter, there’s no output. I’ll connect an HDMI output and go to setup now
okay I just connected HDMI and booted to setup, anddd no setup.
There’s also a SD card in the Thinkpad, that may have the Windows recovery.
I don’t know what to do

Look. Let’s start from scratch. Boot into your Manjaro USB drive. From there do you have an internet connection so that you can post directly here?

If so, run from the terminal, command:- sudo parted -l, (better than sudo fdisk -l). Then from the output, highlight it with your mouse and press keys Cntrl + Shift + c. That copies the output. Then paste this output here (Cntrl + v). Then highlight that output here, and press Cntrl + e. That would be a helpful start.

1 Like
Model: USB2.0 USB Flash Drive (scsi)
Disk /dev/sda: 4003MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3140MB  3144MB  4194kB  primary               esp

Model: MMC SEM64G (sd/mmc)
Disk /dev/mmcblk2: 62.5GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name  Flags
 1      2097kB  317MB   315MB   fat32              boot, esp
 2      317MB   62.5GB  62.2GB  ext4         root

Error: /dev/mmcblk2boot1: unrecognised disk label
Model: Generic SD/MMC Storage Card (sd/mmc)                               
Disk /dev/mmcblk2boot1: 4194kB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags: 

Model: SD SN64G (sd/mmc)
Disk /dev/mmcblk1: 63.9GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  63.9GB  63.9GB  ntfs         Basic data partition  msftdata

Error: /dev/mmcblk2boot0: unrecognised disk label
Model: Generic SD/MMC Storage Card (sd/mmc)                               
Disk /dev/mmcblk2boot0: 4194kB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

did i do it correctly?

@AntoniNowak – Just for reference:- In some/most cases during Linux install you need to specify that the bootloader should also be installed. This usually happens after the partitioning stage (a toggle or checkbox) and prior to rebooting for the first time. It’s possible you missed that. I can’t be more specific as I haven’t actually needed to install for a very long time. Cheers.

huh, I never remembered a checkbox there, lemme check. I’m gonna turn the scale to 100% and get back to you!

BUT ! This is generally meant for standard PCs/Laptops. I strongly suspect chroot will not work automatically in your case. If it works follow the guide.

Did you do the simplest of all to check the boot order and secure boot and fastboot? Maybe you got lucky and it got installed but you are booting from the wrong flash.

You can also try

to test if it finds the linux.

@Teo I’ll get back to you when I install a new copy of Manjaro GNOME, but now I added swap memory, I haven’t seen it before, because of the display scailing OHHH the installer froze now, oopsim gonna do the GRUB/Restore the GRUB Bootloader thingi

okay, it’s like the third time it got stuck at Unpacking image 1/2 file 9427/66838 when I try to clean install it, so I could do something usefull, “JUST PLEASE INSTALL, YOU CAN EVEN INSTALL WITHOUT GRUB” < my thoughts rn, OH wait its doing somehing, oh no it just kicked me out agian to the log in screen, how usefull

im giving up for today, maybe tomorrow i’ll remake the usb drive, for now i need to study for biology class. good night

Yes, that’s fine.

It looks like you installed it on memory cards instead of more conventional internal disks such as an SSD. Just wondering why that was the case? There are 4 memory cards shown. Is that correct?

Anyway it appears that 2 of them have been erroneously labelled, ie there is no partition table for memory cards mmcblk2boot1 and mmcblk2boot0, because such device names are incorrect in the first place. The other 2, mcblk1, and mcblk2, which have Windows and Linux respectively installed are correctly labelled device names. And your bootloader is definitely shown on the Linux drive.

If you don’t know which disks are which, I would boot to your USB installer, then remove the 2 memory cards with illegal device names as mentioned above. Remove one then run sudo parted -l again, and see which one is no longer displayed. Do the same for another disk, until you just get the 2 correct cards displayed. Then reboot your machine, and if you still get no Grub or error messages, let us know what they are.

Don’t mess with these, because we don’t know what they are. The internet wisdom suggest that has something to do with U-boot, but how that works with EFI i do not know.