Bluetooth connectivity issues in display manager with XFCE and KDE

Up until recently, autoconnect for at least KDE worked. I do not recall if I needed to edit /etc/bluetooth/main.conf but noe setting AutoEnable to 1 doesn’t even work at all. I’ve tried on both XFCE and KDE, yet GNOME Shell doesn’t exhibit this problem.

I have no idea when this started becoming an issue, probably 1.5 to 2 months ago. Somewhere in that range. I find I have similar issues on Arch-based desktops as well in spite of following the Arch wiki for supposedly resolving Bluetooth issues.

What’s a user who really doesn’t want anything to do with GNOME can do? I am baffled beyond belief about this problem and I do not know where to begin with a resolution.

Clarificartion: The stack which comes with GNOME Shell works with my hardware out of the box but for some reason recently, BlueZ decided to have a little hiccup and elect to not work at the display manager. This applies to both XFCE and KDE as I spent the time to download the latest builds of those variants and install them. I set true AutoEnable with no joy for either of them.

I have no idea what to do — I am lost. Short of attempting to uninstall and reinstall the whole stack, what else can I do?

Increase your chances of solving your issue:

Provide Information:

Well my status for Bluetooth is running when I check with systemctl so uhmmmm…

Also inxi Faz:

System:
  Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=0680975d-5792-43ab-aa33-98a9d2bfd60e rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81NC v: Lenovo IdeaPad S340-15API
    serial: <superuser required> Chassis: type: 10 v: Lenovo IdeaPad S340-15API
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: AMCN29WW(V1.12)
    date: 01/27/2021
Battery:
  ID-1: BAT1 charge: 51.4 Wh (97.0%) condition: 53.0/52.5 Wh (101.0%)
    volts: 12.6 min: 11.3 model: 0x4C 0x47 0x43 0x00 0x32 0x30 0x 0x4C 0x31
    0x38 0x4C 0x33 0x50 0x5250
    type: Li-ion serial: <filter> status: N/A cycles: 17
  Device-1: hid-77:12:23:15:03:7f-battery model: Anker A7726 serial: N/A
    charge: N/A status: Discharging
CPU:
  Info: model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx bits: 64
    type: MT MCP arch: Zen/Zen+ note: check family: 0x17 (23)
    model-id: 0x18 (24) stepping: 1 microcode: 0x8108109
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 384 KiB desc: d-4x32 KiB; i-4x64 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1929 high: 2786 min/max: 1400/2100 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1239 2: 1792
    3: 1386 4: 1411 5: 2786 6: 2643 7: 1431 8: 2748 bogomips: 33550
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Picasso vendor: Lenovo driver: amdgpu v: kernel
    bus-ID: 03:00.0 chip-ID: 1002:15d8 class-ID: 0300
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-4:3 chip-ID: 13d3:56b2 class-ID: 0e02
  Display: x11 server: X.org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 03:00.1 chip-ID: 1002:15de
    class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
    vendor: Lenovo driver: snd_pci_acp3x v: kernel
    alternate: snd_rn_pci_acp3x,snd_pci_acp5x bus-ID: 03:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.12-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel bus-ID: 02:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 3-2:2
    chip-ID: 0cf3:e500 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Drives:
  Local Storage: total: 1.03 TiB used: 349.72 GiB (33.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-24Z10
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 1A04
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Generic model: SD MMC
    size: 119.38 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 1.00 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
  ID-1: / raw-size: 31.25 GiB size: 30.59 GiB (97.88%)
    used: 11.57 GiB (37.8%) fs: ext4 dev: /dev/sda7 maj-min: 8:7
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
    used: 58.4 MiB (22.8%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 31.25 GiB size: 30.63 GiB (98.03%)
    used: 17.97 GiB (58.6%) fs: ext4 dev: /dev/sda4 maj-min: 8:4
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda5 maj-min: 8:5
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 69.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 295 Uptime: 2h 2m wakeups: 3 Memory: 5.8 GiB
  used: 3.52 GiB (60.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1252 lib: 336 flatpak: 0 Shell: Bash
  v: 5.1.12 running-in: terminator inxi: 3.3.11

What else am I suppose to do How can I check if SDDM is working with Bluetooth service? I’m also too tired for proper troubleshooting, I’ll commit some more research later.

Is there a reason using bluetooth keyboard at the login screen without any user intervention had been disabled recently? Because I’ve lost the capability to do that.

See

Is there a reason you’re suspecting this has anything to do with the kde package cleanups?

2 Likes

See that doesn’t work for me. And I have no idea why. I can smash this keyboard as much as I want at the login screen but I receive no joy until I use either the built-in laptop or a USB laptop to log in, which would be absolutely no good if the built-in keyboard decided to (or was forced due to malfunction) not work.

I think this honestly has something to do with BlueZ because I get the same issue with Arch “Proper” (or as close as I could with another Arch distro). I should attempt with a fresh install on an external device.

And you don’t feel that this would be appropriate for a separate thread ─ and for that matter, under the Support section?

QED. This thread here is not about the Bluetooth stack. It’s about cleaning up the Plasma installer images.

:eyes:

1 Like

I’ll do that after more research has been committed to potentially isolate the problem.

I’ve moved all relevant posts to a new thread (edit) your extra thread as this doesn’t seem to have anything todo with the kde cleanup effort.

Did you try different kernels?

1 Like

I already made a thread about it in Support / Network but that’s cool I suppose you could move those posts here as well, or visa-versa.

So the extra research I did before going to bed was installing all of the mainline builds fresh and ths issue affects XFCE as well, which also means it likely affects MATE, Budgie, probably Deepin and so-on but i hadn’t tested those.

What worked surprised me — GNOME Shell. So something is messed up with the Bluetooth stack somewhere for me to suddenly lose this capability of using a Bluetooth keyboard at the display manager.

1 Like

I tried 5.10. Kernel isn’t the issue. GNOME Shell install has 5.15 as kernel. I was able to use 5.15 with my bluetooth keyboard at the display manager before. I do not understand.

Also, I used bluetoothctl to establish the connection. No dice still, so it doesn’t seem to have anything to do with KDE’s tools. I mean — the keyboard works. I can pair, connect and use it, it’s only at the display manager for KDE and XFCE where it does not work.

So it has to be a stack issue, or some underlying display manager dependency that has become messed up with time which causes it to not play nice with bluez or systemd out of the box where the display manager doesn’t permit Bluetooth input.

Just to remind all: I am having these issues with a fresh install. I have an older install I can check out since I tend to just play with USB stuff randomly and forget about it.

Thhe one instance I mentioned earlier is now absolutely busted with a bad superblock issue I cannot resolve. But before I messed it up trying to duplicate it in KDE Partition Manager I managed to test successfully connecting a Bluetooth device with the laptop, then signing in with the Bluetooth device.

But now I have an even more interesting issue; no matter how far back I go (I am using a build from 2020 asI write this) I cannot get the device to work in KDE. I presume the same thing will happen in XFCE. I had not updated any packages yet.

I booted into Windows recently and updated some software there. Could it be that an update in Windows replaced / upgraded the firmware of my multi-purpose radio and somehow busted this capability? don’t know what else it could be. Scratch that, things were working before as well. And yes I set autoenable to true.

I am losing my God-damn mind here because stuff I figured would work isn’t working now and I am just angry about the whole thing.

I am happy to say I had solved the problem. My only disappointment, aside from the hardship I had endured frgetting this, was the affirmation and fulfillment of bets that I was being a retard.

I forgot to decomment the AutoEnable line. I wrote about that, in this very forum bur forgot about it. Not that I already doubted my reduced mental capacity, but this puts into question if I am a competent human being with any right to profess technical merit when I’m forgetting the basics akin to someone suffering from dementia.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.