Error: file /boot/vmlinuz-5.8-x86_64 not found

I got this errors on any boot option of Manjaro:
Error: you need to load the kernel first

The story short: I didn’t log in to Manjaro for a year, so Windows probably killed the main load option and I used some advanced option to load in Manjaro. Then I updated it, after the update the screen locked and I couldn’t type the password (the input was disabled) so I restarted it. Now I have those errors.

I already checked the forum, made a live usb, and loaded with it then manjaro-chroot -a
Then tried to run the update again ( pacman -Syyu), it said: there is nothing to do.

[manjaro /]# pacman -Syyu
:: Synchronizing package databases...
 core                  142.6 KiB   126 KiB/s 00:01 [######################] 100%
 extra                   8.6 MiB  5.55 MiB/s 00:02 [######################] 100%
 community              29.0   B   161   B/s 00:00 [######################] 100%
 multilib              146.5 KiB   814 KiB/s 00:00 [######################] 100%
:: Starting full system upgrade...
 there is nothing to do

mhwd-kernel -li && mhwd -l -li displays:

[manjaro /]# mhwd-kernel -li && mhwd -l -li
Currently running: 6.5.1-1-MANJARO (linux65)
The following kernels are installed in your system:
   * linux510
   * linux54
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:08:00.0 (0300:1002:67df) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

and update-grub:

[manjaro /]# update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
ERROR: mkdir /var/lock/dmraid
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your
Found Ubuntu 22.04.3 LTS (22.04) on /dev/nvme1n1p2
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme1n1.

Moderator edit: It’s <pre><code> :wink:

Welcome to the forum! :wave:

Please copy and paste terminal output using preformatted text instead of uploading screenshots of text.

Each image uploaded to the server makes forum database backups larger. Search engines cannot read screenshots and one cannot copy and paste from them without an OCR program.

Please edit your post accordingly.

Please also see:

… choose another kernel to boot with
there where no errors re the kernels that you do have
in what you showed here

The error in the title refers to a 5.8 kernel.

It looks like you have a 5.4 and a 5.10 installed.

not a good strategy or use case for Manjaro - if you delay updates for long periods of time, you can expect problems with the update process
when you finally decide to do it

fairly easy to solve - but not just a smooth update either

It looks like an unfinished update - now only fixable by chroot (manjaro-chroot, for example)

Solve how? I already tried to fix it with chroot and there is nothing to update. Kernel 5.8 looks like not even available to install either.

At least now it shows an error. Before the main boot option just showed a grey screen.

sudo parted --list && lsblk

[manjaro /]# sudo parted --list
Model: SanDisk Ultra USB 3.0 (scsi)
Disk /dev/sda: 30.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
2 3751MB 3756MB 4194kB primary esp

Model: WDC WDS100T2B0C-00PXH0 (nvme)
Disk /dev/nvme0n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 17.4kB 16.8MB 16.8MB Microsoft reserved partition msftres
2 16.8MB 1000GB 1000GB ntfs Basic data partition msftdata

Model: WDC WDS100T2B0C-00PXH0 (nvme)
Disk /dev/nvme1n1: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 538MB 537MB fat32 EFI System Partition boot, esp
2 538MB 420GB 419GB ext4
3 420GB 790GB 370GB ntfs msftdata
4 790GB 790GB 646MB ntfs hidden, diag, no_automount
5 790GB 1000GB 210GB ext4

[manjaro /]# lsblk 
loop0         7:0    0 146.7M  1 loop 
loop1         7:1    0   1.2G  1 loop 
loop2         7:2    0   1.5G  1 loop 
loop3         7:3    0 667.9M  1 loop 
sda           8:0    1  28.7G  0 disk 
|-sda1        8:1    1   3.5G  0 part 
`-sda2        8:2    1     4M  0 part 
nvme0n1     259:0    0 931.5G  0 disk 
|-nvme0n1p1 259:7    0    16M  0 part 
`-nvme0n1p2 259:8    0 931.5G  0 part 
nvme1n1     259:1    0 931.5G  0 disk 
|-nvme1n1p1 259:2    0   512M  0 part /boot/efi
|-nvme1n1p2 259:3    0 390.6G  0 part 
|-nvme1n1p3 259:4    0 344.5G  0 part 
|-nvme1n1p4 259:5    0   616M  0 part 
`-nvme1n1p5 259:6    0 195.3G  0 part /

You have to refresh your mirrors first.

That kernel has already been EOL for ages.

Here, try this… :arrow_down:

1 Like

I did. I saw that instruction with
pacman-mirrors -f && pacman -Syyu
and thats how I updated it. The update didn’t fail, it finished before I restarted the system.

But you’re still trying to boot off of a non-existing kernel. You have to select another kernel at boot time by choosing “Advanced options for Manjaro Linux”, and only then can you remove the remnants of your defunct 5.8 kernel.

The is 2 options in advanced boot options: kernel 5.8 and kernel 5.8 with fallback initramfs

Okay, then chroot back into your system as explained in the tutorial, and once in the chroot, issue the following command… :arrow_down:

mhwd-kernel -i linux61
mkinitcpio -P

Let it finish, and then try rebooting from the installed system again.

1 Like

Nothing has changed.

Well, I am sorry but I’m afraid that I cannot help you anymore beyond this point.

By your own admission, you hadn’t updated your system anymore in a year, and a lot changes in a rolling-release distribution over the course of a year. As a community, we cannot and will not support systems that have not been kept up to date, exactly because it is impossible to do so.

You’re probably going to be better off simply reinstalling the system from a recent ISO and then updating it to the very latest state of affairs — there have been a few small updates again since the most recent ISO was released, so you’ll immediately need to refresh your mirror list and run the update procedure.


I loaded with my Ubuntu installation and ran update-grub2 and it generated loading boot options for 5.4 and 5.10 correctly. But it only loads with initramfs as before the update I made.