Another Black Screen on Booting

Hello Everyone,

Whenever I boot my computer the screen turns to black and doesn’t even enter the login screen. I’m aware of this being the case when the drivers are not properly activated, but I’m unable to diagnose what might be wrong. I’ve checked the main FAQ and followed the steps outlined there to no avail. I’ve even delved deep into the links to other solutions such as clearing the cache and installing module headers and dkms, but I’m not sure what to do at this juncture.

It started with me trying to get Optimus driver to work, and uninstalling the Nvidia dkms in exchange for the other Nvidia packages on the official repository (dumb I know). However, this failed. I tried reinstalling the Nvidia dkms package again but this didn’t work. As of now I can only access the computer via the command line tty.

Is there any way I can rectify this without a full reinstall of manjaro? It’s almost certainly not a physical issue. I can still boot into windows and the computer was working just fine until I messed with it.

inxi -Fazy

Apologies for the pictures, but as I can’t cut and paste at the moment and the text is so vast, I hope you can do with this for now. If necessary, I can type any sections you feel are pertinent but illegible.

1 Like

Hi @Abubakar,

Thank you for being polite in your post, I appreciate it. As I’m sure a lot of people will.

I suggest, if you haven’t got one, download an ISO and boot with it. From there you can enter a chroot environment from there you’ll be able to to execute command, and copy and paste outputs.

To enter a chroot environment

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot environment:

manjaro-chroot -a

If you have more than one Linux installation, select the correct one to use from the list provided.

If sucessfully done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart and can cause damage.

From there you can provide more info:

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

Also, please provide the outs of:

mhwd --list


mhwd --listinstalled

…from the chroot environment.

1 Like

Thank you very much @Mirdarthos. It took a while to download the iso file, but here are the results of the first and second command codes:

mhwd --list
[manjaro /]# mhwd --list
> 0000:06:00.0 (0302:10de:174d) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI

> 0000:10:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:00:02.0 (0300:8086:8a56) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2023.03.23               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

And for:

mhwd --listinstalled
Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Finally inxi -Fazy again:

inxi -Fazy
[manjaro /]# inxi -Fazy
  12Kernel 6.1.30-1-MANJARO 12arch x86_64 12bits 64 12compiler gcc 12v 12.2.1
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2213 quiet systemd.show_status=1
    splash driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  12Desktop KDE Plasma 12v ERR-101 12tk Qt 12v 5.15.9 12wm kwin_x11 12dm N/A
    12Distro Manjaro Linux 12base Arch Linux
  12Type Laptop 12System HP 12product HP Pavilion Laptop 15-cs3xxx
    12v Type1ProductConfigId 12serial <filter> 12Chassis 12type 10 12serial <filter>
  12Mobo HP 12model 86E2 12v 95.32 12serial <filter> 12UEFI Insyde 12v F.06
    12date 04/08/2020
  12ID-1 BAT0 12charge 20.8 Wh (100.0%) 12condition 20.8/20.8 Wh (100.0%) 12volts 13.0
    12min 11.4 12model HP Primary 12type Li-ion 12serial N/A 12status full
  12Info 12model Intel Core i5-1035G1 12socket U3E1 12bits 64 12type MT MCP 12arch Ice Lake
    12gen core 10 12level v4 12note check 12built 2019-21 12process Intel 10nm 12family 6
    12model-id 0x7E (126) 12stepping 5 12microcode 0x56
  12Topology 12cpus 1x 12cores 4 12tpc 2 12threads 8 12smt enabled 12cache 12L1 320 KiB
    12desc d-4x48 KiB; i-4x32 KiB 12L2 2 MiB 12desc 4x512 KiB 12L3 6 MiB 12desc 1x6 MiB
  12Speed (MHz) 12avg 1200 12min/max 400/3600 12base/boost 3300/8300 12scaling
    12driver intel_pstate 12governor powersave 12volts 1.1 V 12ext-clock 100 MHz 12cores
    121 1200 122 1200 123 1200 124 1200 125 1200 126 1200 127 1200 128 1200 12bogomips 19048
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  12Type itlb_multihit 12status KVM: VMX disabled
  12Type l1tf 12status Not affected
  12Type mds 12status Not affected
  12Type meltdown 12status Not affected
  12Type mmio_stale_data 12status Vulnerable: Clear CPU buffers attempted, no
    microcode; SMT vulnerable
  12Type retbleed 12mitigation Enhanced IBRS
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer
  12Type spectre_v2 12mitigation Enhanced IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: SW sequence
  12Type srbds 12status Vulnerable: No microcode
  12Type tsx_async_abort 12status Not affected
  12Device-1 Intel Iris Plus Graphics G1 12vendor Hewlett-Packard 12driver i915
    12v kernel 12arch Gen-11 12process Intel 10nm 12built 2019-21 12ports 12active eDP-1
    12empty HDMI-A-1 12bus-ID 00:02.0 12chip-ID 8086:8a56 12class-ID 0300
  12Device-2 NVIDIA GM108M [GeForce MX130] 12vendor Hewlett-Packard
    12driver nouveau 12v kernel 12non-free 530.xx+ 12status current (as of 2023-05)
    12arch Maxwell 12code GMxxx 12process TSMC 28nm 12built 2014-19 12pcie 12gen 1
    12speed 2.5 GT/s 12lanes 4 12link-max 12gen 3 12speed 8 GT/s 12bus-ID 06:00.0
    12chip-ID 10de:174d 12class-ID 0302
  12Device-3 Chicony HP Wide Vision HD Camera 12driver uvcvideo 12type USB 12rev 2.0
    12speed 480 Mb/s 12lanes 1 12mode 2.0 12bus-ID 1-3:4 12chip-ID 04f2:b627 12class-ID 0e02
  12Display 12server 12v 12with Xwayland 12v 23.1.1 12compositor kwin_x11
    12driver 12X 12loaded modesetting,nvidia 12dri iris 12gpu i915 12display-ID :0
  12Monitor-1 eDP-1 12model Najing CEC Panda 0x003c 12built 2018 12res 1920x1080
    12dpi 142 12gamma 1.2 12size 344x194mm (13.54x7.64") 12diag 395mm (15.5") 12ratio 16:9
    12modes 1920x1080
  12API OpenGL 12Message GL data unavailable for root.
  12Device-1 Intel Ice Lake-LP Smart Sound Audio 12vendor Hewlett-Packard
    12driver snd_hda_intel 12v kernel 12bus-ID 00:1f.3 12chip-ID 8086:34c8 12class-ID 0403
  12API ALSA 12v k6.1.30-1-MANJARO 12status kernel-api 12with aoss 12type oss-emulator
    12tools alsactl,alsamixer,amixer
  12Server-1 JACK 12v 1.9.22 12status off 12tools N/A
  12Server-2 PipeWire 12v 0.3.70 12status n/a (root, process) 12with 121 pipewire-pulse
    12status off 122 pipewire-media-session 12status off 123 pipewire-alsa 12type plugin
    12tools pactl,pw-cat,pw-cli
  12Device-1 Intel Ice Lake-LP PCH CNVi WiFi 12driver iwlwifi 12v kernel
    12bus-ID 00:14.3 12chip-ID 8086:34f0 12class-ID 0280
  12IF wlo1 12state up 12mac <filter>
  12Device-2 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    12vendor Hewlett-Packard 12driver r8169 12v kernel 12pcie 12gen 1 12speed 2.5 GT/s
    12lanes 1 12port 3000 12bus-ID 10:00.0 12chip-ID 10ec:8168 12class-ID 0200
  12IF eno1 12state down 12mac <filter>
  12Device-1 Intel AX201 Bluetooth 12driver btusb 12v 0.8 12type USB 12rev 2.0
    12speed 12 Mb/s 12lanes 1 12mode 1.1 12bus-ID 1-10:5 12chip-ID 8087:0026 12class-ID e001
  12Report hciconfig 12ID hci0 12rfk-id 0 12state up 12address <filter> 12bt-v 3.0
    12lmp-v 5.1 12sub-v 100 12hci-v 5.1 12rev 100
  12Info 12acl-mtu 1021:4 12sco-mtu 96:6 12link-policy rswitch sniff
    12link-mode peripheral accept 12service-classes rendering, capturing, object
    transfer, audio, telephony
  12Hardware-1 Intel 82801 Mobile SATA Controller [RAID mode] 12driver ahci 12v 3.0
    12port 7060 12bus-ID 00:17.0 12chip-ID 8086:282a 12rev N/A 12class-ID 0104
  12Local Storage 12total 945.83 GiB 12used 148.77 GiB (15.7%)
  12ID-1 /dev/sda 12maj-min 8:0 12vendor Toshiba 12model MQ04ABF100 12size 931.51 GiB
    12block-size 12physical 4096 B 12logical 512 B 12sata 3.1 12speed 6.0 Gb/s 12tech HDD
    12rpm 5400 12serial <filter> 12fw-rev 7C 12temp 42 C
  12SMART yes 12state enabled 12health PASSED 12on 1y 108d 14h 12cycles 2752 12Old-Age
    12g-sense error rate 1542 12Pre-Fail 12reallocated sector 100 12threshold 5
  12ID-2 /dev/sdb 12maj-min 8:16 12vendor SanDisk 12model Cruzer Spark 12size 14.32 GiB
    12block-size 12physical 512 B 12logical 512 B 12type USB 12rev 2.0 12spd 480 Mb/s 12lanes 1
    12mode 2.0 12tech N/A 12serial <filter> 12fw-rev 1.00
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12ID-1 / 12raw-size 288.06 GiB 12size 282.47 GiB (98.06%) 12used 148.75 GiB (52.7%)
    12fs ext4 12block-size 4096 B 12dev /dev/sda4 12maj-min 8:4
  12ID-2 /boot/efi 12raw-size 100 MiB 12size 96 MiB (96.00%) 12used 25.3 MiB (26.4%)
    12fs vfat 12block-size 512 B 12dev /dev/sda1 12maj-min 8:1
  12Alert No swap data was found.
  12System Temperatures 12cpu 46.0 C 12mobo N/A
  12Fan Speeds (RPM) N/A
  12Processes 251 12Uptime 13m 12wakeups 1 12Memory 12available 15.41 GiB
  12used 3.6 GiB (23.4%) 12Init systemd 12v 253 12default graphical 12tool systemctl
  12Compilers 12gcc 13.1.1 12clang 15.0.7 12Packages 2757 12pm pacman 12pkgs 2729 12libs 542
  12tools pamac,yay 12pm flatpak 12pkgs 28 12Client Unknown Client: systemd 12inxi 3.3.27

You dont have any of the proprietary profiles installed.

First remove any nvidia stuff you previously installed.

pacman -Qs nvidia
sudo pacman -Rns nvidia-470xx-utils nvidia-470xx-settings

(I dont know what you have installed)

Then install the profile you want. Probably latest PRIME:

sudo mhwd -i pci video-hybrid-intel-nvidia-prime

Unless you know what you are doing you should always only use mhwd to handle drivers.

1 Like

Thank you very much. Some questions though:

How do I know which profile I want?
Do I simply install according to the drivers listed in my posts?

Unless you have some specific reason not to … you will want latest proprietary drivers - nothing else will deliver the same performance. As mhwd offered that … thats what I wrote.

Thank you very much. I tried doing that but it threw up an error saying that certain linux drivers couldn’t be found. Ultimately I reinstalled Manjaro as I needed it quickly.