Manjaro freezes on boot, flashes BIOS then "Welcome to GRUB" then ends on 10 "No irq handler for vector"

Hello, I am new to linux for about the last 6 or so months. A friend helped me set up my Manjaro plasma environment with Wayland to accommodate gaming on my nvidia gpu.

My PC was down for the last 3 months due to a fatal manufacturer defect on my gpu that lead to a shitstorm getting the card RMA’d by EVGA.

I launched once successfully into the desktop upon replacing the card and then I began updating, upon requested restart for a package update, my computer now freezes on boot. I can access BIOS and I have spent about three days hunting for answers here and elsewhere before I am now finally making a post.

Any help is appreciated.

Extracted text from a picture of my monitor:

0.0035501 common interrupt: 1.55 No irq handler for vector
0.0035501_common_interrupt: 2.55 No irq handler for vector
0.0035501_common_interrupt: 3.55 No irq handler for vector
0.0035501_common_interrupt: 4.55 No irq handler for vector
0.0035501 _common_interrupt: 5.55 No irq handler for vector
0.0035501_common_interrupt: 6.55 No irq handler for vector
0.0035501_common_interrupt: 7.55 No irq handler for vector 
0.0035501_common_interrupt: 8.55 No irq handler for vector
0.0035501 common_interrupt: 9.55 No irq handler for vector
0.0035501 Connon_interrupt: 10.55 No irq handler for vector
1 Like

Hi there,
Can you get to the system at all?
By booting to runlevel 3? Or maybe you have a live USB lying around to chroot in?

What kernel did you run on this machine ?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

I can access recovery menu and was able to successfully get into a timeshift snapshot backup once, I restarted after attempting to figure out which package update caused the issue, and now after restart each of my three snapshots fail to boot.

Can you explain chroot?

The kernel is 6.2

This is a problem because that kernel is EOL.
You need to install another, supported, one. Boot into that, then remove 6.2.
Then your updates will be less problematic.

You use a live ISO on a USB to boot up … then run

manjaro-chroot -a

Thats about it.
But see the links.

1 Like

I tried booting into runlevel 3 and I am greeted by the same no irq handler error followed by what looks like a bash terminal with an error reading “/sbin/init does not exist Bailing out, you are on your own. Good luck.”

I also cant type in the command line.

Its possible one of the fallback images may work if you generated those.
Otherwise … running another system (like a live USB) and chrooting in might be your best bet.

Once there you will probably want to execute:

mhwd-kernel -r linux62

If that doesnt work then

sudo pacman -Rns $(pacman -Qsq linux62)

Then go for update:

sudo pacman -Syu

And rebuild images, etc, for good measure:

sudo mkinitcpio -P
sudo update-grub

Of course share any errors … but assuming all is well…


and restart and test.

1 Like

Ok when I run manjaro-chroot -a in a liveboot I get an error that reads, “cannot find a GRUB drive for /dev/sda1. Check your”

The name of the drive my data is on is /dev/nvme0n1.

Adn there was no other output, such as

Mounting (ManjaroLinux) [/dev/nvme0n1p1]


Make sure to boot the USB as Legacy-BIOS or UEFI, depending on which the system was installed as. Ostensibly whichever one you arent currently booted into.

You can check with

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

Ok I successfully ran all the listed commands you provided, until error when updating GRUB, reading, failed to get canonical path of ‘overlay’

Full output please.

Upon running update-grub,

Output: “/usr/bin/grub-probe: error: failed to get canonical path of ‘overlay’.”

Same output if I try grub-mkconfig. When I tried grub-install output was:

“Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.”

So I got chroot working, ran through these commands, pacman -Syu says everything is uptodate there is nothing to do, and then update grub returns errors for Kernels not found.

No kernels found is definitely a problem.
Was an upgrade interrupted? Or maybe some removal operation was not careful?
I wonder what the end of /var/log/pacman.log might have.
You can check for kernels a few ways…

mhwd-kernel -li
pacman -Qs linux[1-9]

You will need one…ex:

sudo mhwd-kernel -i linux61

Listing installed kernels returns no result in the chroot but when I try to mhwd install linux62 it errors for installing same kernel currently running.

6.2 kernel is dead. You cannot use that one.
It was likely the cause of your original problems (using an EOL kernel) …
Please install a currently supported one.
6.4 is latest Stable.
6.1 is latest Long Term Support.

My apologies running install on linux61 throws “You cant reinstall your current kernel” Then it recommends I system update to which pacman says nothing to do

Installing linux64 runs database sync and then says error no targets specified

What baffles me is running in chroot from liveboot “mhwd-kernel -li” returns:

“Currently running: 6.1.30-1-MANJARO (linux61)
The following kernels are installed in your system:”

with no further output…