Bluetooth is absent from the Gnome upper-right-corner drop-down menu if it's off

I opened this issue on Gnome’s Gitlab, but the guys there say it might be a problem with faulty Gnome-shell packaging by Manjaro. Please advise.

Welcome to the forum! :wave:

If upstream does not receive enough information about an issue they cannot reproduce, it’s very common to blame downstream.

I’ve replied to the issue to clear up the confusion about the packaging.

Please see:

1 Like


I’m quite sure there is no issue from our end:

Thank you for your responses. But I’m not sure what I should do now? Should I provide some further information? This problem occurs on two totally unrelated laptops, one of which Manjaro was very recently installed on. This problem is therefore present on a new install of Manjaro.

Well, you could run from terminal:

gsettings set had-bluetooth-devices-setup true

Log out and the Bluetooth should be there after that. The issue you described can happen when there was no previous Bluetooth setup done before.

No, this is happening after I’ve set up a device, too. As I mentioned, this problem is happening on two different laptops, only one of which Manjaro was very recently set up on.

Apologies. Your solution actually worked. But the problem is, I’ve connected a Bluetooth device many times already. Why wasn’t this gsetting switched on? It’s gotta be some kind of a bug.

By setup Bluetooth i mean to pair it with another Bluetooth device, not just to insert the dongle in. I know is confusing, as i just did a test on a VM install, but i think was always that way.

Pair it with another bluetooth device? Well, I’ve connected my bluetooth headphones to it. And a bluetooth mouse, too. Does that not count as using bluetooth? Seems weird.

I would have to investigate more. Not using much Bluetooth devices.

Okay, I will accept your gsettings suggestion as a solution for now. I think this might be a problem with Gnome, after all.

Well, just doing some quick tests and in fact is not turning ON on that VM install. So i looked at this:

Doing what was proposed there, now i can have a proper behavior … There might be a proper fix next update, i guess.

Yeah, I tried that solution (changing the AutoEnable setting), this actually doesn’t solve the problem. What solves the problem is your solution.

Changing AutoEnable to True: what it does is turning Bluetooth on after every reboot. But if you then go on to turn the Bluetooth off, the Bluetooth disappears from the drop-down menu, just like before.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.