NetworkManager: no secrets: No agents were available for this request

Hello,

I have a labtop which I use generally with docking station. I have no problem connecting with ethernet. I was able to connect to wifi, when I needed but after updates I can not connect to wifi anymore. I receive “no secrets: No agents were available for this request.”.

I am using firewalld but I have not changed my configuration, and previously I was able to connect to wifi.

NetworkManager applet in kde settings have passwords. kwallet is running.

>pgrep wallet
1431 /usr/bin/kwalletd5 --pam-login 6 8
1596 /usr/bin/kwalletmanager5 --kwalletd
>sudo journalctl -u NetworkManager -f 
Nis 17 14:32:09 vostro NetworkManager[1150]: <info>  [1650195129.3330] device (vostro-wlan): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Nis 17 14:32:09 vostro NetworkManager[1150]: <info>  [1650195129.3332] device (vostro-wlan): Activation: (wifi) access point 'mine1-5' has security, but secrets are required.
Nis 17 14:32:09 vostro NetworkManager[1150]: <info>  [1650195129.3332] device (vostro-wlan): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Nis 17 14:32:09 vostro NetworkManager[1150]: <info>  [1650195129.3333] sup-iface[80255963f0105830,0,vostro-wlan]: wps: type pbc start...
Nis 17 14:32:09 vostro NetworkManager[1150]: <info>  [1650195129.3437] device (vostro-wlan): supplicant interface state: inactive -> scanning
Nis 17 14:32:09 vostro NetworkManager[1150]: <info>  [1650195129.3438] device (p2p-dev-vostro-wlan): supplicant management interface state: inactive -> scanning
Nis 17 14:33:19 vostro NetworkManager[1150]: <info>  [1650195199.1128] audit: op="statistics" interface="dock-eth" ifindex=4 args="2000" pid=1560 uid=3000 result="success"
Nis 17 14:33:30 vostro NetworkManager[1150]: <info>  [1650195210.4990] audit: op="statistics" interface="dock-eth" ifindex=4 args="0" pid=1560 uid=3000 result="success"
Nis 17 14:33:31 vostro NetworkManager[1150]: <info>  [1650195211.1568] dhcp6 (dock-eth): activation: beginning transaction (timeout in 45 seconds)
Nis 17 14:33:31 vostro NetworkManager[1150]: <info>  [1650195211.1584] policy: set 'vostro-eth' (dock-eth) as default for IPv6 routing and DNS
Nis 17 14:34:09 vostro NetworkManager[1150]: <warn>  [1650195249.8452] device (vostro-wlan): no secrets: No agents were available for this request.
Nis 17 14:34:09 vostro NetworkManager[1150]: <info>  [1650195249.8453] device (vostro-wlan): state change: need-auth -> failed (reason 'no-secrets', sys-iface-state: 'managed')
Nis 17 14:34:09 vostro NetworkManager[1150]: <warn>  [1650195249.8468] device (vostro-wlan): Activation: failed for connection 'mine1-5'

Any help much appreciated.

Hi @benibilme,

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

Hello,

Thank you for the response. I am not quite sure what information I should provide. Please specify what you need to see, I will provide it.

Thanks again.

I’m not going to repeat myself. Not my thing. So I’m just going to point you at my previous post :point_up: I’ll even be super helpful and link to it here:

I have noticed that kdewallet somehow does not provide credentials to the networkmanager. I have disabled the kdewallet, deleted the cached previous wifi connections. I connected to wifi by suppliying password via network manager applet in kde and I could connect to wifi. I have noticed that “Store passwords for all users (not encryted)” option became active under wifi security tab of the relavant connection in kde connections applet. If I change the setting to “Store password for this user only (encrypted)”, I can connect no more. It does not matter if kdewallet is running or not. It seems kdewallet can not properly communicate with network manager.

In summary, whether or not kdewalled is working, network manager works with open passwords.

If you really want to help and need more information just ask or just go away.

He asked.
Please provide the info mentioned in his post.

With that attitude I’m afraid no ones going to try to help you. I did ask, didn’t want to repeat myself, so gave you a link to it again. And you still didn’t provide any more information. Nor, it seems, did you bother reading the requests. So,

:leaves: :leftwards_hand: This is me, leaving.

3 Likes