X wouldn’t start properly after upgrade

X wouldn’t start properly after upgrade. Screen went black and back to console in an endless loop. Not sure if it is an issue with the new nvidia drivers, Xorg or KDE. Booted into console and restored with timeshift for now.

I am running a “NVIDIA GeForce GTX 1060 with Max-Q” and used optimus manager to use the NVidia only.

Increase your chances of solving your issue:

Provide Information:

Here I have the same problem, no X after boot.
I am also using optimus for my nvidia gtx 1650 card.
I can’t use my laptop, I don’t know how should restore with timeshift.

Just encountered the same issue. (in the difference that it just stayed black ; I had to CTRL + SHIFT + F2 and login in tty2 console

sudo timeshift --restore

Back in 2021 baby ! :smiley:


FYI it happened to me on December the 17th ; in both case I had looooots of upgrades from one day to the other, in particular nvidia. Last time I could yay -Syyu directly and it worked just fine. In this case, I’ll obviously wait for the end of my exams since I need my desktop ; but also I had to downgrade yay -Syuu just after the upgrade since local manjaro-hello was newer than repo.

List of updated packages (sorry, didnt get any blame logs before I timeshift)

Not sure if its fixed yet but according to this thread optimus manager is broken atm

Thanks for the advise, but…
timeshift: command not found.

I tried this from the thread that you mentioned:
sudo pacman -U /var/cache/pacman/pkg/optimus-manager-1.4-1-any.pkg.tar.zst

The system is still unusable.

Not sure if this is the issue but it maybe, have a look in the announcement thread

You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/

Timeshift is a way to rollback your system easily to a previous state.
It is especially useful in completely undoing an update that went the wrong way

Then may be it is time to have a look at



OK, I rebuild the python package.
In the command line with yay you used a “(” character, unfortuntely I can’t see the opposite pair of that, the “)” character. Where should I insert that?

And after the pacman and yay commands, what command will refresh the optimus package?

Thanks for enlighten me about timeshift.
You must to know, the distribution does NOT contain the very useful utility.
If you address me as newbie please enlighten also the manjaro distribution maker group too.
With or without newbie, I must to admit backup is important.

Unfortunately, the commands got truncated when they were quoted. What you can try is the following:

$ pacman -Qoq /usr/lib/python3.9

to see if you have any packages affected by that issue at all, and if yes, you can do

$ yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

In such a case, it is recommended to switch to a console by pressing CTRL+ALT+F2, logging in and having a look at the following places:

cat /var/log/Xorg.0.log
journalctl -b
dmesg | grep nvidia

If you are unable to find any error messages that might be helpful, you can also try

sudo modprobe nvidia

and have a look at any errors thrown at the console or at the very end of the dmesg output.

1 Like

I am very grateful for your quick and useful help.
Now it works! :grinning:

Thanks a lot. Resolved for me. Optimus-manager was also to blame.
Also, for other rookie like me coming here : the below command is to run AFTER the upgrade. Obviously. Yap, I tried to do it before. Of course, it didn’t work and had to timeshift again

$ yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All
1 Like

Thank you. This solved my problem. But mine with python 3.10. I’m just an inch away from formatting and reinstall Manjaro :smiley: . Thank you so much guys.