Global scale is not working

Hi, yesterday I did a fresh install and my new laptop has resolution 2560x1600.
I can see all very very small and I’m trying to use the global scale in 150% but is not affecting to all the elements.

For example when I go to dolphin is almost perfect, but my Desktop is all too small, icons, texts, etc… Same in firefox and all the apps.

Dolphins has some problems for example the icons to close, minimize, etc… the title all is too small. The rest is ok with 150% scale.

And firefox for example like this:

How can I do it to see all OK without lowering my resolution? Is it possible?


Where did you set that to 150%? :thinking:

Everything should have it’s own settings somewhere…
PS: Some apps have their own settings that are depending on your screen’s DPI only…

I would also prefer 1280x540 with meh’ol eyes, except while gaming in 3D :wink:

$ inxi -Gaz
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: ZOTAC driver: nvidia
    v: 535.86.05 alternate: nvidiafb,nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 2 speed: 5 GT/s ports: active: none off: HDMI-A-1
    empty: DP-1, DP-2, DP-3, DVI-D-1 bus-ID: 01:00.0 chip-ID: 10de:1b06
    class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 22.1.8
    compositor: kwin_wayland driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,nouveau,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: 0
  Monitor-1: HDMI-A-1 model: LG (GoldStar) ULTRAWIDE serial: <filter>
    built: 2019 res: 2560x1080 dpi: 97 gamma: 1.2 size: 673x284mm (26.5x11.18")
    diag: 730mm (28.8") modes: max: 2560x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 535.86.05 renderer: NVIDIA GeForce GTX 1080
    Ti/PCIe/SSE2 direct-render: Yes

Thanks for your reply @TriMoon.
I was trying to do it in Settings Screen → Global Scale:

Maybe others can figure out what the problem is if you post your system info in more details. :woman_shrugging:

Because it’s working fine for me on my system, plus that screen looks different on mine, perhaps you’re using a different version of KDE due to distro diff…
It could also be related to having two screens vs a single one on mine.

Please read and follow all advice in this thread:


Sorry @TriMoon, I didn’t replay to you. I don’t know why I didn’t see my post.
I don’t know why is not working the global scale.

I have two monitors one with 2560x1600.
And the other with 1920x1080.

I putted bot in 1920x1080 too see better the things BUT If I open my second monitor (1920x1080, the things are bigger than the other but both are in 1920x1080)

I don’t know how can I do to have the correct scale in both monitors.

I would like to use 2560x1600 obviously, but all is too small, I don’t know if the solution is increase the font. I don’t know if it’s possible put global scale to monitor 1 in 200% and global scale to 100% in monitor 2 or something like that.