Visual glitch issue while using apps!

when I use something a little bit heavy software like, vscode, postman, mongodb compass etc… I face a visual problem on window border and whole layout!

I don’t know what should call this but you can see there’s something like dot . . . inside red marked area!
mainly I use manjaro for coding but this kind of visual glitch are too much distrubing for me!
how can I fix this?

btw, for let you know… I use custom screen resolution using xrandr (/etc/X11/xorg.conf.d/10-monitor.conf)

Hi @muhammadabir,

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

Those are called artifacts that happen with a failing gpu, your VRAM might be done for. Try another OS, but I think you will get the same result. Also like @Mirdarthos said paste your System Information.

this not happen on peppermint, linux lite, endeavouros, kali, zoirn… I’ve used a lot of distro just some of them happen this issue!

  Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_XFCE_2125 quiet
    systemd.show_status=1 apparmor=1 security=apparmor driver=free
    nouveau.modeset=1 i915.modeset=1 radeon.modeset=1
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P8H61-M LX2 R2.0 v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 0605
    date: 07/03/2012
  Message: No system battery data found. Is one present?
  RAM: total: 3.53 GiB used: 1.61 GiB (45.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Pentium G620 bits: 64 type: MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x26
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 128 KiB
    desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB L3: 3 MiB
    desc: 1x3 MiB
  Speed (MHz): avg: 1600 min/max: 1600/2600 scaling: driver: intel_cpufreq
    governor: schedutil cores: 1: 1600 2: 1600 bogomips: 10405
  Flags: acpi aperfmperf apic arat arch_perfmon bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb est fpu fxsr ht
    lahf_lm lm mca mce mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe
    pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp
    rep_good sep sse sse2 sse4_1 sse4_2 ssse3 syscall tm tm2 tsc
    tsc_deadline_timer vme xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds
    status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: ASUSTeK driver: i915 v: kernel ports: active: VGA-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:0102 class-ID: 0300
  Display: x11 server: X.Org v: compositor: xfwm v: 4.16.1 driver:
    X: loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 96 s-size: 270x203mm (10.6x8.0")
    s-diag: 338mm (13.3")
  Monitor-1: VGA-1 res: 1024x768 hz: 60 size: N/A modes: max: 1024x768
    min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK P8 series driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp5s0 state: down mac: <filter>
  Device-2: Realtek RTL8188GU 802.11n WLAN Adapter (After Modeswitch)
    type: USB driver: N/A bus-ID: 2-1.4:7 chip-ID: 0bda:b711 class-ID: 0000
    serial: <filter>
  WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 140.7 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD SSD 120GB
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: <unknown>
    type: SSD serial: <filter> rev: 0108 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: USB DISK 3.0 size: 28.91 GiB
    block-size: physical: 512 B logical: 512 B speed: <unknown> type: N/A
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/dm-0 maj-min: 254:0 mapped: ventoy size: 3.33 GiB fs: iso9660
  ID-2: /dev/sda1 maj-min: 8:1 size: 549 MiB fs: ntfs label: System Reserved
    uuid: 3CD0F0B6D0F0778A
  ID-3: /dev/sda2 maj-min: 8:2 size: 111.25 GiB fs: ntfs label: N/A
    uuid: 5CF6F41AF6F3F1DE
  ID-4: /dev/sdb1 maj-min: 8:17 size: 28.88 GiB fs: exfat label: Ventoy
    uuid: 4E21-0000
  ID-5: /dev/sdb2 maj-min: 8:18 size: 32 MiB fs: vfat label: VTOYEFI
    uuid: 0922-588F
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.2:3 info: Kingston SP Mobile C31 (64GB) type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.1 speed: 480 Mb/s power: 498mA
    chip-ID: 13fe:6300 class-ID: 0806 serial: <filter>
  Device-2: 2-1.3:4 info: USB OPTICAL MOUSE type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 0000:3825 class-ID: 0301
  Device-3: 2-1.4:7
    info: Realtek RTL8188GU 802.11n WLAN Adapter (After Modeswitch) type: WiFi
    driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:b711 class-ID: 0000 serial: <filter>
  Device-4: 2-1.6:5 info: CASUE USB KB type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 2a7a:938f class-ID: 0300
  System Temperatures: cpu: 64.0 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 174 Uptime: 3m wakeups: 0 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1151 lib: 319
  flatpak: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.13

No offense meant, but that sounds very aggressive, dude!

Nevertheless, it doesn’t change the fact that it is quite possibly hardware. And the fact that it did happen on others as well, reaffirms that theory.

If you think it’s a manjaro-only problem, to find out if it’s hardware related try a distro you mentioned to do a benchmark that overloads the VRAM and see if they appear again. But to me it looks like a hardware problem.

thanks @Dullnets & @Mirdarthos for your time but trust me, I only notice this on manjaro, ubuntu, deeping & linux mint but these all was my favourite distro’s!

Let me explain, maybe I expressed myself wrong, you are using integrated graphics which is a GPU integrated into the processor. The integrated graphics hardware does not use a separate memory bank for graphics / video. Instead, the GPU uses system memory shared with the CPU. The fact that this happens to you with these distros over other lighter ones confirms my theory that it can be a hardware problem. That’s why I asked you to try making a benchmark that overloads the VRAM in those distros. If it’s not a hardware problem, that’s better :grinning: But first you should test.


Do you know what kernel the distributions that works use?

@Mirdarthos all of them use 5.4, 5.10 & + higher
but 5.10 works well on my machine

Have you tried using a different Kernel version?

yes… I’ve upgrade & downgraded into different kernels

If the ones giving the problem(s) are all 5.4 and above, try 4.19. It’s LTS and will be supported until December 2024 AFAIK.



From what I can see, this machine is kind of old-ish. So it’s not really surprising if something reach their end of life. And this might just be part of it.

1 Like