Deleted kernel after updating, no longer booting

I tried updating my system and kernel last night, and after resorting to pacman to get around a strange nvidia “breaks dependency” warning to download the latest kernel, I deleted the old one and restarted after checking to see if it was installed properly.

After restarting my system, I was stuck at the boot screen saying “Recovering journel…” and with the blocks readout. It would not progress past that point.

I’ve attempted to install the kernel again using a live environment to no avail. I’m a little new at Linux boot and kernel stuff, so I would not be surprised if I just ruined my system. Is there anything I can do?

EDIT: I forgot to mention that I lost the ability to boot into GRUB, instead my system boots straight to Manjaro.

so boot into the live usb, connect to internet, chroot:
sudo manjaro-chroot -a
post first output from:
mhwd -l && mhwd -li && mhwd-kernel -li

1 Like

While not a solution to the current problem. One best practice is to have two versions of the kernel installed. That way if there is a problem with one kernel (you delete it) you have another to boot into for troubleshooting. Another is to have timeshift and timeshift-autosnap installed. It creates a restore point so if an update fubars your OS its easy to recover.


Here’s those command outputs from earlier:

[manjaro /]# mhwd -l && mhwd -li && mhwd-kernel -li
> 0000:0a:00.0 (0300:10de:2488) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2021.12.18               false            PCI

Warning: No installed USB configs!
Currently running: 5.15.57-2-MANJARO (linux515)
The following kernels are installed in your system:
   * linux519

so chroot again, and rerun update again:
pacman-mirrors --fasttrack 5 && pacman -Syyu
install the 5.15:
pacman -S linux515
reinstall nvidia:
mhwd -r pci video-nvidia
install it again:
mhwd -i pci video-nvidia
then open grub config:
nano /etc/default/grub
edit this line to look like this:
save the file with: ctrl+x, then run this:
reboot and in the grub menu select the 5.15 kernel under advanced options

I got all other commands to run fine, however when I tried to reinstall nvidia this is that I got.

[manjaro /]# mhwd -r video-nvidia
Error: invalid use of option: -r/--remove

[manjaro /]# mhwd --remove video-nvidia
Error: invalid use of option: -r/--remove

I went ahead and ran everything and edited GRUB, so I’m going to restart and hope for the best.

EDIT: After restarting, first I failed to select 5.15 kernel. This brought me to the boot screen which showed “FAILED” and something about failing to update pkgfile database. After restarting and booting 5.15, it sits on the boot screen with the standard byte and block readout with a blinking cursor.

you ran wrong commands for reinstalling drivers, so chroot again:
mhwd -r pci video-nvidia
mhwd -i pci video-nvidia

you ran:
mhwd -r video-nvidia
instead of
mhwd -r pci video-nvidia

That was it! I apologize for running the wrong command, I didn’t even double check. It boots up, now I’m off to reinstall Windows for dual boot. Thank you so much for bearing with me!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.