GTA IV Complete Edition crashes when I try to open it

I recently installed Manjaro KDE Plasma Minimal (recommended by a friend) since I needed Linux for a course I’m doing. I had some space so I decided to download games to play since I ended up liking Linux quite a lot. Anyway, one of the games I downloaded was GTA IV Complete Edition through Steam and since then I haven’t been able to launch the game, it simply gives an error and closes itself.


A few of the things I’ve tried were.

  • A few Proton versions, none made any difference

  • Using PROTON_USE_WINED3D=1 %command% as a launch option since it fixed Hitman: Blood Money (which was also crashing on startup but without any error)

  • Downloading Rockstar Games Launcher through Lutris but I ran into another problem, which was being unable to log in (2fa fails when I try to input the numbers)

I’d like to clarify that this PC is REALLY underpowered, BUT, it should be able to run GTA IV without any major problems. Everything is up to date (afaik).

Where do you know that for a fact? We got no information about the system, but you already indicated things that tell me you can NOT run Proton games properly.

First things first:

A key word to get support is to provide information, logs, exact actions and results, for example when you say “I tried a few Proton version”, which ones and what were the logs from Steam and Proton when launching the game? You see the difference between what you provided for information and what is expected?

Then it doesn’t use Proton as you should, it internally then use the OpenGL mode for the game instead of DXVK the Vulkan to DirectX translation layer, which is most case is a big nono or only for a backup solution to run old games, and with bad performance.


You can start Steam from a terminal to get direct Steam log output in the terminal itself which is great to have errors on game launch directly.
You can add Launch option to the game itself to make it create a log in your Home folder so you can the what Proton is getting for errors too, right click the game, go to Properties, and add this launch option PROTON_LOG=1 %command% it will generate a log called steam-APPID.log where APPID is the Steam App ID.

1 Like
  Kernel: 6.6.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=4cb25bd6-91c0-4b8e-8d5f-0ddf57105973 rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: A88XM-A v: Rev X.0x
    serial: <superuser required> UEFI-[Legacy]: American Megatrends v: 3001
    date: 03/09/2016
  Info: model: AMD A10-7850K Radeon R7 12 Compute Cores 4C+8G bits: 64
    type: MT MCP arch: Steamroller level: v2 built: 2014 process: GF 28nm
    family: 0x15 (21) model-id: 0x30 (48) stepping: 1 microcode: 0x6003106
  Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 256 KiB
    desc: d-4x16 KiB; i-2x96 KiB L2: 4 MiB desc: 2x2 MiB
  Speed (MHz): avg: 2403 high: 3351 min/max: 1700/3700 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1768 2: 3351
    3: 2394 4: 2101 bogomips: 29539
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Kaveri [Radeon R7 Graphics] vendor: ASUSTeK driver: radeon
    v: kernel alternate: amdgpu arch: GCN-2 code: Sea Islands
    process: GF/TSMC 16-28nm built: 2013-17 ports: active: VGA-1
    empty: DVI-D-1,HDMI-A-1 bus-ID: 00:01.0 chip-ID: 1002:130f class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: radeon display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
    s-diag: 449mm (17.69")
  Monitor-1: VGA-1 mapped: VGA-0 model: LG (GoldStar) L192WS serial: <filter>
    built: 2007 res: 1440x900 hz: 60 dpi: 89 gamma: 1.2
    size: 410x256mm (16.14x10.08") diag: 483mm (19") ratio: 16:10 modes:
    max: 1440x900 min: 720x400
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast gbm: drv: kms_swrast surfaceless: drv: radeonsi x11:
    drv: radeonsi inactive: wayland
  API: OpenGL v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: KAVERI ( LLVM 16.0.6 DRM 2.50 6.6.8-2-MANJARO)
    device-ID: 1002:130f memory: 1000 MiB unified: no
  API: Vulkan Message: No Vulkan data available.
  Device-1: AMD Kaveri HDMI/DP Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:01.1 chip-ID: 1002:1308 class-ID: 0403
  Device-2: AMD FCH Azalia vendor: ASUSTeK AM1I-A driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  API: ALSA v: k6.6.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK H81M-C driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter
    driver: rtl8187 type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
    bus-ID: 2-4:2 chip-ID: 0bda:8189 class-ID: 0000 serial: <filter>
  IF: wlp0s18f2u4 state: up mac: <filter>
  Local Storage: total: 2.04 TiB used: 84.47 GiB (4.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10EZEX-00BBHA0
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: 1A01 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA100
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A750 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: PNY model: CS900 240GB SSD
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 0613 scheme: GPT
  ID-1: / raw-size: 931.51 GiB size: 915.81 GiB (98.31%) used: 84.47 GiB (9.2%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 50.0 C mobo: N/A gpu: radeon temp: 46.0 C
  Fan Speeds (rpm): N/A
  Processes: 229 Uptime: 1h 12m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 14.58 GiB used: 4.6 GiB (31.5%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1262 libs: 416 tools: pamac,yay Shell: Zsh v: 5.9
  default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31

I know GTA IV can run on windows with my specs (and it should be compatible with Vulkan, I honestly have no idea if it can run Proton games, but that’s why I’m here.

The version of proton I’ve tried were; Proton experimental, Proton 8.0-4 and Proton 7.0-6 (None of them really made any difference)[6092]: Running Steam on manjarolinux 23.1.1 64-bit[6092]: STEAM_RUNTIME is enabled automatically[6165]: Steam runtime environment up-to-date![6092]: Steam client's requirements are satisfied
[2023-12-24 16:57:21] Startup - updater built Dec  8 2023 00:32:59
[2023-12-24 16:57:21] Startup - Steam Client launched with: '/home/zero/.local/share/Steam/ubuntu12_32/steam'
12/24 16:57:21 Init: Installing breakpad exception handler for appid(steam)/version(1702079146)/tid(6217)
[2023-12-24 16:57:21] Loading cached metrics from disk (/home/zero/.local/share/Steam/package/steam_client_metrics.bin)
[2023-12-24 16:57:21] Using the following download hosts for Public, Realm steamglobal
[2023-12-24 16:57:21] 1., /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-12-24 16:57:21] 2., /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-12-24 16:57:21] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-12-24 16:57:21] Verifying installation...
[2023-12-24 16:57:21] Verification complete

Steam logging initialized: directory: /home/zero/.local/share/Steam/logs

/usr/share/themes/Breeze/gtk-2.0/widgets/entry:70: error: unexpected identifier 'direction', expected character '}'
/usr/share/themes/Breeze/gtk-2.0/widgets/styles:36: error: invalid string constant "combobox_entry", expected valid string constant
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xe9189dc0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xe9188500[6241]: Runtime for steamwebhelper: defaulting to /home/zero/.local/share/Steam/ubuntu12_64/steam-runtime-heavy[6241]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
Steam Runtime Launch Service: starting steam-runtime-launcher-service
Steam Runtime Launch Service: steam-runtime-launcher-service is running pid 6336
CAppInfoCacheReadFromDiskThread took 183 milliseconds to initialize
vkEnumeratePhysicalDevices failed, unable to init and enumerate GPUs with Vulkan.
BInit - Unable to initialize Vulkan!
vkEnumeratePhysicalDevices failed, unable to init and enumerate GPUs with Vulkan.
BInit - Unable to initialize Vulkan!
BRefreshApplicationsInLibrary 1: 1ms
BuildCompleteAppOverviewChange: 441 apps
RegisterForAppOverview 1: 26ms
RegisterForAppOverview 2: 26ms
fsync: up and running.
wine: RLIMIT_NICE is <= 20, unable to use setpriority safely
/bin/sh\0-c\0PROTON_LOG=1 /home/zero/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=12210 -- /home/zero/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/home/zero/.local/share/Steam/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/home/zero/.local/share/Steam/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/home/zero/.local/share/Steam/steamapps/common/Grand Theft Auto IV/GTAIV/PlayGTAIV.exe' WINEDLLOVERRIDES="dinput8=n,b" /home/zero/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=12210 -- /home/zero/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/home/zero/.local/share/Steam/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/home/zero/.local/share/Steam/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/home/zero/.local/share/Steam/steamapps/common/Grand Theft Auto IV/GTAIV/PlayGTAIV.exe' gamemoderun /home/zero/.local/share/Steam/ubuntu12_32/reaper SteamLaunch AppId=12210 -- /home/zero/.local/share/Steam/ubuntu12_32/steam-launch-wrapper -- '/home/zero/.local/share/Steam/steamapps/common/SteamLinuxRuntime_soldier'/_v2-entry-point --verb=waitforexitandrun -- '/home/zero/.local/share/Steam/steamapps/common/Proton 7.0'/proton waitforexitandrun  '/home/zero/.local/share/Steam/steamapps/common/Grand Theft Auto IV/GTAIV/PlayGTAIV.exe' -novid -nojoy -console\0
chdir "/home/zero/.local/share/Steam/steamapps/common/Grand Theft Auto IV/GTAIV"
ERROR: object '/home/zero/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/zero/.local/share/Steam/ubuntu12_64/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS64): ignored.
ERROR: object '/home/zero/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/zero/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
ERROR: object '/home/zero/.local/share/Steam/ubuntu12_32/' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
Game 12210 created interface STEAMAPPLIST_INTERFACE_VERSION001 / AppList
Game 12210 created interface STEAMAPPS_INTERFACE_VERSION008 / Apps
Game 12210 created interface STEAMHTMLSURFACE_INTERFACE_VERSION_004 / HTMLSurface
Game 12210 created interface STEAMHTTP_INTERFACE_VERSION002 / HTTP
Game 12210 created interface STEAMINVENTORY_INTERFACE_V002 / Inventory
Game 12210 created interface STEAMMUSICREMOTE_INTERFACE_VERSION001 / MusicRemote
Game 12210 created interface STEAMMUSIC_INTERFACE_VERSION001 / Music
Game 12210 created interface STEAMPARENTALSETTINGS_INTERFACE_VERSION001 / ParentalSettings
Game 12210 created interface STEAMREMOTESTORAGE_INTERFACE_VERSION014 / RemoteStorage
Game 12210 created interface STEAMSCREENSHOTS_INTERFACE_VERSION003 / Screenshots
Game 12210 created interface STEAMUGC_INTERFACE_VERSION010 / UGC
Game 12210 created interface STEAMUSERSTATS_INTERFACE_VERSION011 / UserStats
Game 12210 created interface STEAMVIDEO_INTERFACE_V002 / Video
Game 12210 created interface SteamController006 / Controller
Game 12210 created interface SteamFriends015 / Friends
Game 12210 created interface SteamMatchMaking009 / Matchmaking
Game 12210 created interface SteamMatchMakingServers002 / MatchmakingServers
Game 12210 created interface SteamNetworking005 / Networking
Game 12210 created interface SteamUser019 / User
Game 12210 created interface SteamUtils009 / Utils
Game 12210 method call count for IClientAppManager::GetAppInstallState : 2
Game 12210 method call count for IClientUtils::RecordSteamInterfaceCreation : 22
Game 12210 method call count for IClientUtils::GetSteamUILanguage : 1
Game 12210 method call count for IClientUtils::GetAppID : 24
Game 12210 method call count for IClientUser::GetSteamID : 1
Uploaded AppInterfaceStats to Steam
[2023-12-24 16:59:23] Background update loop checking for update. . .
[2023-12-24 16:59:23] Checking for available updates...
[2023-12-24 16:59:23] Downloading manifest:
[2023-12-24 16:59:23] Manifest download: send request
[2023-12-24 16:59:23] Manifest download: waiting for download to finish
[2023-12-24 16:59:24] Manifest download: finished
[2023-12-24 16:59:24] Download skipped: /steam_client_ubuntu12?t=3149395468 version 1702079146, installed version 1702079146, existing pending version 0
[2023-12-24 16:59:24] Nothing to do

Thanks for the patience, I’m somewhat new to doing things on my own in Linux.

I would expect that the amdgpu driver provides a better performance, have a look here:

1 Like

I’ll try that, thanks

But that doesn’t mean it will run under Proton on a Linux system. especially with not so high end hardware.

The Steam log doesn’t tell us anything, it is weirdly silent about what’s going on.
Maybe the Proton log would share more info regarding the issue you’re having.

Also I can see you added startup parameter for the game -novid -nojoy -console where did you get that? Why did you put them? Remove them if you’re troubleshooting, don’t add things that will complicate things, start simple, have things to work before trying to customize. I can tell you, these are not GTA startup parameter but Source games parameters.

When you change Proton version, especially when troubleshooting, always reset the Proton prefix folder, delete it or rename it to something else to keep it if it contains savegame you may lose by deleting the folder, it is located, by default, in ~/.local/share/Steam/steamapps/compatdata/12210 for this game (if you install on another disk, it will be another path). Always reset the Proton prefix between tests if previous thing didn’t work.

Proton latest versions may require higher support for some video card functionalities, so you may try an old Proton version like the Proton 6.

But the best bet for now, is to use amdgpu driver, that you can enable (along with other experimental features…) by simply installing the package amdgpu-experimental from the repositories amdgpu-experimental (I’m not sure how technical you are, the Arch WIKI could be confusing as it assumes you already know and understand most of the things they don’t explain at all, so following it could be tricky).

Check with the inxi command if this worked and you’re not using the old radeon driver anymore.

1 Like

I copied it from to activate gamemode gamemoderun %command% -novid -nojoy -console thing is, I copied it from Left 4 Dead 2 and I forgot to remove -console, and had no idea what -novid and -nojoy did or that they where for source only. I now removed that, even if it made no difference, thanks for the heads up.

About the Steam log, it does say that Vulkan couldn’t initialize

vkEnumeratePhysicalDevices failed, unable to init and enumerate GPUs with Vulkan.
BInit - Unable to initialize Vulkan!

I guess that could be because of the drivers, since I saw in the Arch wiki that there was an option to enable Vulkan

For Vulkan support:

Test with only vulkan-radeon first: although not appearing as the first provider of vulkan-driver (due to its alphabetical order), it avoids some issues that have repeatedly been reported about amdvlk.

When the amdvlk package is installed, it sets itself as the default Vulkan driver: see Vulkan#Selecting via environment variable if you need to have both drivers installed (e.g. when having issues with vulkan-radeon).

Optionally, for 32-bit application support, install the lib32-vulkan-radeon or lib32-amdvlk package to match the native package installed.

I will try reseting Proton prefix and using version 6

I ain’t really got much idea of what I’m doing, but I will try my best to install amdgpu and use those drivers instead to test if that makes any difference. If i run into any problems installing them I guess I’ll come back here.

Well, did you verify your game data? Please don’t tell me the game is on an NTFS partition…

The radeon driver does not support Vulkan.

Have you checked ProtonDB?

1 Like

As I said, just install the package I told you, to enable the proper amdgpu driver if you don’t know what you’re doing.

Didn’t catch that as it is before the game is started. Anyway back to initial thought, as you’re using the old radeon driver, start with using amdgpu driver, and see. Just do one thing at a time to try to pinpoint the issue but this is most likely the issue.

//EDIT: this is also why your other game worked with PROTON_USE_WIND3D as it would run on OpenGL and not Vulkan and why I thought initially what you said was pointing to you not being able to run Proton games.

1 Like

Yes, verifying game data was the first thing I tried, did not change a thing. And no, it’s not an NTFS partition, it’s ext4, the disk where I have Linux installed is literally brand new.

Figured that would be it. Like I said, when I have time I’ll install amdgpu driver instead and try with that.

Alright, just making sure.

Normally, there’s nothing to install as it’s provided by the kernel.

However, there is something that may work.

We have a package called amdgpu-experimental based on Enable Southern Islands (SI) and Sea Islands (CIK) support.

Be aware: Either it will work and you’ll be using amdgpu, or it won’t and booting will fail. Be prepared to switch to a TTY to remove the package if it does fail.

Oh boy… Alright, I’m just going to try it, worst case scenario, if it doesn’t work and I can’t get it working again I can easily just reinstall Linux, I installed just a few days ago, it’s pretty fresh.

I would just be a command from the non working system at worst. If you can come back here tell you have a black screen, and someone will explain what to do.

It did not work, and I couldn’t figure out how to open TTY (I tried ctrl+alt+Fx but nothing happened, I always got a black screen with nothing on it). So I just reinstalled Manjaro and everything’s already back to normal, tbh, working even better than before LMAO.

just to be curious,
did you try to run it with lutris?
Most of the games what i have tried run with it and handling is not to hard.

I only had to install lately additional the package proton-qt, that it runs with the Lutris-GE-Proton8-5 settings at → rightclick - configuration - options.

I did deactivate there Vulkan and activated DXVK, or toggle around, if it still doesnt work.
Both activated at the same time caused some lag.
And if it still does not run proper, you can run lutris from a console and see what errors it has.
But mainly, its the easiest setup for games, and it has a lot of install scripts at her page (left side top, that little cross).


DXVK is litterally DirectX to Vulkan translation layer, it IS Vulkan.

Anyway, the issue is most likely the radeon driver, not supporting Vulkan which is required to run Proton games properly, as we already established in the thread. Also she has tried Lutris (read first post).

Hi omano
Weird, that you reply where my post was not directed to you.
Also answer questions, what i asked the op.

There is nothing weird here, besides not even reading the first post to reply to a thread.

That’s a forum, expect people to reply. Even the ones you didn’t wrote to directly.

Ofc here is something weird with your answers.
That its the radeon driver so far i see, is only your opinion.
Second she tried lutris only for the launcher.
So why do you open now a a new can with your assumptions and bload the topic?

That’s not only my opinion, that’s what was found in the logs, as per the thread, just read it.