Boot into a static Black Screen Upon a Fresh Install (Gnome Edition)

This is similar to several other posts, but unfortunately couldn’t find any advice that applies to this situation.

Installation Steps:

  • Tried to Install several times with and without proprietary drivers
  • In all cases, Live USB experience works great, and installation completes without issues

System Config:

  • Ryzen 3700 X
  • Nvidia RTX 2060 Super
  • Windows 10 on SSD drive, with its own EFI Boot Partition
  • Ubuntu 20.04 LTS on an NVMe drive, with its own EFI boot Partition, along with Manjaro (21.2.1) entirely installed on one partition besides Ubuntu

Manjaro Linux Kernel 5.15.12-1

Fails to boot Normally into Manjaro - gets to a blank, black screen, completely frozen.

Successfully Boots with fallback initramfs

Upon booting with the fallback option, tried switching back and forth between the Open Source and Proprietary Drivers (Assuming it might be a driver Issue), Still unable to boot without the fallback initramfs mode.

So the question is, what makes the fallback initramfs work while the normal mode doesn’t?

Thanks in Advance!

The fallback initramfs includes ALL modules of the kernel. If this works, but your normal initramfs does not, then you have to look into /etc/mkinitcpio.conf to look for the problem.

The Arch wiki may be a good resource to do this.

Increase your chances of solving your issue:

Provide Information:

Hey that makes a lot of sense!

Thank you so much for your help and quick response.

Housekeeping …