How to connect iPhone 6

Hello. How to connect iphone 6 ios 12 on manjaro KDE plasma 22.0 «Sikaris . Everything by default is already libimobiledevice, etc., it connects as a device, you trust it, but it is not displayed anywhere in the explorer. On the same Manjaro Mate, you click to trust the device and now the iphone is displayed in the explorer, the iphone Documents folders appear on the desktop and you can upload files.

Welcome to the forum! :wave:

Please edit your topic title to be more clear and concise about what you need help with. I suggest something like, How do I connect an iPhone 6?

As far as what KDE ISO you installed, more detailed information like that should be in the first post, not the topic title.

Please see:

Please be more specific. One must manually install libimobiledevice, nothing is installed by default.

EDIT: It’s a dependency of a few packages that may be preinstalled like gvfs-afc and upower.

Please see: iOS - ArchWiki

I looked for libimobiledevice in Pamak, I found it, it had a trash icon on it, which means it was already installed right away in Sikaris. Namely, that you connect the Iphone, trust the device, open it through the file manager and it’s empty. In the same Manjaro Mate or in Deepin, you connect your iphone, trust the device in the explorer, iPhone Documents immediately appears and you can upload movies to your phone. But Dolphin does not see iPhone 6. Maybe there still need to install ifuse.

There is likely several possible components available - have you checked the Arch wiki?

The package gvfs-afc provides some Apple device related functionality.

1 Like

As I understand it, you first need to install all the missing packages as gvfs-afc and only then connect the iphone
And yes arch wiki looked and did everything as there. A folder with a photo appeared, but there are no folders with the iPhone Documents window where you can throw a video there.
And I also collected there at the suggestion of solid-gitAUR and kio-extras-git, so the screen popped up. The work of the screen blocker is broken, switch to the virtual terminal, etc. kio-extras-git was building for a long time, and then after 20 minutes of building, an interrupt error occurred. I reboot the system and the window pops up, select the login and enter the password, and something is there on a blue background in red letters, something about the topic is some kind of error. It’s just that for the window if there is an auto-login. I had to reinstall the system and again when assembling the jamb.
And I also thought to put another file manager instead of a dolphin, on any other iphone it works out of the box, but the problem does not work again. And so I would like to put a deepin interface, it’s beautiful, but it’s set up, but some is not stable. But strangely, change it, don’t change the interface, but it’s still like it’s really KDE. Although deepin Linux also installed out of the box, the phone works. If only it weren’t for the nvidia drivers that I couldn’t install, I would have stayed on it.

I ran into a similar problem last year trying to get access to my iPod Touch’s photos/videos. Here are some of my notes, some problems I ran into and references that eventually led me to a solution that worked. They are a bit sketchy but perhaps they will be of help for your iPhone.

Tried to transfer some photos from the iPod Touch to the PC, missing the permission to trust popup on the iPod and Dolphin can’t seem to get into the iPod, like it’s not mounting.

Some references to research:
iFuse –

This YouTube might be of some help as well:

This one suggests installing iFuse and then Shotwell –

Installed iFuse first and when that completed, installed Shotwell. Have to restart before using iFuse.

Continuing to have that missing Trust popup in the iPod and without it, nothing connects.
A search came up with this page –

The one possible solution it offered worked: Going to the iPod’s Reset Location & Privacy Settings (Settings app → General → Reset → Reset Location & Privacy) and doing the reset did the trick. Plugging in the iPod to USB, getting past the lock screen eventually brought up the Trust popup.

Found this other solution later on –
It suggested a solution for when the Trust popup didn’t appear –
If you do not see the popup, you can start the pairing process manually. Connect the device, unlock the screen and run:
$ idevicepair pair
SUCCESS: Paired with device d8e8…

The problem with Shotwell’s organization of photos is the missing filenames; since I have based my history of known imported photos on their filenames, not being able to view the photos by filenames leaves me in the dark as to whether I have already imported them.
Going back to Dolphin and entering into the nav bar camera:// (it automatically added another slash to create the camera:///) and that then displayed USB PTP Class Camera / store_00010001 / DCIM / 102APPLE, etc. And then I was able to copy over the new photos to the hard drive.

The steps 4 and 7 listed gave a clue as to what this “mountpoint” was all about. I created an iPod directory in Home and thus, the command would be –
ifuse ~/iPod
And BINGO! Dolphin now lists all sorts of stuff in the iPod directory!! including the photo files.
Note that I had to again reset the Location and Privacy settings before I got the Trust popup.
Step 8: When you want to unmount it, you should use this command:
sudo umount ~/iPod

1 Like

The feeling that you connect a phone to manjaro Cinnamon and Mate, trust it and it immediately appears in Nemo would be sitting, but the interface itself looks like 20 years ago. It also appears in Deepin. But on all KDE that I have tried, it does not appear anywhere after trust. Well, how does Manjaro Cinnamon differ from KDE, if only in appearance and a dance file manager, but all the software will be the same, fresh and the necessary to work with iphone is included in them the same. But the dolphin does not work without dancing.
Well, I’ll try to dance more on what you suggested.

Nothing is shorter, does not see kde out of the box and that’s it