Won't boot after update, pacman no connection

Following an update Today (06/02)
My system is hanging on “/dev/nvme0n1p2: clean, / files, / blocks”

I’ve tried running “kstart5 plasmashell” and get the following result

qt.qpa.xcbP could not connect to display
qt.qpa.plugin: could not load the Qt platform “xcb” in “” even though it was found
this application failed to start because no Qt platform plugin could be initialized, reinstalling the application may fix this problem

Available platform plugins are: eglfs, linuxfb, minimal, minimaleg1, offscreen, vnc, waylands-eg1, wayland, wayland-xcomposite-eg1, wayland-xcomposite-glx, xcb.

Aborted (core dumped)

I’ve tried “sudo pacman -Syu”
and got core.db failed to download … could not resolve host…

I also tried opening the grub menu and adding “nomodeset” but that just gave out a command not found message.

Running AMD 3700x and an RTX 2070

results of mhwd -li are:

name: video-nvidia
version: 2021.12.18
freedriver: false
type: PCI

How to increase your chances of solving your issue:

Please provide Information: