Kpeoplevcard will not update from 0.1-2 to 0.1+r38.32d50a9-1

I’ve tried all the other solutions that I could find before like uninstalling and re-installing but nothing gets it to update. Is it even a useful, required piece of software?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

It is if you use kdeconnect.

If you don’t use kdeconnect then uninstall both.

1 Like

Do a downgrade of the package. See here: Packages

0.1-2 is the most recent version. Package managers get confused by the older version number, 0.1+r38.32d50a9-1, due to an unfortunate numbering quirk.

Do you read the update announcements? This solution was posted on the second thread of every update announcement for the past 2 months.

Have you seriously not updated your system in over 2 months?

1 Like

As Takakage said, there is nothing to update. If some package manager offered you that sort of upgrade you are probably not properly synced. If you have another problem you have to formulate it more precisely and post some logs.

1 Like

As has been outlined in countless other posts and in every release announcement for months …



sudo pacman -Syuu

Did you do that?


Seems to be working for all package managers but Discover, it keeps asking for an upgrade.


For those that need more explanation.
Discover is fine for things like
For Arch/Manjaro system packages it is a packagekit frontend.

Please see the literal first line of the Archwiki on the pacman subsection “Graphical Utilities”;

(which, honestly, is a very mild note for all the myriad problems it can actually produce)

1 Like

I don’t. I use it as KDE widget update manager, which any other package managers are incapable of. I don’t think your argument isn’t convincing enough to ignore that it’s not doing things right.

So many negatives.
Lets break it down.
So you think my argument is convincing enough for people to ignore that its doing things wrong ?

Seems confusing to me.

You shout as if it’s something not need fixing, just don’t use it as a package manager and ignore whatever it is doing, instead of admitting there’s something missing there that needs fixing so it doesn’t display the wrong update information anymore.

I guess I used capitals.

But … what is there to admit?

Its not my tool … just like pamac is not … they dont work correctly, have not for years … so … I dont use them.

This is not a dichtomy between that and improving it.

By all means improve it if you can.

But packagekit itself is broken … so unless you fix that … or have Discover use something else (both development cases neither of us has control over) … then the only good advice is to not use them for those purposes.

Up til now

The only valid package management in Arch (And manjaro) is the ALPM.

pacman uses it. even pamac uses it with all its faults.

Discover … does not. It is not valid even if it ‘worked’ … which it doesnt.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.