Unable to boot to desktop after update from kernel 513 - kernel 515

Hello, so my KDE machine has been broken for a couple of weeks now and for the past couple of days I’ve been trying to fix it, this happened after updating the machine there was a new kernel update so my machine updated from kernel 513 to 515 and after rebooting my computer it would not get past the startup script and just stay stuck there. I figured out that by uninstalling and reinstalling NVIDIA drivers or by using the startx command my computer manages to load the desktop environment and I would be able to use my machine normally until next boot I have tried fixing this using tty2 terminal and from live boot reinstalling drivers just don’t seem so work for my case to me it seems like my machine is not loading the NVIDIA driver modules at boot unless i reinstall or use startx command. Any tips to help solve this? i am using the latest drivers for 2070 Super running proprietary drivers.

Increase your chances of solving your issue:

Provide Information:

Boot from USB:

see this

I ran the commands @stephane posted on that post, running mhwd-kernel -li returned linux513 and 516 .preset.somethingsave so I removed them and kept the current one for linux515. I then ran mkinitcpio -P then update-grub and rebooted my machine and still having the same issue but I had no idea there were still some stuff left behind from those kernels so thank you for the suggestion.

can you boot on USB live manjaro ,
open a terminal and browser on this topic,

sudo manjaro-chroot -a
mhwd-kernel -li
mhwd -li 
ls /etc/mkinitcpio.d/*.preset
ls /boot/
ls /bin/modules/
exit ( to end chroot )

kernels 5.10 (LTS) should also works on your config

These are the results when I ran the commands.

Command: mhwd-kernel -li
Currently running: 5.10.89-1-MANJARO (linux510)
The following kernels are installed in your system:
   * linux515
Command: mhwd -li   
Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

command: ls /etc/mkinitcpio.d/*.preset 

command: ls /boot/

command: ls /usr/bin/modules/
ls: cannot access '/usr/bin/modules/': No such file or directory

Also I should note when I ran mhwd-kernel -li on the machine it gives me

Currently running: 5.15.12-1-MANJARO (linux515)
The following kernels are installed in your system:

  • linux515

which defers from what the live boot gave me.

error on part

sudo ls /bin/modules/

you can add kernel 5.10

sudo mhwd-kernel -i linux510

can you report

inxi -Fza

This is what I got

command: inxi -Fza
  12Kernel 5.10.89-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 11.1.0
    12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC misobasedir=manjaro
    misolabel=MANJARO_KDEM_2121 quiet systemd.show_status=1 apparmor=1 security=apparmor
    driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  12Console N/A 12wm kwin_x11 12Distro Manjaro Linux 12base Arch Linux
  12Type Desktop 12System Gigabyte 12product B550 AORUS PRO AC 12v N/A 12serial N/A
  12Mobo Gigabyte 12model B550 AORUS PRO AC 12v x.x 12serial N/A 12BIOS American Megatrends 12v F1
    12date 05/14/2020
  12Info 12model AMD Ryzen 7 3700X 12socket AM4 12bits 64 12type MT MCP 12arch Zen 2 12family 0x17 (23)
    12model-id 0x71 (113) 12stepping 0 12microcode 0x8701021
  12Topology 12cpus 1x 12cores 8 12tpc 2 12threads 16 12smt enabled 12cache 12L1 512 KiB
    12desc d-8x32 KiB; i-8x32 KiB 12L2 4 MiB 12desc 8x512 KiB 12L3 32 MiB 12desc 2x16 MiB
  12Speed (MHz) 12avg 2375 12high 3600 12min/max 2200/4560:4690:4823:4426:5224:5091:4957 12boost enabled
    12base/boost 3600/4400 12scaling 12driver acpi-cpufreq 12governor schedutil 12volts 1.1 V
    12ext-clock 100 MHz 12cores 121 3600 122 3600 123 2200 124 2200 125 2200 126 2200 127 2200 128 2200 129 2200 1210 2200
    1211 2200 1212 2200 1213 2200 1214 2200 1215 2200 1216 2200 12bogomips 115026
  12Flags avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  12Type itlb_multihit 12status Not affected
  12Type l1tf 12status Not affected
  12Type mds 12status Not affected
  12Type meltdown 12status Not affected
  12Type spec_store_bypass 12mitigation Speculative Store Bypass disabled via prctl and seccomp
  12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization
  12Type spectre_v2
    12mitigation Full AMD retpoline, IBPB: conditional, STIBP: conditional, RSB filling
  12Type srbds 12status Not affected
  12Type tsx_async_abort 12status Not affected
  12Device-1 NVIDIA TU104 [GeForce RTX 2070 SUPER] 12vendor eVga.com. 12driver nvidia 12v 495.44
    12alternate nouveau,nvidia_drm 12bus-ID 09:00.0 12chip-ID 10de:1e84 12class-ID 0300
  12Device-2 Logitech HD Pro Webcam C920 12type USB 12driver snd-usb-audio,uvcvideo 12bus-ID 1-9:7
    12chip-ID 046d:082d 12class-ID 0102 12serial <filter>
  12Display 12server X.org 12compositor kwin_x11 12driver 12loaded nvidia
  12Message Unable to show advanced data. Required tool glxinfo missing.
  12Device-1 YUAN High-Tech Development 12driver N/A 12bus-ID 04:00.0 12chip-ID 12ab:0710 12class-ID 0480
  12Device-2 NVIDIA TU104 HD Audio 12vendor eVga.com. 12driver snd_hda_intel 12v kernel 12bus-ID 09:00.1
    12chip-ID 10de:10f8 12class-ID 0403
  12Device-3 AMD Starship/Matisse HD Audio 12vendor Gigabyte 12driver snd_hda_intel 12v kernel
    12bus-ID 0b:00.4 12chip-ID 1022:1487 12class-ID 0403
  12Device-4 Logitech HD Pro Webcam C920 12type USB 12driver snd-usb-audio,uvcvideo 12bus-ID 1-9:7
    12chip-ID 046d:082d 12class-ID 0102 12serial <filter>
  12Sound Server-1 ALSA 12v k5.10.89-1-MANJARO 12running yes
  12Sound Server-2 JACK 12v 1.9.19 12running no
  12Sound Server-3 PulseAudio 12v 15.0 12running yes
  12Sound Server-4 PipeWire 12v 0.3.42 12running no
  12Device-1 Realtek RTL8125 2.5GbE 12vendor Gigabyte 12driver r8169 12v kernel 12port f000 12bus-ID 07:00.0
    12chip-ID 10ec:8125 12class-ID 0200
  12IF eno1 12state up 12speed 1000 Mbps 12duplex full 12mac <filter>
  12Device-2 Intel Dual Band Wireless-AC 3168NGW [Stone Peak] 12driver iwlwifi 12v kernel
    12bus-ID 08:00.0 12chip-ID 8086:24fb 12class-ID 0280
  12IF wlp8s0 12state down 12mac <filter>
  12Device-3 Realtek RTL8153 Gigabit Ethernet Adapter 12type USB 12driver r8152 12bus-ID 6-4.4:3
    12chip-ID 0bda:8153 12class-ID 0000 12serial <filter>
  12IF enp11s0f3u4u4 12state down 12mac <filter>
  12Device-1 Intel Wireless-AC 3168 Bluetooth 12type USB 12driver btusb 12v 0.8 12bus-ID 1-5:4
    12chip-ID 8087:0aa7 12class-ID e001
  12Report rfkill 12ID hci0 12rfk-id 0 12state up 12address see --recommends
  12Local Storage 12total 5.71 TiB 12used 220.87 GiB (3.8%)
  12ID-1 /dev/nvme0n1 12maj-min 259:0 12model PCIe SSD 12size 1.82 TiB 12block-size 12physical 512 B
    12logical 512 B 12speed 31.6 Gb/s 12lanes 4 12type SSD 12serial <filter> 12rev ECFM53.0 12temp 28.9 C
  12SMART yes 12health PASSED 12on 66d 10h 12cycles 357 12read-units 69,685,219 [35.6 TB]
    12written-units 25,256,006 [12.9 TB]
  12ID-2 /dev/sda 12maj-min 8:0 12vendor Western Digital 12model WD40EZRZ-00WN9B0 12family Blue
    12size 3.64 TiB 12block-size 12physical 4096 B 12logical 512 B 12sata 3.0 12speed 6.0 Gb/s 12type HDD 12rpm 5400
    12serial <filter> 12rev 0A80 12temp 33 C
  12SMART yes 12state enabled 12health PASSED 12on 2y 266d 15h 12cycles 3109
  12ID-3 /dev/sdb 12maj-min 8:16 12vendor Samsung 12model SSD 850 EVO 250GB 12family based SSDs
    12size 232.89 GiB 12block-size 12physical 512 B 12logical 512 B 12sata 3.1 12speed 6.0 Gb/s 12type SSD
    12serial <filter> 12rev 2B6Q 12temp 34 C
  12SMART yes 12state enabled 12health PASSED 12on 2y 271d 19h 12cycles 3167 12written 52.4 TiB
  12ID-4 /dev/sdc 12maj-min 8:32 12type USB 12vendor SanDisk 12model Cruzer Spark 12size 29.25 GiB

    12block-size 12physical 512 B 12logical 512 B 12type N/A 12serial <filter> 12rev 1.00
  12SMART Message Unknown USB bridge. Flash drive/Unsupported enclosure?
  12ID-1 / 12raw-size 29.3 GiB 12size 28.67 GiB (97.86%) 12used 19.3 GiB (67.3%) 12fs ext4 12block-size 4096 B
    12dev /dev/nvme0n1p3 12maj-min 259:3
  12ID-2 /boot/efi 12raw-size 199 MiB 12size 198.2 MiB (99.60%) 12used 45.6 MiB (23.0%) 12fs vfat
    12block-size 512 B 12dev /dev/sdb1 12maj-min 8:17
  12ID-3 /home 12raw-size 421.88 GiB 12size 414.17 GiB (98.17%) 12used 201.53 GiB (48.7%) 12fs ext4
    12block-size 4096 B 12dev /dev/nvme0n1p5 12maj-min 259:5
  12Alert No swap data was found.

  12System Temperatures 12cpu 58.9 C 12mobo N/A
  12Fan Speeds (RPM) N/A
  12Processes 355 12Uptime 6m 12wakeups 1 12Memory 31.36 GiB 12used 3.98 GiB (12.7%) 12Init systemd 12v 250
  12tool systemctl 12Compilers 12gcc 11.1.0 12Packages 12pacman 1327 12lib 383 12flatpak 0
  12Client Unknown Client: systemd 12inxi 3.3.11

you boot on USB iso manjaro
open a terminal

sudo manjaro-chroot -a
pacman -Syy
mhwd-kernel -i linux510 
mhwd -a pci nonfree 0300

Hey sorry for the delay I haven’t come around to it until last night, I ran those commands and it didn’t seem to work, I also attempted to remove linux515 and ran only linux510 but no change. I also removed linux open source drivers and installed Nvidia’s drivers from their site running the .run file and nothing worked. I also tried adding nouveau module to /etc/mkinitcpio.conf to see if adding nouveau would make nvidia boot up with the computer and nothing no change I really don’t know whats wrong.

Guessing and trying will not help !

Providing the error messages is essential in getting help :wink: