Next Update for 2023

I recently came to Manjaro because it just works. I’ve tried it before and it was great. It works great on my wife’s computer. But not on mine. I’ve done a little reading; it’s a desktop bug that causes long delays opening programs. And it causes disk access problems with MailSpring. But otherwise, I can get stuff done.

A terminal fix was provided (can’t remember where), and I tried it as best I could, but it didn’t work. Nothing changed. I don’t speak Linux very well, and have already spent too much time trying to figure it out.

So, I’ll limp along until the next update. What are the chances that that will fix it?

If you are interested (and help will be appreciated), here’s my system: (But don’t expect meaningful conversation about it with me!)

  Kernel: 6.1.41-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1 Desktop: Cinnamon v: 5.8.4
    tk: GTK v: 3.24.38 dm: LightDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 7050 v: N/A serial: <superuser required> Chassis:
    type: 3 serial: <superuser required>
  Mobo: Dell model: 0NW6H5 v: A00 serial: <superuser required> UEFI: Dell v: 1.25.0
    date: 04/05/2023
  Info: quad core model: Intel Core i7-7700 bits: 64 type: MT MCP arch: Kaby Lake rev: 9 cache:
    L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 988 high: 1000 min/max: 800/4200 cores: 1: 1000 2: 1000 3: 1000 4: 1000
    5: 1000 6: 1000 7: 904 8: 1000 bogomips: 57616
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel arch: Gen-9.5 ports:
    active: HDMI-A-1,HDMI-A-3 empty: DP-1, DP-2, DP-3, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5912
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3360x1050 s-dpi: 96
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,left model: Samsung SyncMaster res: 1680x1050
    dpi: 99 diag: 511mm (20.1")
  Monitor-2: HDMI-A-3 mapped: HDMI-3 pos: right model: Samsung SyncMaster res: 1680x1050 dpi: 99
    diag: 511mm (20.1")
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 200 Series PCH HD Audio vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:a2f0
  API: ALSA v: k6.1.41-1-MANJARO status: kernel-api with: aoss type: oss-emulator
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 0.3.75 status: off
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa type: plugin
  Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
    chip-ID: 8086:15e3
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Ralink RT5370 Wireless Adapter driver: rt2800usb type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 bus-ID: 1-10:6 chip-ID: 148f:5370
  IF: wlp0s20f0u10 state: up mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb v: 0.8 type: USB
    rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-4:3 chip-ID: 0a12:0001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 bus-ID: 00:17.0
    chip-ID: 8086:2822
  Local Storage: total: 968.52 GiB used: 119.17 GiB (12.3%)
  ID-1: /dev/sda vendor: Kingfast model: N/A size: 953.87 GiB speed: 6.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: Generic model: Flash Disk size: 14.65 GiB type: USB rev: 2.0
    spd: 480 Mb/s lanes: 1 serial: <filter>
  ID-1: / size: 493.19 GiB used: 118.07 GiB (23.9%) fs: ext4 dev: /dev/sda5
  ID-2: /boot/efi size: 96 MiB used: 43.3 MiB (45.1%) fs: vfat dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Packages: 1270 pm: pacman pkgs: 1260 pm: snap pkgs: 10
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https: //$repo/$arch
    2: https: //$repo/$arch
    3: https: //$repo/$arch
    4: https: //$repo/$arch
    5: https: //$repo/$arch
    6: https: //$repo/$arch
    7: https: //$repo/$arch
    8: https: //$repo/$arch
  Processes: 291 Uptime: 2d 1h 12m Memory: total: 32 GiB available: 31.22 GiB
  used: 6.48 GiB (20.8%) Init: systemd v: 253 default: graphical Compilers: gcc: 13.1.1
  clang: 15.0.7 Client: Cinnamon v: 5.8.4 inxi: 3.3.28

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

That sounds like you are having installed


On a desktop that is not gnome. Uninstall and install



sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -Syu xdg-desktop-portal-gtk

What didnt work? Were there errors?

Of course … the suggestion is just a guess - assuming that you do have portal-gnome installed and that it is the cause of the problems.



Clearly, I don’t know what I’m doing. The terminal fix did not specifically name the Cinnamon desktop, so I guessed. And apparently guessed wrong because your fix worked.

My one complaint about Manjaro is that the forum assumes that users know more than I know about using Linux. Clearer instructions for complete dummies would be appreciated. Maybe there should be a complete dummy section for the forum.


The forum is made so, that “dummies” are allowed to ask questions. And the “dummies” of last year do answer them :wink:

(Wisdom lies in asking → listening → reading :wink: )


I uninstalled xdg-desktop-portal-gnome and all problems were solved.

xdg-desktop-portal-gnome should only get installed if you use the Gnome Desktop Environment. All others you should uninstall it. It is a simple issue with the alphabetical order and pre-seleciton. Happens if you hit enter without selection on your side.xdg-desktop-portal-gnome 44 causes delays in non-GNOME desktops (#74) · Issues · GNOME / xdg-desktop-portal-gnome · GitLab

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.