Resume from suspend fails and errors out, leaving me at a logging console

Here’s an image of the errors I’m getting, honestly not sure why it’s doing this, I’m using kernal 5.15, I can switch sessions with ctrl + alt+f1-12, but it’s just a blank console, with no actual terminal, and REISUB works. the ssd is brand new, so I don’t really think there are actual issues with it.

Edit: Here’s my system Information

Please provide Information:

How to increase your chances of solving your issue:

I updated the post to include system info, haven’t included any logs yet though cause that’s going to be difficult to do as I’ll need to live boot and find the appropriate logs, and I’m not sure what those are yet

This post makes me think you need to update the firmware in that SSD. Updating the SSD firmware is discussed in Arch Wiki here, but unfortunately there is no mention of your SSD vendor Silicon Power.

A quick web search reveals there is a firmware update for the SSD available on Silicon Power’s website, but it looks like they only offer a Windows version. :face_with_diagonal_mouth:

according to fwupdmgr get-updates there are no available firmware updates, but then again maybe it just doesn’t support the devices I have

Firmware metadata has not been updated for 30 days and may not be up to date.

Update now? (Requires internet connection) [y|N]: y
Updating lvfs
Downloading…             [***************************************]
Downloading…             [***************************************]
Downloading…             [***************************************]
Downloading…             [***************************************]
Downloading…             [***************************************]
Successfully downloaded new metadata: 0 local devices supported
Devices with no available firmware updates: 
 • DT01ACA100
 • System Firmware
 • UEFI Device Firmware
 • UEFI Device Firmware
No updatable devices

Update: same thing seems to happen in arch too, so i’m guessing it’s not the kernel version, since i think arch uses later kernels

Out of curiosity, what if you tried with Arch Linux using kernel 5.17-rc7? (You’ll have to manually download and install the package, since it’s not available with the default repositories.)

EDIT: Or rather, 5.15.28 (which you can grab from a testing repository if the mirror has it.)

@trinsdar [SOLVED] Suspend broken after recent update (Page 2) / Laptop Issues / Arch Linux Forums

@winnie It is available in the unstable branch. Packages

Even better. Good to know. Must have been recently added. :+1:

EDIT: Is there a way within pacman / Pamac to only install a specific package from a specific branch? (In this case 5.17-rc7, since you don’t want -rc5)

Or a direct link to the compressed package file?

Yes but don’t do this specially in the case of linux…the kernel. Most packages are built against particular library versions so packages in the Unstable and Testing will require library version from these branches. Installing packages like this will leave in a state of partial update which is not supported. See System Maintenance - Manjaro

But for "scientific purposes only :wink: " here’s how you do it…on your own risk…on your own risk…on your own risk:

sudo pacman-mirrors --api --set-branch {branch} #change branch
sudo pacman-mirrors --fasttrack 5 #update mirrorlist 
sudo pacman -Syyu #do a full system upgrade
sudo pacman -S <package_name> #install that package

Now you can change back to the original branch and ignore future messages on installed packages newer than repo.

Couldn’t find that. You can compile it from source → Packages / Core / linux517 · GitLab

“Scientifically” it would make for an interesting test. :wink:

UPDATE: Typing this from a cafe shop WiFi connection. House burned down. Too much science. :frowning_face:

Yes…only if you want to reinstall manjaro after the experiment :stuck_out_tongue:

so update: just to test, I instaled a debian based system alonglside manjaro and arch to see if it was related to arch at all, but still got the errors, however I was able to get this error out of it by doing so:

Aborting journal on device nvme0n1p4-0
Buffer I/O error on dev nvme0n1p4, logical block 54558720, lost sync page write
JBD2: Error -5 detected when updating journal superblock for nvme0n1p4-0

so update: updating to that kernel has changed nothing, it still errors out when resuming