Unable to boot or use chroot

ok i see from sdc :
1 1049kB 9437kB 8389kB this is a bios-grub (8Mo) partition

==> reboot on USB MBR ( active CSM only)
==> put on sdc1 flag bios-grub ( boot & esp will be removed from 4 , as you cant get full UEFI and disks )
with Gparted & flag options
==> recheck return

sudo manjaro-chroot -a
grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdc
exit ( end-chroot)

Thanks, the

sudo manjaro-chroot -a

still doesn’t work for me, so nor does the second line.

grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdc

Thanks Stephane. This is all over my head. I am going to scrub everything and start over. I will not have a backup OS since installing more than one often makes problems happen (this is not the first time). At least this way I will have a free 500 GB disk since I’ll put my main OS on the smaller 240 GB disk which is more than enough for an OS and some timeshift images which is all there will be on it.

Thanks for trying but it will take much less time to start over than it has done thus far with no progress.

All best.

just if you look carefully from start
sda was in MBR ,
sdc was in GPT with bios-grub , meaning that boot full UFI was difficult ( or something else … )

==> on this point if a boot UEFI is possible , install FULL EFI on sda is possible
==> then recheck carefully sudo gparted -l in case of UEFI
==> do not install on sdc ( nothing ) to keep your data safe

i dont know why sdc4 is a partition with flag boot& ESP , and if there in /etc/fstab

1 Like

I can open up and see the fstab:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /              btrfs   subvol=/@,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 1
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /home          btrfs   subvol=/@home,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /var/cache     btrfs   subvol=/@cache,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
UUID=9b57e27f-245c-4e84-9779-7d0cbe578626 /var/log       btrfs   subvol=/@log,defaults,noatime,space_cache,ssd,compress=zstd,commit=120 0 2
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=ec4a266c-f6e1-497c-91ab-af62b4230b7a /run/media/baron/2TBData ext4 defaults,noatime 0 2

My programmer son will try to log in remotely tomorrow and dig in there.
I now have a new system on the smaller HD which is working but I’ve spent over an hour trying to install the printer and have had to give up. The printer is installed and it sends the job etc. but it doesn’t print. It’s the main thing I use the computer for: writing and printing. Last time I installed it was a snap. Th time before it took days. This time it’s a nightmare again. THAT’s why I try to back up OS’s so as not to go through all this. Oh well…

Hi and welcome to the Forum :+1:

I skipped reading your post due to formatting which makes me dizzy…

Help others to help you better by:

  1. Providing system info about your hardware by posting program output instead of describing your hardware.
  2. Use new lines when a sentence ends, so it is better readable and followable by others.
  3. If english is not your native language please see:
    • :us: :uk: English [HowTo] Become multi-language on internet
    • :tr: Türkçe [Nasıl] İnternette çok dilli olun
    • :de: Deutsch [Wie man] Werden Sie im Internet mehrsprachig
    • :fr: Français [Comment] Devenir multilingue sur internet
    • :es: Española [Cómo] Conviértete en multilenguaje en Internet
    • :cn: 中文 [如何] 成为互联网上的多语言
    • :it: Italiana [Come] Diventa multilingua su internet
    • :ru: русский язык [Как] Стать многоязычным в Интернете

Please read and follow all advice in this thread:


If you often have a need to do a “Hard reset” or “Power off” to get back to your system, then avoid that when possible by following:


Thank you Trimoon. I see that in one of my posts I messed up the formatting somehow. Apologies.

1 Like

It would be nice to alse edit all your posts with wrong formatting to fix them :wink:

Oh! I wasn’t aware they were all wrong formatted. Have been using

this method . Is this wrong?

I read somewhere that manjaro-chroot doesn’t work with btrfs partitions. I spent 3 hours with my graduate degree computer programmer son in Deutschland yesterday and he couldn’t rescue the OS either. It’s all just sitting there but we cannot create a way of booting into it. He will try again one more time then I’ll scrub. Meanwhile have installed new Manjaro and it sort of works but
a) I can’t get my other HD’s to boot up automatically though they did in System 1
b) most frustratingly, cannot print, which is crucial. Have spend hours on it, no joy.
c) I installed Fedora scion nobara (?) and it found the printer immediately but then on rebooting it too could not reboot and corrupted the new Manjaro as well. I find installation a major headache (obviously!). Once things are running, it’s great, but getting them running is ridiculously difficult. That’s why I want that old OS back with everything running well. But it won’t let me in. I need an old-fashioned repair disk. Timeshift only works when you don’t really need it!


Maybe Linux is not yet the right OS for you. It’s not a shame to use something simpler for the moment.

Thanks for the suggestion. Haven’t used any other OS for over 10 years, but still totally confounded by installation booting issues when they occur. So was my graduate degree professional programmer son stumped - but he uses Debian and never has such issues!

I was here a few days ago after messing up my system by installing a backup OS on a smaller 240 GB SSD drive (on my Lenovo W530 laptop). After installing the new OS on the SSD drive and rebooting, I could no longer boot up into the original main system on a larger 500 GB HDD. The boot menu would appear, but - except one time - none of the options (normal boot, picking one of the images or fallback images etc.) would work and I would be shunted into Emergency mode where I lacked the skills to do anything. I created a topic here but nothing worked.

Then my professional programmer son - who works for Ford and sometimes Mercedes running small programming teams in Deutschland - tried to help for a few hours but got nowhere either. We gave up and I abandoned the old OS on the 500 GB drive and moved to a new installation of Manjaro on the 240 GB SSD drive and after dicking around for a few hours, everything works - printer, bluetooth, extensions, etc.

This morning I decided to scrub the 500 GB drive and turn it into a place to store backup images created by dd. My son recommended it. He’s run the same Debian server system since 2014 and the same Debian OS on his laptop since 2018 without problems. He’s much younger than I (obviously) but old school with systems and says he likes 1970’s style bullet-proof approaches. (He also doesn’t know much about dicking around with booting issues like this!)

But then I thought: why not see if I can do a grub repair from the Emergency console? He played around in there in ways I didn’t know could be done. So I removed the small SSD drive to be safe, booted up and… no emergency console appears. Nothing. Just a blinking cursor.

So I booted into F1 BIOS to check the startup menu. Everything normal.

So I tried to boot up a livecd flash drive. Couldn’t do it even though usually works every time. Back into BIOS. There they are, the flash drives, above the hard drives.

So then I hit F12 to manually select what to boot into and I could see the flash drive for the livecd system and also the Samsung 500 GB OS drive. I selected the latter just to see and … guess what… the OS booted up, just like normal except with a twist:

the menu it showed was the old menu from before I deleted the Debian backup OS and installed a Manjaro OS instead. It still shows the Debian option. In any case, I can boot into my old system.

But because this is a btrfs system, I cannot figure out how to repair the boot-up situation so that it works normally. The only way I can boot into this OS now is by hitting Enter during the boot-up, going into BIOS options and hitting F12 to do it manually.

So it seems to me that something is happening very early on in the boot–up process that is preventing it from accessing the usual grub menus or whatever. This part of computing is very arcane to me.

In any case, if I can keep this OS and get it to operate normally, I would like to very much. Manjaro Gnome installed 2-3 years ago and running nicely until this incident when I was just trying to install a backup OS on a different drive just to be safe. (Ugh!) I think my problem was I selected a different boot option in the installation on the SSD instead of telling it to use the existing boot partition on the main HDD 500 GB drive with the main system. Things got confused.

But right now I have removed the SSD drive with its own boot-up partition which works great and only have the 500 GB HDD with the original main system. But can only boot up using the manual F12 option.

Can some kind soul help us to find out
a) what is going on so there is some learning/understanding
b) how to get this beast running normally again and later
c) how to configure a laptop with two drives and two separate OS’s properly so this sort of thing never happens again, including how to re-jigger the SSD system so that it no longer boots up onto that drive but piggy-backs onto this system’s boot-up partition and menu etc.

I know this was long, but I am trying to be clear. I won’t print out stuff until someone who is willing to help asks for it. I’ve been using computers since the 80’s but am not good at technical issues. I moved to Linux because I don’t like Windows culture and surveillance etc. but am not a ‘power user’ type, so apologies. I can follow instructions though.

Thanks in advance.

PS My son also mentioned that he has hardly ever touched btrfs systems and recommended I drop back to ext 4 because then all this stuff would have been much easier to figure out and fix. I wonder if anyone has any thoughts on that. I would do it except now that I have the original btrfs system up and running again, I hate to delete it and start over!

PPS When using the F12 option, there is no Manjaro-generated bootup menu with options. It just goes straight to the Manjaro welcome with the three little dots gif and then goes to the screen asking for PW to log in.

I found and ran grub-btrfs and it made many images, but the boot-up process remained as above.

Please provide the output of:

sudo parted -l

Please as code (like i did), so as “preformatted text”.

It is very likely that the bootorder is wrong.

It is intentional, that there is no boot menu, if there is no second OS and the boot log is hidden. You can “unhide” the grub menu by typing ESC at boot time.

    ~  efibootmgr                                                       ✔ 
EFI variables are not supported on this system.
    ~  sudo parted -l                                                 2 ✘ 
[sudo] password for baron: 
Model: ATA ST2000LM015-2E81 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name     Flags
 1      1049kB  1064GB  1064GB  ext4         2TBData
 2      1064GB  2000GB  936GB   ext4         STBBU1

Model: ATA SAMSUNG MZMTE512 (scsi)
Disk /dev/sdb: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  9437kB  8389kB
 4      9437kB  316MB   306MB   fat32                 boot, esp
 2      316MB   8704MB  8389MB  linux-swap(v1)        swap
 3      8704MB  512GB   503GB   btrfs

Thank you. Hopefully have formatted this reply correctly.

1 Like

Ok your Manjaro System is installed in BIOS/Legacy mode, although there is an EFI partition, what makes me thinking that you installed Manjaro in UEFI mode and afterward replaced it grub in legacy/bios mode:

And that must be the 8MB non-formatted partition, where grub writes the “MBR” on the GPT Partition Scheme:

  1. Is there a specific reason to use legacy mode when UEFI mode is available? The UEFI mode much more flexible, especially when having more than one OS.

  2. I can now imagine what happens here. You installed Debian on the second drive (240GB) and the boot prioirty got the this drive then after installation. Problem though is that Debians grub is not compatible with Manjaro/Arch Grub. While Arch/Manjaro follow upstream, Debian does not exactly. Maybe read this: [ SOLVED ] can't boot Manjaro from mint - Linux Mint Forums It is about the microcode for the CPU. While debian has it integrated into the kernel image, Arch/Manjaro has it separated, thus the boot parameter is different. Manjaro can boot debian, but debian cannot boot Manjaro (I mean the grub of each Distro). It can be adjusted, but needs manual edit.

  3. About typing F12 each time: You need to set Manjaro first in the UEFI Settings. If it is the BIOS mode, then it must be the drive name. If you think, you see debian’s grub, then I can only think that debian was installed in EFI mode and most likely reused /dev/sdb4. Probably there is something located?

Thank you for your reply.
A year or more ago, first I installed Manjaro on the 500 GB drive with a disk erase and selecting the Btrfs option.
Later, I installed Debian as a backup system for emergencies on the smaller 240GB SSD drive. After which there was both Manjaro and Debian on the grub menu and they both worked.
A week ago I opened up the Debian for the first time in about a year (because the default Manjaro OS has been working fine without issues). The Debian did a fairly big (for Debian) update but it couldn’t go through because of a size limitation on a var partition. (I think I had that SSD set up for btrfs installation and Debian just took what was offered and installed on top. Really can’t remember.) So rather than fuss with the Debian I thought: why not just put another Manjaro in there for emergency use and to hell with this Debian? I then installed Manjaro over the Debian selecting the Erase and Replace option. But then I made the mistake (I assume) by selecting to have it boot up on the SSD instead of the 500 GB drive. So after installation I could boot into the new system but not the old system.

I suspect that the Legacy mode happened with my son who tried to rewrite grub a few times and is not familiar with btrfs. I can disable legacy mode in the BIOS, no? Maybe I should do that.

I used to see Manjaro in the boot list in BIOS but didn’t realize it was part of btrfs stuff. And so removed it each time since I couldn’t boot up into anything else when it was there. I do not know how to put it there myself, perhaps it happens only when I boot up into an EFI situation which apparently I no longer have on this 500 GB drive.

I still can no longer boot into a livecd flashdrive unless doing the F12 business.

Is there a way to set up this current 500GB system to boot up properly in EFI mode either from within this system (now running) or via livecd?

Also, can I get the machine to boot up flash drives like it used to? (Have no idea how or why that has changed).

If I can rescue this 500 GB main OS (Manjaro Gnome) and if it makes life easier, I can happily delete the 2nd Manjaro on the second 240 GB drive (now removed from the laptop). OR: if it is impossible to get this current system booting up properly - though presumably it can be done along with getting the machine to boot up normally - then I can scrub this lovely system and use the drive for dd and timeshift backups and just have the one system running on the 240GB SSD in ext4 format, ditching the btrfs as too advanced somehow.

PS. I went to your Mint page and noticed an item there about grub.cfg file. So went to it and found I have two files altered at 09. 13 this morning.

Now I have two files in the boot/grub directory:
both made at 09.12 am today

It seems these two files were made when I ran the grub-btrfs command. I just re-ran “pacman -S grub-btrfs” and it remade those two files again - along with going through various routines for each kernel taking several minutes.

Maybe this has nothing to do with why you say I have legacy BIOS grub. Anyway…

PPS I disabled Legacy in the BIOS and then the 500 GB OS cannot be accessed. On re-enabling it boots up fine. But for either OS and/or a livecd flashdrive I still have to use the F12 option to boot up.

I put the 240 GB SSD drive back in and that one can boot up normally on a restart, but anything else requires F12, be it a flash drive or the 500 GB Manjaro. I reset the BIOS to defaults but still the flash drive doesn’t automatically boot. I have never encountered this sort of thing before with the flash drives not loading except from the manual prompt after the F12 menu.

I will try to explain you a few more things and maybe in more details.

Example ( i had to edit this part)
You have two drive and make partitions on it.
One disk is structured to MBR (msdos), the other to GPT.
MBR (Master boot record) has a different structure as GPT (GUID Partition table),
thats the part, where your hard drives are structured into parts.
GPT did come later, because it supports a partion greater then 2TB, what is the limit for MBR

Just not sure here, if you have to change also at the Bios settings to boot from legacy to UEFI, when you want to boot from the GPT disk, because legacy does not support GPT.
Basically, when you will boot your GPT disk ATA ST or ATA Samsung, which you have at a GPT partition table, you need to set also UEFI at the bios.
At your ATA CT drive, it may works with UEFI, if not, you need to switch back to legacy boot in Bios.


Next thing is your boot priority.
You can set up at your Bios the boot priority (del or F2 during boot), at which Harddisk should be looked for a OperationSystem or a boot loader. If you have multiple drives, you should have them all listed there, even USB.
You have to set there the right drive, where you want to boot from, like ATA Samsung or ATA ST2000 first.
With the F12 key, you have a quick boot menu, where you can temporary manually choose the drive, where you want to boot from. But this is only temporary, because your Laptop will load by standard your Bios settings, what you can save and need to adjust to your prefered Harddisk.

So, if you want have 2 or more systems, you may want to install grub into the drive, where you install your OS on it.
But remember, even, when you make at one Harddrive 2 partitions, you can only install 1 bootloader on that disk. And as we have learned, you can also not mix grub from Mint or from Manjaro, because they are different.
Grub ie will autodetect and reconfigure the list from your bootable systems with every grub-update what you manually do or the system does during an update, even when you have 2 Systems on the same disk in 2 Partitions.
Disk1 (sda)

  • Partition1 (sda1 100GB Manjaro
  • Partition2 (sda2 100GB Debian
    Grub will be installed at /dev/sda and will show you Manjaro and Debian to boot.

When you have 2 Disks, you could install a bootloader at each disk, but then you need to change the boot priority at the Bios from driveA to driveB, that it loads the second grub installation.
Disk1 sda - Partition1 200GB Manjaro
Disk2 sdb - Partition1 500GB Debian
Grub can be installed once at sda or sdb, Bios settings needs to point either to driveA or driveB.
When grub works proper, it would show both times both systems to boot at the menu.

I am not sure at this point, if it would work, when you ie install a grub from Manjaro system into
ie /dev/sda, have Manjaro sys on /dev/sda1, got ie Nobara at /dev/sda2, and install Nobara grub into /dev/sda2, grub-update at sda with the Manjaro system, that it finds both.
But usually, if there is a system, it should not need such a ‘hidden grub’.

So seems you did only overwrite your manjaro grub with Nobara grub.
Fedora itself is some different from Arch or Debian and not really compatible. And not sure, how well her grub works.
But you also could skip a grub installation, and grup-update from an other system.

At this point, if you destroy your boot up, chroot becomes handy. You can log into the system you want, gain the rights to make installations like install your boot loader new.

For your system, its save, when you make a seperate partition or hard drive as your /home drive.
There you have all your personal datas, and the system gets installed at different partitions.
You only need to bind it manually to a new system during the installation process.
Then you can try what you want at the other partitions, but your personal datas are more save.

For F12, i use it only for quick boot up tests, to see, what bootloader is installed.
That way you can easy rotate through, what is installed at drives.
And mainly, when i install a new system, i usually always pick a second disk, where i can disconnet others, when i assume, something can be messed up

So, basically, you should now sort your boot order, install grub again on that priority1 drive, bind the home into your system, if an old one exists, and if you want install an other system, remember the letter from the new drive and install the bootloader from the new system on the same drive as the installation.
fdisk -l and lsblk gives you an easy overview all time, what letter is assinged to a drive or what partitions exist there.

If you figure out how to dd your harddrives back to you previous status, you only need to install the proper grub into your booting disk and, if debian would mess it up again, chroot into manjaro and grup-update /dev/sda.

I dont know too, if some systems has the routines during an update, that they auto-install grub into the first harddisk. I guess i had once the situation, and as i did try to update an second system, i did first change the boot priority to this system, like the Debian drive, because the routine seems did plainly grup-update /dev/sda, no matter where the Debian installation was.

Thank you. Will take some time to absorb!
But am getting the feeling that I won’t be able to resolve this the way things are and most likely will have to re-install.
OR: can continue with going to BIOS if I want to use a 2nd system on a different drive. Easy enough. If the main system works well this way - it created a grub menu some time this morning which seems fine - and the system is stable, I’ll just stick with it.
I still don’t know why I can’t boot into a flash drive, but since I only do it once every year or so, having to use the F12 option is hardly a hardship. My only concern is that something is wrong somewhere and it will cause worse problems later. Time will tell.
Thanks again.