I tried to boot from an old usb stick, now cannot boot Manjaro from my main HD

Hi there! I am sorry but I am stuck.
I have a dual boot old machine with windows 8 and Manjaro (openbox). All was working perfectly until I wanted to boot an old edition of manjaro I had on an old usb stick. I modified the bios settings to boot from the usb stick. It was not able to boot since the usb stick was encripted. When I wanted to revert to my dual-boot installation, loading from my main HD, it won’t boot anymore. I can see two partitions to boot (on the BIOS): windows and Manjaro. Windows is ok, Manjaro gives a black screen (it won’t load grub). I usually dual booted with grub.
This is my partition scheme:

[manjaro@manjaro Desktop]$ sudo fdisk -l /dev/sda
Disk /dev/sda: 447,13 GiB, 480103981056 bytes, 937703088 sectors
Disk model: Intenso SSD Sata
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6DA1C675-CD49-45AF-AF51-ADE13611139F

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    616447    614400   300M Windows recovery environment
/dev/sda2     616448    821247    204800   100M EFI System
/dev/sda3     821248   1083391    262144   128M Microsoft reserved
/dev/sda4    1083392 442370047 441286656 210,4G Microsoft basic data
/dev/sda5  899813376 937703054  37889679  18,1G Linux swap
/dev/sda6  442370048 899074047 456704000 217,8G Linux filesystem
/dev/sda7  899074048 899813375    739328   361M Microsoft basic data

Partition table entries are not in disk order.

this is my system:

[manjaro@manjaro Desktop]$ sudo inxi -b
  Host: manjaro Kernel: 5.15.55-1-MANJARO arch: x86_64 bits: 64 Desktop: Xfce
    v: 4.16.0 Distro: Manjaro Linux
  Type: Laptop System: SAMSUNG product: 350V5C/351V5C/3540VC/3440VC
    v: P09ABE.012.CP serial: HXYC98FD3B15XK
  Mobo: SAMSUNG model: NP350V5C-S09IT v: BOARD REVISION 00
    serial: 123490EN400015 UEFI: American Megatrends v: P09ABE date: 07/04/2013
  ID-1: BAT1 charge: 7.3 Wh (100.0%) condition: 7.3/47.5 Wh (15.5%)
  Info: quad core Intel Core i7-3630QM [MT MCP] speed (MHz): avg: 1344
    min/max: 1200/3400
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: AMD Thames [Radeon HD 7500M/7600M Series] driver: radeon
    v: kernel
  Device-3: Silicon Motion WebCam SC-13HDL11939N type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X:
    loaded: modesetting,radeon gpu: i915 resolution: 1366x768~60Hz
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k
  Local Storage: total: 461.98 GiB used: 0 KiB (0.0%)
  Processes: 261 Uptime: 30m Memory: 15.52 GiB used: 2.23 GiB (14.4%)
  Shell: Bash inxi: 3.3.19

Thanks for your help!

so modify the bios settings again to the previous working one

Try looking for errors.

Hi Brahma, i did revert the bios to the initial settings, but it won’t load grub and stays in a black screen. If I remember well I installed grub on a separate partition.

Also, when I booted straight to windows, there was a scary screen saying that windows was repairing the installation… probably windows messed up the partitions?

Thank you Maycne, how can I look for errors?

The link was actually provided inside the previous guide…

so you were shown the grub menu before this issue?
and what exact bios setting did you modify?

Hi Brahma, thank you!
Yes, before the accident, I used Grub to boot Manjaro and Windows 8. I don’t remember where grub was installed (maybe in /dev/sda2, which says EFI System, or in /dev/sda6 Linux filesystem). Please see my first post with the output of fdisk -l and inxi if they can give some more info.
In BIOS I modified the boot order, in order to have the system boot from the USB drive. Trying many times, I probably turned on and of also the SECURE BOOT, and eventually booted Windows 8, which gave a screen indicating it was “repairing” the installation.
Any suggestion will be very appreciated! Thank you!

so is secure boot disabled now? …
is fastboot disabled in windows?
and you changed the boot order, thats probably the issue … select to boot manjaro as first in boot options in bios
do you have some grub error during booting like grub not found, or grub error … any kind of message during booting?

Hej elia,
In the image you oosted here there is one option called “Manjaro (P0: Intenso…).” and one option “P0: Intenso…”
Did you try both of them?

Hi Erim, thank you so much! Yes, I tried both partitions, “Manjaro (P0: Intenso)” and “P0: intenso”. The stay in a black screen, with fans running. No hint of the grub.
If I put “Windows boot manager”, it works, i.e. it boots into Windows, with no GRUB and no option to boot linux.

Hi Brahma, thank you very much!
Yes, secure boot is disabled. Fast boot in windows is disabled as well. I tried to boot Manjaro as first option in bios: it won’t boot. No messages on the screen: black screen and fans running.

maybe the windows repairing that you mentioned somehow corrupted grub … so prepare manjaro usb, boot into manjaro installation again, then boot into the usb, connect to internet, chroot:
sudo manjaro-chroot -a
check logs from the failed boot:
journalctl -b-1 -p4 --no-pager

then reinstall grub:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
mkinitcpio -P

reboot and try booting into manjaro

1 Like

Eventually Windows decides to reinstall the bootloader (by repairing it)… and since Windows and Manjaro share one EFI Partition:

Windows must have corrupt the Manjaro EFI Bootloader…

So I guess you need to reinstall grub: GRUB/Restore the GRUB Bootloader - Manjaro

:notebook: However… it would be not bad to have another 100MB EFI Partition just for Manjaro.

The screen shows your boot order:

  • CD boots first, if no cd in drive it’ll boot to next option:
  • win boot manager, since there IS a win it won’t boot the next option:
  • manjaro

Move manjaro to the top (for info: grub, like the win bootloader, is installed on efi partition sda2) and try if you can boot. If that works you can leave it like that or put CD back on top if you use your cd drive for booting iso:

  • CD
  • manjaro
  • win

Thank you all for your suggestions. I was not able to solve the issue, but found a strange workaround, which is far from optimal.
If I press F10 immediately after turning on the laptop, I have a BIOS window and I select Manjaro P0 intenso partition, I then boot straight to the GRUB, and everything works fine.

If I program the BIOS to boot from the Manjaro P0 Intenso partition, it does not boot and stays on a black screen. This happens even if I try to boot from a USB stick: if I program the BIOS to boot from the USB stick, save settings and exit, when booting it stays on a black screen. If I select the usb pendrive pressing F10 when I switch on the laptop, I am able to boot.

This is very strange! Possibly some error on the BIOS?
Here are my bios settings, I really don’t know what to edit!

once booted into Linux
you should probably reinstall Grub.

The Windows automatic repair process very likely wiped it out and installed it’s own bootloader, that’s why you can only properly boot into Windows.

1 Like

Can you check other available options of:
AHCI Mode Control [Auto]
This should be ‘Enabled’ or ‘AHCI’.

Yes, I enabled it explicitly, but no luck! :frowning:

Hi Nachlese, thanks! Yes, I will try it.
Do you recommend reinstalling grub even knowing that I was not able to boot to a working USB stick with Manjaro via BIOS (only after pressing F10 at startup and directly selecting the USB stick)?
I booted into Linux (by pressing F10 and selecting the working partition - which gave me GRUB), and updated the system. I saw it updated also GRUB, do you think I should manually reinstall it? If yes, which tutorial do you recommend me to use?
Maybe something zapped or corrupted part of my bios and I need to update it as well?