Desktop display totally broken


I have a problem with my system. I haven’t done anything special but since yesterday after booting and login my desktop looks crazy. Some links on the desktop are not visible, text appears as cryptic characters and apps don’t start.

Here is a screenshot of my left side of the display:

  Kernel: 5.10.167-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=b160fc10-88da-4fdb-a916-93ba7328a1f7 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Hewlett-Packard product: HP EliteDesk 800 G1 TWR v: N/A
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Hewlett-Packard model: 18E4 serial: <superuser required>
    UEFI: Hewlett-Packard v: L01 v02.71 date: 05/09/2017
  Message: No system battery data found. Is one present?
  RAM: total: 31.25 GiB used: 3.44 GiB (11.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-4770 bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2647 high: 3171 min/max: 800/3900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1465 2: 2078 3: 2893
    4: 2894 5: 3171 6: 2894 7: 2894 8: 2890 bogomips: 54293
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht ibpb ibrs
    ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs
    pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sdbg sep smep
    smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc
    tsc_adjust tsc_deadline_timer vme x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
    vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-7.5
    process: Intel 22nm built: 2013 ports: active: none empty: DP-1, DP-2,
    HDMI-A-1, HDMI-A-2, VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0380
  Device-2: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: ASUSTeK driver: nvidia
    v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:2182
    class-ID: 0300
  Device-3: Microdia Dual Mode Camera (8006 VGA) type: USB
    driver: hid-generic,usbhid bus-ID: 3-12:4 chip-ID: 0c45:8006 class-ID: 0301
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: nvidia gpu: i915,nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 93 s-size: 524x331mm (20.63x13.03")
    s-diag: 620mm (24.4")
  Monitor-1: DVI-D-0 res: 1920x1200 hz: 60 dpi: 94
    size: 519x324mm (20.43x12.76") diag: 612mm (24.09") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce GTX 1660
    Ti/PCIe/SSE2 direct-render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20 class-ID: 0403
  Device-3: NVIDIA TU116 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
  Sound API: ALSA v: k5.10.167-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Ethernet I217-LM vendor: Hewlett-Packard driver: e1000e
    v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:153a class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.15 TiB used: 790.64 GiB (67.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 840 PRO Series
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 6B0Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: HD103SI
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: 1118 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Sony model: Sony
    size: 7.4 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 6.00 scheme: MBR
  Optical-1: /dev/sr0 vendor: hp model: CDDVDW SN-208FB rev: HJ10
    dev-links: cdrom
  Features: speed: 24 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 238.17 GiB size: 233.38 GiB (97.99%)
    used: 38.83 GiB (16.6%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: b160fc10-88da-4fdb-a916-93ba7328a1f7
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 3FB1-50D4
  ID-3: /home raw-size: 931.51 GiB size: 915.82 GiB (98.32%)
    used: 751.65 GiB (82.1%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A
    uuid: 7ddab5a1-bd10-45ad-8632-15ffce7f8d12
  ID-4: /run/media/janexx2/B909-4458 raw-size: 7.4 GiB
    size: 7.39 GiB (99.80%) used: 167.3 MiB (2.2%) fs: vfat dev: /dev/sdc1
    maj-min: 8:33 label: N/A uuid: B909-4458
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8008 class-ID: 0900
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 15 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-5:5 info: Sony Cyber-shot Mavica (msc) type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 2mA
    chip-ID: 054c:0010 class-ID: 08ff
  Device-2: 3-8:2 info: SHARKOON GmbH 2.4GHz Wireless rechargeable vertical
    mouse [More&Better] type: Mouse driver: hid-generic,usbhid interfaces: 1
    rev: 1.1 speed: 12 Mb/s power: 100mA chip-ID: 1ea7:0064 class-ID: 0301
  Device-3: 3-11:3 info: Pixart Imaging Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 093a:2510 class-ID: 0301
  Device-4: 3-12:4 info: Microdia Dual Mode Camera (8006 VGA)
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 0c45:8006 class-ID: 0301
  Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-7: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-8: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 30.0 C mobo: N/A gpu: nvidia temp: 32 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 24%
  Processes: 335 Uptime: 2h 20m wakeups: 0 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1495 libs: 432 tools: pamac,pikaur pm: flatpak
  pkgs: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.25

When I start applications with TT1 I got error messages like this:

“no DISPLAY environment variable specified” (Firefox)
“GHOST: failed to initialize display for back-ends: (‘WAYLAND’, ‘X11’)” (Blender)

What I’ve already tried:

  • reinstall xfce4
  • xfwm4 --replace
  • set xfce config folder to default

But that didn’t helped.

Maybe also helpful the output of /var/log/Xorg.0.log

I hope that anyone can help me here. :pray:


Hi @janexx, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

Try the following:

echo "DISPLAY=:0" | tee --append /etc/environment

Followed by rebooting and seeing if it worked.

I tried your suggestion @Mirdarthos but it didn’t solved it.
After the input line it said:
What dows that mean?

Thanks also for the welcome and the info how to post!


I don’t know. So what @Nachlese said is as good idea as any.

It shows just an empty line. The reboot before or after the prompt?

That was probably a misunderstanding, because you said:

You likey meant to say:
TTY1 (or another TTY)


won’t work in this case because a TTY is not a valid Xorg display.

Graphical applications won’t work on a TTY.

Reinstalling Xfce will do nothing - as that will not change any configuration files inside your $HOME directory.

How did you


It’s possible but the xfce settings daemon has to be stopped to do this.

killall xfsettingsd

Then you can replace the ~/.config/xfce4 folder with the defaults found in /etc/skel

Sorry I am no expert I just tried some suggestion from forums withoutn knowing exactly whether this makes sense :see_no_evil: . Here is what I tried exactly:

I logged in via login screen as usual and then changed to a TTY terminal. There I tried this:

sudo pacman -S xfce4
xfwm4 --replace
rm -rf ~/.config/xfce
cp -r /etc/skel/.config/xfce ~/.config

a Very dangerous thing to do. For example: I’m not even an Xfce user, but this: :point_down:

Makes no sense for what you’re trying to do. And this: :point_down:

Didn’t do harm, no, but it could have. Since that command recursively deletes items without confirming it before done. It could have been much worse.

As it is, I think you might have missed a / at the end there:

cp -r /etc/skel/.config/xfce ~/.config/

And I also think ownership is wrong by default and this should have been run before the reboot:

sudo chown --recursive $USER:$USER ~/.config/xfce

Buut, as I mentioned, I so not use, so do not know Xfce, this is all just educated guessing.

Yeah… I am a bit lost I admit. So I am happy to get help here and for every advice I get.

If you did that logged in as user (not root) in a TTY
then the permissions are ok - no need to amend them.

1 Like

So do you have any ideas what the problem is causing? Could it be a virus or something?

No. No Idea.

very, very unlikely

But what you did should have restored most of the defaults.
… and it still doesn’t work/look strange?

I have no idea in that case - other than to also remove the cache folder
or rather it’s contents

Well, it’s obviously SOMETthing, even if we, humans, think it’s nothing. What the some thing is, is what should be determined.

As for virus. I suppose anything is possible, but I’ve never heard of something like this. Or actually any virus on Linux.

Ha you saved me @Nachlese. I deleted the cache content (~5GB) and now it works again! :tada:

Thank you both @Mirdarthos and @Nachlese!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.