Recovery from kernel update failure

On 20221016 I applied an update to LTS Kernel515 (Linux 5.15.72-1) with zfs and virtualbox dkms module support. After reboot virtualbox gave me errors related to no modules loaded. Later, while searching for hints on what to do I also tried a simple #zpool -list command which also indicated no modules found. After trying things like reloading the linux515 kernel using the GUI as well as mhwd-kernel, and then trying to load an earlier kernel, I did some investigating into what versions of linux515 kernel was in the core repositories and found the actual latest version if Linux 5.15.74 so no wonder I got this message in my /var/log.pacman.log “ERROR: Missing 5.15.72-1-MANJARO kernel headers for module zfs/2.1.6.”

While this is probably an error that needs to be fixed by whomever sent the automated update package, how can I now recover as to the best of my knowledge I cant get back to an earlier version of the header and *.zst file.

Hi @SmilingInSeattle, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

This sounds like the classic partial update due to unsynced mirrors.
The /usr/lib/modules/extramodules-5.15-MANJARO is a fixed folder, for extramodules for the Linux5.15 and that is where the linux515-zfs would install and load from.

Either from chroot system or from single user TTY, run this command:
sudo pacman-mirrors -f5 && sudo pacman -Syyu linux515-zfs

This problem was fixed in a single item update pushed by the update-manager. Consider the problem solved, but not by any of my actions!

1 Like

Your seer sync’s later, more slowly than thought…or something. Because with that update it fixed the problems you had that would’ve been fixed with @bogdancovaciu’s instructions.