Dolphin not remembering folder settings per folder on SMB folders, image large icons does not show the image

Hi all. I have recently switched from KDE Neon to Manjaro KDE Plasma (v5.24.6) for my daily driver system. It’s great so far. I have however a small annoying problem…

My dolphin settings are set to remember view (list/large icons) for each folder separately. Unfortunately, this seems not to work on any of SMB folders. Local folders are working fine. And thumbnails for picturs in SMB folders does not show the image on any SMB folders.

Do you have the same issues ? Is there some fix for this, or will it be corrected in the next update ? Thanks in advance!

Hi @MrPK, and welcome!

I believe that feature hasn’t been enabled for you, because mine is working fine.

To enable it:

  1. Open Dolphin and click on the :hamburger: menu.
  2. Go to the Configure.
  3. Select the Configure Dolphin menu item.
  4. In the window that pops up, ensure that Remember display style for each folder is selected on the GeneralBehavior tab.
  5. Apply and close the settings window.

In theory it should be good now.

See below to make sure we understand each other.

Hope it helps!

AFAIK per-folder settings are recorded in a file in each folder with settings differing from the default. Do you have write permissions on those folders?

Thanks for lighting fast reply :slight_smile: Yes, I did this. My problem is only on SMB folders, from my Synology NAS. Local folders work fine. I did correct my post just now.

Then it sounds like a permissions problem, like @maycne.sonahoz said:

Well, I have my login/password set for SMB, and that user have write permissions on my NAS. I did not set anything else special on Manjaro, just a standard setup from the ISO… And I can write files in those SMB folders, no problem here. Do I need to add some permissions in manjaro/samba ? In that case what, where ? Maybe I should mount those folders some other way, in fstab file ? Thanks.’

How are you accessing your SMB shares? Via the built-in smb:// protocol? Or the kernel cifs module method (i.e, mount, Smb4K, fstab, and/or systemd-mount)?

It’s preferable to use the latter method. This will also resolve issues with thumbnails and previews.

I use systemd-mounts (and automounts), which uses the cifs module method. It’s akin to fstab or manually mounting them. (Smb4K is a GUI, user-friendly alternative that uses the same underlying module.)

Your shares will be treated as any other folder; settings and all…

It will also yield better performance.

Even the permissions, as mentioned by @maycne.sonahoz.

Configure Dolphin... --> General, Previews tab --> Skip previews for remote files above:

Increase that limit to suit your data.

This is how I use it now: smb://nas2/home/Files/ Added shortcuts just by browsing the network. I will try to do as you wrote soon, thanks!

That was easy :slight_smile: I missed that setting, thanks a lot, one problem solved.

The only benefit to this method is convenience.

It’s slower than the native cifs kernel module, as well as lacks in certain features, as well as yields more problems (as you’re already discovering.)

Once you switch to accessing your SMB shares with the cifs module (mount, fstab, systemd, Smb4K), you’ll notice everything improves, including Dolphin remembering your folder settings. :wink:

1 Like

Mounted all my shares using fstab, works like a charm :upside_down_face: Thanks a lot for all help!

1 Like


Keep in mind there are still periphery considerations for your future usage, such as using sidebar shortsbuts, auto mounting/unmounting, using systemd-mount (with “automount”), instead of the fstab, boot issues (if the SMB network share is not available at bootup), and other specific cifs mount options.

The GVFS/KIO “convenience” or just using the built-in file manager’s protocol is slower, lacks some features, and can introduce other issues. Not sure why they don’t use cifs by default, after all these years. :shrug:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.