Cannot Switch to Most Recent Installed Kernel Via GRUB

My system is showing that both 6.1.69-1 and 6.6.8-2 are installed via the Kernel page in System Settings. 6.1.69-1 shows as “Running”. However, when I reboot, the Advanced options page in the GRUB menu only lists 5.15.144-1 and 6.1.69-1 - an older kernel that is not installed and the current running kernel, but not the latest kernel that I wish to run.

I assume that something is wrong with my GRUB menu and it’s not properly updating to offer the correct list of installed kernels? Can somebody walk me through how to fix this?


Try reinstalling 6.6.

pacman -S linux66{,-headers}

Not necessarily. Please post output of

cat /etc/default/grub

Was / is this a multiboot / linux system ?

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.
  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

Have you already :mag: for your problem in the forum ? (Wisdom lies in asking → listening → reading :wink: )

Yes, this is a dual boot (Win10/Manjaro) system, so I didn’t want to muck with GRUB without making sure I’m not going to clobber the entire system.

So might you be able to show us your /etc/default/grub ?

This could potentially explain why both 6.1.69-1 and 6.6.8-2 kernels are installed and you are always booting into 6.1.69-1.

1 Like

You already did :man_shrugging:
Not telling us beforehand is not helpfull :see_no_evil: → please share your inxi

inxi -Fazy
mhwd-kernel -li
pacman -Q linux

In the case of odd leftovers … theres a script to look for that…

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki:

Gong to be hard to set anything in the grub menu if it is hidden.
Change to:


Then run sudo update-grub

  Kernel: 6.1.69-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=ac2409e9-b990-460c-9388-a744776a2fcc rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Micro-Star product: MS-7B79 v: 3.0
    serial: <superuser required>
  Mobo: Micro-Star model: X470 GAMING PLUS MAX (MS-7B79) v: 3.0
    serial: <superuser required> UEFI: American Megatrends v: H.50
    date: 04/20/2020
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 2x16 MiB
  Speed (MHz): avg: 2389 high: 3965 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2207 2: 2058
    3: 2200 4: 2980 5: 2199 6: 2131 7: 3965 8: 2139 9: 2199 10: 2198 11: 2200
    12: 2200 bogomips: 86437
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_rstack_overflow mitigation: safe RET
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: Gigabyte driver: nvidia
    v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2023-11; EOL~2026-12-xx) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-2022 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 27:00.0 chip-ID: 10de:1e89 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.50x13.46")
    s-diag: 1108mm (43.63")
  Monitor-1: DP-4 pos: primary,top-left res: 2560x1440 hz: 144 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-2: HDMI-0 pos: bottom-r res: 1920x1080 hz: 60 dpi: 92
    size: 531x299mm (20.91x11.77") diag: 609mm (23.99") modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
    memory: 5.86 GiB
  API: Vulkan v: 1.3.274 layers: 1 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 2060 driver: nvidia v: 545.29.06
    device-ID: 10de:1e89 surfaces: xcb,xlib
  Device-1: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
    bus-ID: 27:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 29:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.1.69-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 4.43 TiB used: 46.96 GiB (1.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 2B2QEXE7 temp: 23.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:5 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 3B4QFXO7 temp: 23.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: A3T0 scheme: GPT
  ID-4: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: BB6Q scheme: MBR
  ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WD10EZEX-00KUWA0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: N/A serial: <filter> fw-rev: 1H15
    scheme: MBR
  ID-6: /dev/sdd maj-min: 8:48 vendor: Corsair model: Force GT
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 5.24 scheme: GPT
  ID-7: /dev/sde maj-min: 8:64 vendor: Western Digital model: WD10EAVS-00D7B1
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter>
    fw-rev: 1.75 scheme: MBR
  ID-1: / raw-size: 111.29 GiB size: 108.98 GiB (97.93%)
    used: 46.96 GiB (43.1%) fs: ext4 dev: /dev/sdd1 maj-min: 8:49
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 316 KiB (0.1%) fs: vfat dev: /dev/sdd2 maj-min: 8:50
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 15.62 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2
  System Temperatures: cpu: 52.8 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 303 Uptime: 1m wakeups: 0 Memory: total: 16 GiB
  available: 15.56 GiB used: 1.97 GiB (12.7%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1600 pm: pacman pkgs: 1571 libs: 414 tools: pamac pm: flatpak
  pkgs: 29 Shell: Zsh v: 5.9 default: Bash v: 5.2.21 running-in: yakuake
Currently running: 6.1.69-1-MANJARO (linux61)
The following kernels are installed in your system:
   * linux61
   * linux66
linux61 6.1.69-1

This is causing you will boot into the saved entry, which seems to boot kernel 6.1.

If you change to


as mentioned by @bedna you could better decide for each boot process what entry to boot.

Yeah, I must be missing something, because the GRUB menu displays when I reboot and I can select between Win10 or Manjaro…or choose advanced options, which lists two choices of kernel, but 6.6 is not among them. Am I somehow using a different GRUB menu than what’s in /etc/default/grub?

Because when I choose Advanced Options at boot time, it shows 5.15 and 6.1, but not 6.6. And 5.15 isn’t even installed, so it looks like I’m pulling some old version of grub and it isn’t getting updated.

Granted, I don’t know what I’m talking about, so I’m just trying to apply logic here.

A longshot, but could be possible you are somehow running of a grub on the windows boot partition.

What is the output of:

lsblk -f
cat /etc/fstab

And please, do not make multiple posts, if you need to add info, edit your old post and add the info.

NAME        FSTYPE FSVER LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─sda1      ntfs         WD-HGST-HDD 572B674853889C17                                    
└─sda2      swap   1                 1ae9a221-eae0-4e67-8492-409706963343                [SWAP]
└─sdb1      ntfs         840EVO      48BBB7380819D800                                    
└─sdc1      ntfs         WDBlueHDD   3676FF0B76FECB1F                                    
├─sdd1      ext4   1.0               ac2409e9-b990-460c-9388-a744776a2fcc   56.4G    43% /
└─sdd2      vfat   FAT32 MANJARO     C8EE-10AF                             510.7M     0% /boot/efi
└─sde1      ntfs         WD-EXTERNAL 72004FFD004FC737                                    
├─nvme0n1p1 ntfs         Recovery    0EBACBFEBACBDFF7                                    
├─nvme0n1p2 vfat   FAT32             4ECC-3C42                                           
└─nvme0n1p4 ntfs         970EVO      884CD28C4CD27502                                    
└─nvme1n1p2 ntfs         980SSD      C6D47D10D47D0449 
cat /etc/fstab                                                                                                             

UUID=C8EE-10AF                            /boot/efi      vfat    umask=0077 0 2
UUID=ac2409e9-b990-460c-9388-a744776a2fcc /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

UUID=1ae9a221-eae0-4e67-8492-409706963343 none swap defaults 0 0

Your ESP is on /dev/sdd2. Is your firmware booting using this ESP? I’m asking as you have several disks and could have easily disorganized it as nvme0n1p2 also looks like an ESP (for that other disk). The /etc/fstab setting is only relevant if the firmware uses the right ESP. If the firmware is correctly set, and the right boot entry is selected as well then I would restore the boot loader:

Like above says, I edited and added efibootmgr to see if there are multiple entries into manjaro.
You might have missed that edit. :slight_smile:

If you want to you can just try to run what wollie says, but that might not fix the issue if you are selecting the wrong manjaro efi in your bios.

Honestly, 50% of my neural processing power is being applied to try to solve the problem and the other 50% trying to figure out how to post such that I don’t upset you guys…

Do you really want the whole output of efibootmgr? It produces a huge wall of alphanumerics.